Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000245KdenliveMLTpublic2008-10-21 20:482008-11-12 22:22
Reporterjmpoure 
Assigned Toddennedy 
PriorityhighSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformDebianOSGNU/LinuxOS VersionSID
Product VersionRecent git 
Target Version0.7.0Fixed in Version0.7.0 
Summary0000245: Pixel Aspect Ration problem in PAL Wide profile
DescriptionMy family movies were shot in 16:19 in PAL. I have some AVI DV files. The AVI seem to carry the PAR or DAR information, as I can display them without problem in totem or any video player. But Kdenlive (MLT?) does not seem to read the PAR information.

See screenshots and example DV file (less than 1 second).
TagsNo tags attached.
Build/Install Method
Attached Filespng file icon Pal-wide-totem.png [^] (387,144 bytes) 2008-10-21 20:48
png file icon pal-wide-kdenlive.png [^] (173,594 bytes) 2008-10-21 20:48


? file icon palwide-test-dv.avi [^] (1,917,636 bytes) 2008-10-21 20:54
? file icon kbw.gdb.output.xAs30024 [^] (32,281 bytes) 2008-10-21 22:21

- Relationships
has duplicate 0000033closed 16/9 DV movies exported as 4/3 
related to 0000276closed Implement remaining advanced clip settings 
related to 0000313closed NTSC widescreen is compressed, looks 'skinny' (maybe related to bug 245) 

-  Notes
(0000540)
madsdyd (administrator)
2008-10-21 22:21

I can acknowledge this issue - it looks weird - appears as 4:3 with black borders, even though the DV PAL 16:9 profile is selected. (I am assuming the 16:19 from the reporter is a typo).

The clip appears correctly in kino.

Also, Kdenlive crashed when I tried to move the clip around on the timeline, and move the point within it (the current location of the point). Attaching crashlog shortly.
(0000541)
ddennedy (developer)
2008-10-21 22:30

The AVI does not contain the aspect info in a vprp chunk. Therefore, apps either assume 1.0 pixel aspect, which ffmpeg does, or they have to probe deeper into the elementary stream to determine that (what Kino does). It appears this file was made by avidemux. dvgrab and Kino do not write vprp chunk either. A workaround is to use: inigo libdv:somepaldv.avi -consumer westley:somepaldv.westley and then load the westley file into kdenlive. I will consider an enhancement to MLT's avformat producer to look into the DV if it is a DV file since DV is rather important.
(0000542)
ddennedy (developer)
2008-10-21 22:38

Another workaround to continue using the avformat producer is:
inigo palwide-test-dv.avi force_aspect_ratio=1.42 -consumer westley:palwide-test-dv.westley

It might be nice someday to right-click on a clip in kdenlive and change any number of incorrectly detected things including even and audio offset to correct a/v sync. Alas, MLT has no audio offset yet, but it is on my todo list.
(0000544)
jmpoure (developer)
2008-10-21 23:46

Very cool: inigo palwide-test-dv.avi force_aspect_ratio=1.42 -consumer westley:palwide-test-dv.westley

Thanks.
(0000552)
jmpoure (developer)
2008-10-22 10:54

MLT was updated to fix this issue. Now we need a fix on Kdenlive side.
(0000600)
administrator (administrator)
2008-10-23 01:36

Ok, I finally enabled the advanced tab in Kdenlive's clip properties dialog. You can now set force_aspect_ratio value from there. Feedback welcome (other properties like audio/video index and threads not yet implemented, I really need some sleep now :)
(0000601)
jmpoure (developer)
2008-10-23 08:26

Thanks a lot JB. Have a nice sleep ...
(0000859)
ddennedy (developer)
2008-11-07 19:37

It is legitimate to keep this open. The work done was simply to enable a manual workaround. Work must be done in MLT or FFmpeg to fix the detection of aspect in a DV AVI that does not have a vprp chunk.
(0000860)
ddennedy (developer)
2008-11-07 19:38

To me, this is a serious issue, and I will work on it over the weekend.
(0000861)
madsdyd (administrator)
2008-11-07 20:10

Great to hear that you will be working on it, Dan!

I have changed this to acknowledged and upped the priority. Will be great to get a proper fix, as setting the aspect ratio on my 60 clip files are ... a job better suited for a python script than the kdenlive gui :-)
(0000873)
ddennedy (developer)
2008-11-08 10:13

I added special support for DV in AVI in MLT Subversion tonight. Please update and test it. Recent changes in FFmpeg also caused a problem even with Raw DV, and this fixes that as well.
(0000880)
jmpoure (developer)
2008-11-08 17:06

Fully tested, works fine on PAL AVI DV WIDE.
(0000889)
madsdyd (administrator)
2008-11-08 18:19

Tested against MLT svn rev. 1227 - works very well! Tested also with dv 4/3 clips, which works as expected, and with rendering.

Closing bug.

And may I add that this was really nice to be done automatically!

- Issue History
Date Modified Username Field Change
2008-10-21 20:48 jmpoure New Issue
2008-10-21 20:48 jmpoure File Added: Pal-wide-totem.png
2008-10-21 20:48 jmpoure File Added: pal-wide-kdenlive.png
2008-10-21 20:49 jmpoure Summary Pixel ration in PAL Wide => Pixel Aspect Ration problem in PAL Wide profile
2008-10-21 20:50 jmpoure Description Updated
2008-10-21 20:54 jmpoure File Added: palwide-test-dv.avi
2008-10-21 20:54 jmpoure Description Updated
2008-10-21 21:06 jmpoure Description Updated
2008-10-21 22:21 madsdyd Note Added: 0000540
2008-10-21 22:21 madsdyd Status new => acknowledged
2008-10-21 22:21 madsdyd File Added: kbw.gdb.output.xAs30024
2008-10-21 22:30 ddennedy Note Added: 0000541
2008-10-21 22:38 ddennedy Note Added: 0000542
2008-10-21 23:46 jmpoure Note Added: 0000544
2008-10-22 10:54 jmpoure Note Added: 0000552
2008-10-23 00:26 madsdyd Target Version => 0.7.0
2008-10-23 01:36 administrator Note Added: 0000600
2008-10-23 08:26 jmpoure Note Added: 0000601
2008-10-23 08:27 jmpoure Status acknowledged => closed
2008-10-23 08:27 jmpoure Resolution open => fixed
2008-10-23 19:50 madsdyd Relationship added has duplicate 0000033
2008-10-23 21:10 madsdyd Relationship added related to 0000276
2008-11-07 19:37 ddennedy Assigned To => ddennedy
2008-11-07 19:37 ddennedy Note Added: 0000859
2008-11-07 19:37 ddennedy Status closed => feedback
2008-11-07 19:37 ddennedy Resolution fixed => reopened
2008-11-07 19:38 ddennedy Note Added: 0000860
2008-11-07 20:10 madsdyd Note Added: 0000861
2008-11-07 20:10 madsdyd Priority normal => high
2008-11-07 20:10 madsdyd Severity minor => major
2008-11-07 20:10 madsdyd Status feedback => acknowledged
2008-11-07 20:10 madsdyd Category User Interface => MLT
2008-11-07 20:10 madsdyd Product Version => Recent git
2008-11-08 10:13 ddennedy Note Added: 0000873
2008-11-08 17:06 jmpoure Note Added: 0000880
2008-11-08 18:19 madsdyd Note Added: 0000889
2008-11-08 18:19 madsdyd Status acknowledged => closed
2008-11-08 18:19 madsdyd Resolution reopened => fixed
2008-11-08 18:19 madsdyd Fixed in Version => Recent git
2008-11-08 19:10 madsdyd Relationship added related to 0000313
2008-11-12 22:22 madsdyd Fixed in Version Recent git => 0.7.0


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker