Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002516KdenliveUser Interfacepublic2012-02-10 11:502012-05-15 10:58
Reporterblume 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionno change required 
Platform32 bit intel and alikeOSUbuntuOS Version11.04
Product Version0.8.2.1 
Target VersionFixed in Version0.9 
Summary0002516: Crash on startup
DescriptionKdenlive crashes on startup from command line or using system menu. No gui is ever shown, the application crashes before that.
sudo kdenlive from command line does work.

Removing mlt-packages and reinstalling kdenlive (Issue 0002456) didn't help.
"sudo mv /usr/lib/mlt/libmltjackrack.so /usr/lib/mlt/libmltjackrack.so-removed" (Issue 0002439 and Issue 0002493) didn't help.

Here ist the crash information:
Application: Kdenlive (kdenlive), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76f8720 (LWP 3049))]

Thread 3 (Thread 0xb7333b70 (LWP 3051)):
#0 0x0011a416 in __kernel_vsyscall ()
#1 0x02586f76 in poll () from /lib/i386-linux-gnu/libc.so.6
0000002 0x0125784b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
0000003 0x012471af in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
0000004 0x0124792b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
0000005 0x01601304 in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
0000006 0x012702df in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
0000007 0x00120e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
0000008 0x0259573e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xb69d6b70 (LWP 3052)):
#0 0x0011a416 in __kernel_vsyscall ()
#1 0x00125834 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
0000002 0x002e7f0e in ?? () from /usr/lib/i386-linux-gnu/libgthread-2.0.so.0
0000003 0x0121a42c in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
0000004 0x0121af6d in g_async_queue_timed_pop () from /lib/i386-linux-gnu/libglib-2.0.so.0
0000005 0x01272980 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
0000006 0x012702df in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
0000007 0x00120e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
0000008 0x0259573e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb76f8720 (LWP 3049)):
[KCrash Handler]
0000007 0x02559875 in opendir () from /lib/i386-linux-gnu/libc.so.6
0000008 0x01aea425 in ?? () from /usr/lib/mlt/libmltjackrack.so-removed
0000009 0x01aea999 in plugin_mgr_new () from /usr/lib/mlt/libmltjackrack.so-removed
0000010 0x01ae6ba9 in mlt_register () from /usr/lib/mlt/libmltjackrack.so-removed
0000011 0x0030ba70 in mlt_repository_init () from /usr/lib/libmlt.so.4
0000012 0x0030affc in mlt_factory_init () from /usr/lib/libmlt.so.4
0000013 0x00bf96d5 in Mlt::Factory::init(char const*) () from /usr/lib/libmlt++.so.3
0000014 0x081cd7da in _start ()

Additional InformationI can work with sudo, but it looks different and it seems there are missing some features.

Anyway, kdenlive is a very good programm, you are doing a great job!!
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships
duplicate of 0002493feedbackj-b-m crash at startup 

-  Notes
(0007884)
blume (reporter)
2012-02-10 12:00

Maybe also interesting: the output of the terminal
I removed "/var/tmp/kdecache-reiner3" and "/tmp/kde-reiner3", but it didn't help.

reiner3@reiner3-laptop:~$ sudo kdenlive
[sudo] password for reiner3:
Error: "/var/tmp/kdecache-reiner3" is owned by uid 1000 instead of uid 0.
project monitor connected
clip monitor connected
QWidget::insertAction: Attempt to insert null action
QWidget::insertAction: Attempt to insert null action
Error: "/tmp/kde-reiner3" is owned by uid 1000 instead of uid 0.
^C
(0007885)
j-b-m (administrator)
2012-02-10 15:06

Simply renaming the libmltjackrack.so file does not work, you must delete it or move it to another folder if you want to disable it.

Which MLT version do you have? I wonder if you have an older mlt package still installed on your system that breaks things. Check which mlt / libmlt packages are installed.
(0007889)
blume (reporter)
2012-02-12 17:17

Thanks a lot, deleting libmltjackrack.so helped. No crashes any more.

libmlt++3
libmlt-data
libmlt4
melt

all -> 0.7.6-0ubuntu0~sunab~natty1

Bye,
Reiner

- Issue History
Date Modified Username Field Change
2012-02-10 11:50 blume New Issue
2012-02-10 12:00 blume Note Added: 0007884
2012-02-10 15:06 j-b-m Note Added: 0007885
2012-02-10 15:07 j-b-m Assigned To => j-b-m
2012-02-10 15:07 j-b-m Status new => feedback
2012-02-12 17:17 blume Note Added: 0007889
2012-02-12 17:17 blume Status feedback => assigned
2012-02-13 08:09 j-b-m Status assigned => resolved
2012-02-13 08:09 j-b-m Fixed in Version => Recent git
2012-02-13 08:09 j-b-m Resolution open => no change required
2012-02-15 09:43 j-b-m Relationship added duplicate of 0002493
2012-05-15 10:57 j-b-m Fixed in Version Recent git => 0.9
2012-05-15 10:58 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker