Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002543KdenliveUser Interfacepublic2012-03-14 08:202012-05-15 10:58
Reporterprogman32 
Assigned Toj-b-m 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformAMD64OSGentooOS Version10.0
Product Version0.8.2.1 
Target VersionFixed in Version0.9 
Summary0002543: Usability: Render profile selector confusing when only one profile exists under category.
DescriptionHeh, this little idiosyncrasy had me grepping my entire ~/.kde4 directory for a sign that kdenlive actually installed a render profiles I grabbed from the profile downloader. The issue is that if you only have one profile under a given category, the right panel in the render profile chooser disappears, leaving you with no idea which profile you're actually using. In my repro steps below I show what happens if I have exactly one "Custom" profile under the "Websites" target. When I click on the "Custom" category, there is absolutely no feedback that I have activated a profile. It looks like I'm just building a custom render profile (but most of the options are greyed out since I'm actually using a premade profile). Confusing to say the least.

I'm by no means scared of complicated UI (UI framework dev by trade, longtime cinelerra user), but like I said it took me around 15 minutes to figure out that kdenlive was simply collapsing categories. Maybe a bit of a lapse on my part, but my point stands.

I'd suggest always leaving the right list visible, so users can always see the description of the profile they're using. If it's possible to get arbitrarily deep nested profile categories, I'd strongly consider un-listbox-ifying the hierarchy and just using a tree view instead.
Steps To ReproduceThese steps are just to demonstrate the odd UI - they're by no means the only way to see the this behavior.

1) Clear out user render profiles in ~/.kde4/apps/kdenlive/export (makes repro simpler since we're on common ground).
2) Go to the render profile downloader. Install the YouTube 480p Optimized profile.
3) Enter the render profile selector (hit Render, select Render Project tab).
3) Select the "Web Sites" destination, then click on the "Custom" category.

Expected: Some sort of feedback that I'm using the "YouTube 480p Optimized" profile.
Actual: Right listbox disappears. For all intents and purposes, it looks like I'm using some sort of "Custom" profile, not "YouTube 480p Optimized"
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
(0007929)
j-b-m (administrator)
2012-03-14 17:15

Thanks. I just fixed the problem in git, now the right list is always visible.

- Issue History
Date Modified Username Field Change
2012-03-14 08:20 progman32 New Issue
2012-03-14 17:15 j-b-m Note Added: 0007929
2012-03-14 17:15 j-b-m Status new => resolved
2012-03-14 17:15 j-b-m Fixed in Version => Recent git
2012-03-14 17:15 j-b-m Resolution open => fixed
2012-03-14 17:15 j-b-m Assigned To => j-b-m
2012-05-15 10:57 j-b-m Fixed in Version Recent git => 0.9
2012-05-15 10:58 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker