Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002654KdenliveUser Interfacepublic2012-06-21 18:272013-01-28 19:50
Reporterevorster 
Assigned Tovpinon 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSLinuxOS Version3.2.20
Product VersionRecent git 
Target VersionFixed in Version0.9.4 
Summary0002654: Fade out from timeline with no time.
DescriptionAdding fade-out on the timeline adds a fade-out of 0 length, and not the selected time as is shown on the timeline.
Steps To ReproduceSelect a video clip on the timeline.
Hover mouse over end top corner to get the glowing green selector.
Drag selector to add fade-out.
Look at time duration for fade-out in clip properties.

Additional InformationThe fade out time is still adjustable in clip properties.
Looks like this is affecting fade to black as well, as it gets 0 time instead of it's default 1s.

This kdenlive was pulled from git on 15 Jun 2012.

TagsNo tags attached.
Build/Install MethodManual build from Git
Attached Files

- Relationships

-  Notes
(0008141)
norms2 (reporter)
2012-06-28 11:51

I can confirm this with latest sunab svn.

Select clip then double click Fade to Black and the duration graphic appears at the beginning of the clip.The fade to black duration in the effects stack, as already said, is set to zero but still adjustable from there.You then have two fade graphics on the clip (start and end). Save project and reload and it shows correctly. (no start graphic)
(0008142)
vpinon (administrator)
2012-06-30 00:13

Hi,
many fadeouts problems with git 4d988e (from jb on June 20) : sometimes drawn as fadeins on the timeline, sometime applying a volume effect on the whole track...
I have spent few hours tracing the latest changes on the topic, but am not well experienced in this kind of debug yet ;)
I will keep trying unless the "code master" finds a quick answer!
(0008143)
vpinon (administrator)
2012-06-30 12:52

I think I just fixed the problem in commit 9cac64de, please confirm?
(0008167)
eddrog (developer)
2012-07-23 10:22

Nop. I've compiled yesterday with recent git version. The problem is still there. If I have time today I'll take a closer look at it.
(0008173)
evorster (reporter)
2012-08-02 05:45

This works correctly again with the git from 29 Jul 2012
Thanks for fixing it!
(0008184)
eddrog (developer)
2012-08-05 10:47

Compiled again with recent mlt && kdenlive git version. For me the problem is still there. Try to debug whats still wrong.
(0008215)
vpinon (administrator)
2012-08-24 11:58

eddrog I assigned it to you as I can't reproduce the problem on my side ;-)
(0008225)
evorster (reporter)
2012-08-25 07:25

There seems to be two different issues here.
The one I reported, ie: just dragging a fade out on the clip in the timeline now works as expected.

However, if you right-click on a clip in the timeline and add fade-out, then it shows a "fade-in" graphic on the clip in the timeline. It also does not set a time. This is the same for fade-out, and fade to black.

In the past, a default time was set for fade-ins and outs, and also for fade to and from black. Currently adding these fades from the context menu does not add a time, even though the graphic on the clip in the timeline suggests otherwise.

Hope this clarifies some things?
I just pulled from git ( 25 August 2012 ) and this is the current state of this report.

Kind regards,
-Evert Vorster-
(0008226)
vpinon (administrator)
2012-08-25 07:34

OK now I understand & reproduced, having a look...
Thanks for clarification ;-)
(0008231)
vpinon (administrator)
2012-08-26 09:51

fixed in git 34f1721 (2012/08/26)
(0008232)
evorster (reporter)
2012-08-26 13:32

Confirmed fixed.
Both dragging in an audio fade on the timeline and adding fades from the context menu works properly with the git 34f1721

Thank you very much!
(0008252)
eddrog (developer)
2012-09-02 16:30

Sorry vpinon for the late response - I had vacations :-))

I compiled with recent git and can also confirm the fix. Thanx.

A lot of thanx to evoster for clarification.

- Issue History
Date Modified Username Field Change
2012-06-21 18:27 evorster New Issue
2012-06-28 11:51 norms2 Note Added: 0008141
2012-06-30 00:13 vpinon Note Added: 0008142
2012-06-30 12:52 vpinon Note Added: 0008143
2012-07-23 10:22 eddrog Note Added: 0008167
2012-08-02 05:45 evorster Note Added: 0008173
2012-08-05 10:47 eddrog Note Added: 0008184
2012-08-24 11:58 vpinon Assigned To => eddrog
2012-08-24 11:58 vpinon Status new => assigned
2012-08-24 11:58 vpinon Note Added: 0008215
2012-08-25 07:25 evorster Note Added: 0008225
2012-08-25 07:33 vpinon Assigned To eddrog => vpinon
2012-08-25 07:34 vpinon Note Added: 0008226
2012-08-26 09:51 vpinon Note Added: 0008231
2012-08-26 09:51 vpinon Status assigned => feedback
2012-08-26 13:32 evorster Note Added: 0008232
2012-08-26 13:32 evorster Status feedback => assigned
2012-08-26 16:19 vpinon Status assigned => resolved
2012-08-26 16:19 vpinon Resolution open => fixed
2012-09-02 16:30 eddrog Note Added: 0008252
2013-01-28 19:50 j-b-m Fixed in Version => 0.9.4
2013-01-28 19:50 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker