Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002655KdenliveMLTpublic2012-06-21 22:412013-01-28 19:50
Reporteroschonrock 
Assigned Toj-b-m 
PriorityurgentSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSUbuntu 64bitOS Version12.04
Product Version0.9.2 
Target VersionFixed in Version0.9.4 
Summary0002655: some frozen frames in clip when viewing in clip/project monitor and after render
Descriptionsaving now

Versions:
Camcorder profile: http://www.kdenlive.org/video-editor/panasonic-hx-wa10 [^]

using sunab/kdenlive-release

# dpkg -l kdenlive melt ffmpeg frei0r-plugins
ffmpeg 4:0.8.3-0ubunt
frei0r-plugins 1.3.0+git20120
kdenlive 0.9.2-0ubuntu0
melt 0.8.0-0ubuntu0
TagsNo tags attached.
Build/Install Method3rd party package
Attached Files

- Relationships

-  Notes
(0008134)
oschonrock (reporter)
2012-06-21 23:22
edited on: 2012-06-22 15:08

sorry..can't seem to edit main bug now..so will add detail in notes:

In making a medium size project I noticed that after some cuts there would be some frozen frames (ie same frame repeated multiple times) in the clip after the cut.

Reduced the project to just one clip and then created brand new project with just that same clip. Issue still present. ie clip shows same frame near start of clip for 5-10 frames.
Issue is visible in clip monitor, in project monitor (after adding clip to start of timeline) and after render using default h264 profile.

If I enable proxy clips the issue dissappears (or at least reduces to the very first frame).

proxy clip config is:
-f mpegts -acodec libmp3lame -ac 2 -ab 128k -ar 48000 -vcodec mpeg2video -g 5 -deinterlace -s 960x540 -vb 8000k

playing the same clip from command-line with ffplay, melt, totem, mplayer does not show frozen frames

the clip I am using is:
http://www.realtsp.com/download/IMGA0191.MP4 [^]
this clip also does it:
http://www.realtsp.com/download/IMGA0156.MP4 [^]

Here is the trivial projcet:
http://www.realtsp.com/download/Debug.kdenlive [^]

(0008135)
oschonrock (reporter)
2012-06-22 11:24
edited on: 2012-06-22 11:25

tested on different machine running ubuntu 32bit 12.04 with these versions:

ffmpeg 5:201111031644-git-1 (self compiled..)
frei0r-plugins 1.3.0+git20120409.5f719f20-0ubuntu0~sunab~oneiric1
kdenlive 0.8.3+git20120420.f41ee253-0ubuntu0~sunab~oneiric1
melt 0.7.9+git20120420.3e2c5773-0ubuntu0~sunab~oneiric1

same issue persists and is resolved (to 1st frame pause) if clip is proxied using default proxy settings.

Given this is kdenlive 0.8.3, could this be related to some lib change in ubuntu 12.04, because these clips were behaving fine earlier in the year..?

What other libs could this be related to, I could provide versions in both 11.10 and 12.04 and test in both potentially.

(0008136)
oschonrock (reporter)
2012-06-22 14:33
edited on: 2012-06-22 14:38

ok..have now tested on an ubuntu 11.10 machine and the result is different, ie the problem does not exist. Clips plays perfectly in clip monitor and in project monitor on timeline.

Also I have confirmed that the playing of proxy clips above is not a 100% "workaround" as it is still frozen for exactly 1 frame. In something like totem or in kdenlive on the 11.10 machine the 1st 2 frames are different..ie as soon you hit "right arrow" from first frame, you get movement (see the flag blowing in wind at top of IMGA0191.MP4 test clip linked to above).

On ubuntu 12.04 the un-proxied clip is "stuck" on 1st frame for about 5 frames. With proxied-clip it is "stuck" for 1 frame (ie the 1st 2 frames look identical).

Here are the version of the working 11.10 machine:

ffmpeg 4:0.7.6-0ubuntu0.11.10.1
frei0r-plugins 1.3.0+git20120530.dcb0dd04-0ubuntu0~sunab~oneiric1
kdenlive 0.9.2-0ubuntu0~sunab~oneiric1
melt 0.7.8-0ubuntu0~sunab~oneiric3

so which lib could it be? ffmpeg or something else? or maybe its a bug in mlt 0.8.0, because the 11.10 machine seems to be running 0.7.8 which is the max version that the sunab/kdenlive-release repo provide for 11.10 oneirix

Need some help on how to narrow it down further...

(0008137)
oschonrock (reporter)
2012-06-22 14:59

ok..another test ubuntu 12.04 with sunab/kdenlive-svn

same problem and behaviour as ubuntu 12.04 with sunab/kdenlive-release

versions:

ffmpeg 4:0.8.3-0ubuntu0.12.04.1
frei0r-plugins 1.3.0+git20120612.b6528c5f-0ubuntu0~sunab~precise1
kdenlive 0.9.3+git20120621.4d988e59-0ubuntu0~sunab~precise1
melt 0.8.1+git20120621.9358509a-0ubuntu0~sunab~precise1
(0008138)
oschonrock (reporter)
2012-06-22 15:03

so..not being an expert on the interaction of the lib supporting kdenlive my current guess is, that the issue could be between:

ffmpeg 0.7.6 => 0.8.3

or

melt 0.7.8 => 0.7.9
(0008206)
oschonrock (reporter)
2012-08-23 13:31
edited on: 2012-08-23 13:33

I have just rested with the following and the issue now seems resolved:

ffmpeg           4:0.8.3-0ubuntu0.12.04.1
frei0r-plugins   1.3.0+git20120612.b6528c5f-0ubuntu0~sunab~precise1
kdenlive         0.9.3+git20120815.72a8dbe8-0ubuntu0~sunab~precise1
kdenlive-data    0.9.3+git20120815.72a8dbe8-0ubuntu0~sunab~precise1
libmlt++3        0.8.1+git20120817.99d95a01-0ubuntu0~sunab~precise1
libmlt-data      0.8.1+git20120817.99d95a01-0ubuntu0~sunab~precise1
libmlt5          0.8.1+git20120817.99d95a01-0ubuntu0~sunab~precise1
melt             0.8.1+git20120817.99d95a01-0ubuntu0~sunab~precise1


I am unable to update bug status...but consider this resolved with latest git packages on ubuntu 12.04 64 bit. I will update here if it re-occurs


- Issue History
Date Modified Username Field Change
2012-06-21 22:41 oschonrock New Issue
2012-06-21 23:22 oschonrock Note Added: 0008134
2012-06-21 23:22 oschonrock Note Edited: 0008134 View Revisions
2012-06-22 11:24 oschonrock Note Added: 0008135
2012-06-22 11:24 oschonrock Note Edited: 0008135 View Revisions
2012-06-22 11:25 oschonrock Note Edited: 0008135 View Revisions
2012-06-22 14:33 oschonrock Note Added: 0008136
2012-06-22 14:38 oschonrock Note Edited: 0008136 View Revisions
2012-06-22 14:59 oschonrock Note Added: 0008137
2012-06-22 15:03 oschonrock Note Added: 0008138
2012-06-22 15:08 oschonrock Note Edited: 0008134 View Revisions
2012-08-23 13:31 oschonrock Note Added: 0008206
2012-08-23 13:33 oschonrock Note Edited: 0008206 View Revisions
2012-09-01 21:10 j-b-m Status new => resolved
2012-09-01 21:10 j-b-m Fixed in Version => Recent git
2012-09-01 21:10 j-b-m Resolution open => fixed
2012-09-01 21:10 j-b-m Assigned To => j-b-m
2013-01-28 19:50 j-b-m Fixed in Version Recent git => 0.9.4
2013-01-28 19:50 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker