Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002671KdenliveMLTpublic2012-07-03 23:002014-05-09 00:19
Reportermrbumpy409 
Assigned Tovpinon 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
Platformamd64OSKubuntuOS Version12.04
Product VersionRecent git 
Target VersionFixed in Version 
Summary0002671: split audio sometimes out of sync with video
DescriptionAfter using "split audio" on a video clip, the audio may or may not be in sync with the video depending on where playback starts.
Steps To Reproduce1. Add a clip to a Kdenlive project. I'm not sure if this bug affects all video files, so you may want to try it with the video file attached to this bug report.
2. Play the project from the beginning, frequently starting and stopping playback using the spacebar. The video and audio always remain in sync.
3. Now, use "split audio" on the clip.
4. Play the project from the beginning, frequently starting and stopping playback using the spacebar. The video and audio do not remain in sync. Using the attached video file, each time you stop and start the file using the spacebar, you hear the voice say "one", even though the numbers spoken should increment throughout the video.
Additional InformationUsing kdenlive version 0.9.3+git20120701.53f9c1b9-0ubuntu0~sunab~precise1 from the SVN PPA.
TagsNo tags attached.
Build/Install Method3rd party package
Attached Filesgz file icon counting.tar.gz [^] (574,565 bytes) 2012-07-03 23:00

- Relationships
duplicate of 0002853new Preview audio/video sync problem when splitting audio in mp4 and flv 
duplicate of 0002694feedbackddennedy Video sync drifts further behind audio in renders, while preview playback syncs perfectly 

-  Notes
(0008425)
walxo (reporter)
2012-10-01 00:17

Very annoying bug
(0008680)
rybinin (reporter)
2012-11-30 04:19

Still no response for that? No bug fixing? I have 0.9.2 version and this bug is already there. I have to say I need to split audio for postproduction editing and I cannot do it. That's silly way to manual correct the out-sync audio issue. Not possible. I use normal HDV files, nothing special. There are many problems in split-audio function. Pity, it was good in previous versions. But now? Recently I had a problem with video transition when audio was splitted. Now out of sync audio/video problem when audio is splitted... I don't know what to do.
(0008681)
eddrog (developer)
2012-11-30 09:38
edited on: 2012-11-30 09:39

Still a problem in recent git? Please try it and give some feedback because we fixed some issues in split audio area.

You are right the split-audio function sometimes does not work how expected and has some limitations. The code is pretty complex and should be redesigned. This is done in a complete rewrite of the code in the refactoring tree. But it can take some time. Until this we just fix show stopper bugs.

Is this bug reproducable with other formats like e.g. dnxhd?

>>> There are many problems in split-audio function <<<

Please tell exactly what the problem is and create a ticket per problem. It doesn't help if you say it in general.

(0008693)
javsalgar (reporter)
2012-12-03 16:15

In my case it happens with mp4 and flv.
(0008694)
rybinin (reporter)
2012-12-03 21:57
edited on: 2012-12-03 22:00

I have to correct my post. I upgraded to Kubuntu 12.10 and kdenlive didn't work. I did many things (unfortunately I didn't exactly what I did) but it seems I have MLT 0.8.0 now (I thinkI had newer MLT before, I tried many possibilities) And kdenlive 0.9.2 and it seems to work fine. But I have to say very creepy behaviour that occured to me after this upgrade. I have edited a movie and I couldn't have splited audio without the audio shift, after the upgrade, I could have, but ALL EDITS WERE CCA 1 SECOND SHIFTED!!! (I think the same number as the audio shift) I had to manualy shifted EVERY cut, it was pain in the ass! I hope it will be OK after new upgrade of kdenlive (new version of kdenlive will be out soon).

(0008871)
CrystalGamma (reporter)
2012-12-25 13:44

It seems like I have this problem as well ... As I had "Automatically split audio" enabled (for some reason I don't remember) I didn't even think of the splitting being the problem.
This bug happened to me so far with avi and mkv as well. (MLT 0.8.6 on up-to-date Arch Linux)
(0009101)
vpinon (administrator)
2013-01-18 19:29

MLT was recently updated to fix similar bug 2694, could you check if you problem is solved as well?
(0009107)
LucN31 (reporter)
2013-01-19 12:34

Using
Kdenlive
Version 0.9.3 (rev. v0.9.2-415-g91ea035)
Using KDE Development Platform 4.8.4 (4.8.4).

I test today an avi (mp4) video : 1/ playback is correct even I split audio, 2/ rendering video synchro problem is not present in mplayer or xine but it remains in vlc.

I don't know how sync is made but I have a warning in 2ManDVD about sync between video and audio with all kdenlive rendering output (not present with original media).
(0009108)
rybinin (reporter)
2013-01-19 13:32

I don't know it that helps, hope it will. But I realized that not only render problems, but also preview problems, are present when kdenlive works with newer mlt. When mlt 0.8.0 is used, everything is ok, no out of sync problems present.
(0009309)
mrbumpy409 (reporter)
2013-02-21 06:24

Testing with Kdenlive 0.9.4 and mlt 0.8.8-1+swfdec1~precise1, I can no longer reproduce this bug using the steps in my original report. I guess it can probably be closed as fixed.

- Issue History
Date Modified Username Field Change
2012-07-03 23:00 mrbumpy409 New Issue
2012-07-03 23:00 mrbumpy409 File Added: counting.tar.gz
2012-10-01 00:17 walxo Note Added: 0008425
2012-11-30 04:19 rybinin Note Added: 0008680
2012-11-30 09:38 eddrog Note Added: 0008681
2012-11-30 09:39 eddrog Note Edited: 0008681 View Revisions
2012-12-03 16:15 javsalgar Note Added: 0008693
2012-12-03 16:19 eddrog Relationship added duplicate of 0002853
2012-12-03 21:57 rybinin Note Added: 0008694
2012-12-03 22:00 rybinin Note Edited: 0008694 View Revisions
2012-12-03 22:00 rybinin Note Edited: 0008694 View Revisions
2012-12-13 22:55 vpinon Relationship added duplicate of 0002694
2012-12-25 13:44 CrystalGamma Note Added: 0008871
2013-01-18 19:29 vpinon Note Added: 0009101
2013-01-18 19:29 vpinon Assigned To => vpinon
2013-01-18 19:29 vpinon Status new => feedback
2013-01-19 12:34 LucN31 Note Added: 0009107
2013-01-19 13:32 rybinin Note Added: 0009108
2013-02-21 06:24 mrbumpy409 Note Added: 0009309
2013-02-21 06:24 mrbumpy409 Status feedback => assigned
2014-05-09 00:19 vpinon Status assigned => resolved
2014-05-09 00:19 vpinon Resolution open => fixed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker