Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002683KdenliveUser Interfacepublic2012-07-18 14:202014-08-05 11:56
Reportergingerling 
Assigned Tovpinon 
PriorityurgentSeverityblockReproducibilityalways
StatusresolvedResolutionfixed 
Platform32bit Pentium(R) Dual-Core OSUbuntu OS Version12.04 LTS
Product Version0.9.2 
Target VersionFixed in Version0.9.6 
Summary0002683: Audio late-start in playback AND rendering: continous problem
DescriptionAudio does not play for first few seconds of each clip on playback - and this problem persists after rendering. When audio does "kick in" its usually in perfect sync. Its sounds as if its been muted for a few seconds, then turned on. If I have 3 clips in a row, this happens 3 times in a row.

This does not usually apply to my music tracks in mp3 format.

I am beginning to suspect that the issue lies with my actual clips. This said, they play fine from melt in command line etc (steps 1-5 http://www.kdenlive.org/bug-reports [^] all fine) so if there is any way to resolve the issue with using them in kdenlive i would be extremely grateful.
Steps To ReproduceOpen new blank project, put in clips, play back. Issue affects playback when from beginning of project or from any given point in the project - but sometimes, if you try a few times, it plays. If the project is rendered, then this will continue after rendering, so you can see seamless video with audio turning off and on where the clips were.

NB: I made the second video http://www.ethical-pets.co.uk/blog/2012/07/on-meeting-our-customers/ [^] here with these same clips. I am currently working on some smaller videos of just 1 min, by reusing these same clips, to go with the products on my website. The original interview had separate sound, I put them together, rendered that as one big file, then broke it up into individual clips with just one point of conversation in, and rendered those too. Then made several more files and rendered to fit together all the parts. My computer can't really handle lots of big clips in one file as I have only 2mb of ram. As you can see from the videos, I am producing quite good videos without much fore knowledge of the technology. I know its a techies nightmare, I do tend to just figure things out as I go along...
Additional InformationI discovered this problem when installing a new/separate os for video editing - I usually use crunchbang, but have found you can't install MLT on that os without causing huge dependency issues. Kdenlive still seems to work fine ish though, its just a bit buggy - so I decided to try some new os's for video.

I can therefore say that this problem has persisted across several os's such as avlinux with real time kernel threading AND on Kxstdio with Jack feeding in via pulse audio. Its also on ubuntu, kubuntu, ubuntu studio and dream studio. I am pretty sure its not a "latency" issue.

I had come to the conclusion that the issue must be with the clips themselves, which were made on my crunchbang os without MLT installed. However, they can be played with out any issues using melt or ffmpeg from comandline. Also, when I use the same clips on my ibm/lenovo thinkpad laptop, running crunchbang, there isn't so much of an issue. Its still buggy though.

I have now installed ubuntu, as from looking at your downloads page, this is really the only way to get the recommended versions. I have used the ppa. Ubuntu is installed on a logical partition, its the third os on this computer. This is the command line output when the bug occurs.

anna@ethicalpets:~$ gdb kdenlive
GNU gdb (Ubuntu/Linaro 7.4-2012.04-0ubuntu2) 7.4-2012.04
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html> [^]
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.launchpad.net/gdb-linaro/>... [^]
Reading symbols from /usr/bin/kdenlive...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/kdenlive
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[New Thread 0xb2d2db40 (LWP 3316)]
[New Thread 0xb23ffb40 (LWP 3317)]
[New Thread 0xb19ffb40 (LWP 3318)]
QWidget::insertAction: Attempt to insert null action
QWidget::insertAction: Attempt to insert null action
[New Thread 0xad30bb40 (LWP 3322)]
[New Thread 0xacb0ab40 (LWP 3323)]
[Thread 0xb19ffb40 (LWP 3318) exited]
[New Thread 0xb19ffb40 (LWP 3336)]
[Thread 0xad30bb40 (LWP 3322) exited]
[Thread 0xacb0ab40 (LWP 3323) exited]
[New Thread 0xacb0ab40 (LWP 3337)]
[New Thread 0xad30bb40 (LWP 3338)]
[mpeg @ 0xb1006880] max_analyze_duration reached
[mpeg @ 0xad7c6860] max_analyze_duration reached
[mpeg @ 0xb1009d00] max_analyze_duration reached
[mpeg @ 0xb10301c0] max_analyze_duration reached
[mpeg @ 0xab0c6240] max_analyze_duration reached
[mpeg @ 0xab09e9a0] max_analyze_duration reached
[New Thread 0xaafffb40 (LWP 3339)]
[New Thread 0xaa7feb40 (LWP 3340)]
[New Thread 0xa9ffdb40 (LWP 3341)]
[mpeg @ 0x92f7900] max_analyze_duration reached
[mpeg @ 0x9497240] max_analyze_duration reached
[mpeg @ 0x9497740] max_analyze_duration reached
[Thread 0xacb0ab40 (LWP 3337) exited]
[Thread 0xad30bb40 (LWP 3338) exited]
[New Thread 0xad30bb40 (LWP 3342)]
[New Thread 0xacb0ab40 (LWP 3343)]
[mpeg @ 0x945b400] max_analyze_duration reached
[mpeg @ 0x94bb7a0] max_analyze_duration reached
[mpeg @ 0x987e440] max_analyze_duration reached
[New Thread 0xa606db40 (LWP 3344)]
[New Thread 0xa586cb40 (LWP 3345)]
[New Thread 0xa506bb40 (LWP 3346)]
[Thread 0xad30bb40 (LWP 3342) exited]
[Thread 0xacb0ab40 (LWP 3343) exited]
[New Thread 0xacb0ab40 (LWP 3347)]
[New Thread 0xad30bb40 (LWP 3348)]
[Thread 0xacb0ab40 (LWP 3347) exited]
[New Thread 0xacb0ab40 (LWP 3349)]
[Thread 0xacb0ab40 (LWP 3349) exited]
[New Thread 0xacb0ab40 (LWP 3350)]
[New Thread 0xa37fdb40 (LWP 3351)]
[mp2 @ 0xab0c02c0] Header missing
[New Thread 0x9eb79b40 (LWP 3352)]
[mp2 @ 0xab0c02c0] Header missing
[New Thread 0x9db76b40 (LWP 3353)]
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[mp2 @ 0xab0c02c0] Header missing
[Thread 0x9db76b40 (LWP 3353) exited]
[Thread 0xa37fdb40 (LWP 3351) exited]
[Thread 0xacb0ab40 (LWP 3350) exited]
[Thread 0x9eb79b40 (LWP 3352) exited]
[Thread 0xad30bb40 (LWP 3348) exited]
kdenlive(3313)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
[Thread 0xa506bb40 (LWP 3346) exited]
[Thread 0xa606db40 (LWP 3344) exited]
[Thread 0xa586cb40 (LWP 3345) exited]
[Thread 0xaafffb40 (LWP 3339) exited]
[Thread 0xa9ffdb40 (LWP 3341) exited]
[Thread 0xaa7feb40 (LWP 3340) exited]
[Thread 0xb19ffb40 (LWP 3336) exited]
[Thread 0xb2d2db40 (LWP 3316) exited]
[Thread 0xb23ffb40 (LWP 3317) exited]
[Inferior 1 (process 3313) exited normally]
(gdb)
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files? file icon my_name_is.ogv [^] (14,367,423 bytes) 2012-08-04 16:43

- Relationships

-  Notes
(0008182)
gingerling (developer)
2012-08-04 16:38

http://www.kdenlive.org/forum/sound-problem-very-persistent#comment-18501 [^]

hi, i have this problem again, see description above. I thought it was just an issue with the files I was using at the time, which may not have rendered properly due to a mlt problem, but now i know my mlt is fine and the issue is reocuring! Is there anything about the way I am using kdenlive which could cause this? for example, if I render a clip without saving a kdenlive file the kdelive file I made it in, could that cause this?
(0010156)
vpinon (administrator)
2014-08-05 11:56

obsolete

- Issue History
Date Modified Username Field Change
2012-07-18 14:20 gingerling New Issue
2012-08-04 16:38 gingerling Note Added: 0008182
2012-08-04 16:43 gingerling File Added: my_name_is.ogv
2014-08-05 11:56 vpinon Note Added: 0010156
2014-08-05 11:56 vpinon Status new => resolved
2014-08-05 11:56 vpinon Fixed in Version => 0.9.6
2014-08-05 11:56 vpinon Resolution open => fixed
2014-08-05 11:56 vpinon Assigned To => vpinon


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker