Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000271KdenliveUser Interfacepublic2008-10-23 20:132008-12-29 15:37
Reportermadsdyd 
Assigned To 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version0.7.1Fixed in Version0.7.1 
Summary0000271: Spacer tool: add and remove space in timeline
DescriptionOn the roadmap for kdenlive 0.7.1: http://www.kdenlive.org/roadmap [^]

Implement the spacer tool known from kdenlive 0.5 to move portions of the timeline back and forth.
TagsNo tags attached.
Build/Install Method
Attached Files? file icon capture0004.ogv [^] (3,707,201 bytes) 2008-12-20 20:18
? file icon 271-1911-a+b.ogv [^] (744,891 bytes) 2008-12-23 11:12
? file icon 271-1911-c.ogv [^] (996,381 bytes) 2008-12-23 11:26

- Relationships
has duplicate 0000483closedmadsdyd Spacer tool don't move all clips 
has duplicate 0000498closedmadsdyd moving the entire clips to the right with the spacer tool leaves transitions behind 
related to 0000188acknowledged changing clip speed is faulty/unintuitive 
related to 0000317closedGranjow Add default shortcut keys to select Razor/Select/Spacer tool 

-  Notes
(0001466)
madsdyd (administrator)
2008-11-30 21:48

There has been some checkins to adress this issue (latest 2738).

However, I think there are some issues with the current functionality, that needs to be adressed (tested in 2740)

Two ways to insert and remove space has been added, and they behave slightly differently (not neccesseraly a problem, but I'll have to describe them separately). One is using the context menu on the timeline/track, another is using the spacer tool.

Using the *context menu*:

Remove space: This seems to only to want to remove space in the _start_ of a track (or group of tracks). On e.g. a track with three clips, I am not able to remove the space (using the tool) between clip 2 and 3?

Insert space: Works as expected.

Using the *tool*:

Inserting space: Seems to be working as expected (see below for a general comment).

Removing space: This is flawed: If you have a track with a lot of space, then some clips, say something like this:

[space1][clip1][space2][clip2][space3][clip3]

and you use the tool to try to remove [space2], you can actually drag the cursor left of [clip1], and reposition the sequence [clip2][space3][clip3] left of [clip1], getting a result like this:

[clip2][space3][clip3][some residual of space1][clip1]

This should not happen, IMHO: that is really a multi-select-move, not a space-removal.

Generel comment: I would expect it to be easier to keep the relative position of clips on different tracks. As it is now, it seems you can actually only keep the relative position of clips when *inserting* space, using the *context menu* (on all tracks). There seems to be no way of keeping them using the tool, and not at all when removing space. I think by default the tool should work on all tracks, perhaps ctrl+the tool could work on a single track or something. But default should be all tracks (and transitions/effects/whatever).

Also: I would recommend adding a default shortcut to use the spacer tool. Not sure which though.
(0001472)
cinephiliac (updater)
2008-12-01 00:38

Not having used the spacer tool before in it's pre-0.7 form I find it tricky to comment on how it should / should not work. I would like to suggest regarding the keyboard shotcuts, though. I'd like to propose:
, for the spacer tool
. for select
/ for the razor tool (which really should be called cut, as the icon is not a razor)

The icons are easy for anyone in any language to understand and remember. By choosing the three unusual keys, in a similar position on the keyboard to where they are on screen, in the same order as the icons, we make it very easy for anyone of any language to remember. Also a slash for cut/razor visually makes sense.
(0001515)
cinephiliac (updater)
2008-12-03 20:03

After looking at comments in 0000417, obviously ,./ don't work for all keyboards. It is still worth considering that while R may be good for Razor in English, that in other languages there's a good chance that the tool may not have an "R" anywhere in the name.
(0001792)
madsdyd (administrator)
2008-12-18 15:00

svn rev. 2778 has some changes, that I will soon check.
(0001826)
madsdyd (administrator)
2008-12-20 20:16

The commits in 2778 appears to have wastly improved the overall "feel" of the spacer tool. This is tested with svn rev. 2810.

Some minor issues seems to remain:

- The context "remove space" tool seems unreliable when removing space between clips 1 and 2, and 2 and 3, and appears to lack an "undo"? It seems an "remove space" entry is inserted, which would be better to be named "remove space". If often says "You must be in an empty space to remove space", with a time information that is clearly in empty space.

- Using the spacer tool is very nice now. However, it is possibly, mostly if dragging quickly to the left, to get a varying amount of space between the clips, in situations where I would have expected no space to remain.

- I made the space tool "hang" at one point (my guess is some kind of loop, as CPU usage skyrocketed). Tooks some fiddling around - and I forgot to attach a gdb to the process....

I have tried to create a screengrab with some of my issues, but I am afraid it has not been very good. First I remove space using the context menu, with a surprising result. Then I do it again, nothing happens. Then I use the tool, but some space is "left behind".
(0001827)
madsdyd (administrator)
2008-12-20 20:21

The first "remove space" in the above should have read "insert space"
(0001828)
madsdyd (administrator)
2008-12-20 20:22

Reminder sent to: administrator

Hi jb. Finally had time to look at 271 (spacer tool). Some minor issues still remain, I am afraid.
(0001833)
xzhayon (developer)
2008-12-21 03:06

also: if you have the spacer tool selected and create a new project, its button on the bottom bar remains selected, but you get the usual pointer tool
(0001856)
madsdyd (administrator)
2008-12-21 12:39

Some comments from 498 (duplicate):

nadavkav: moving the entire clips to the right with the spacer tool leaves transitions behind
 and i get the clips without the transitions. undoing the move start to mess up the entire
 project and i have to start all over again.

xzhayon: i get this issue moving the clips both on the right or on the left, what makes the difference is if you're clicking on the right of the transition (bug) or over/below/on its left (correct behavior)
(0001858)
madsdyd (administrator)
2008-12-21 12:41

Reminder sent to: nadavkav, xzhayon

nadavkav, xzhayon: I have subscribed you to this bug, after "resolving" 498.
(0001892)
madsdyd (administrator)
2008-12-22 18:45

svn rev 2817 fix the minor issue in 1833. (Untested, but fix looks trivial).
(0001911)
madsdyd (administrator)
2008-12-23 11:11

Svn rev 2818 contains some updates. However, I still think some minor flaws are present.

Using the spacer tool:

a) It is possibly to drag left of a not-influenced clip, if there is room.
b) It is almost always "hard" to eliminate all space left of a dragged sequence.
c) With dragging on multiple tracks, a clip on track 0, will block left dragging clips on track 1.

Context:
d) It is possibly to get the context tool into a situation where it says "You must be in an empty space to remove space", where the cursor clearly *is* in empty space.

Both
d) The undo-stack gets the words "Insert space" in all cases. It should either be able to distinguesh (e.g. "Remove space" for the context removals, "Insert space" for the context insertions), or use a generic term, such as "Adjust space" First option preferred.

I will try to create screengrabs of the various problems.
(0001913)
madsdyd (administrator)
2008-12-23 11:30

OK, attached screengrabs for comment 1911, a,b and c.

A note for b: This is actually the most serious issue with the spacer tool. It is frustrating to have to zoom in to remove tiny sections of space. Given that "snaps" work so well for the rest of kdenlive, it seems weird/broken that it should not sort of "snap" to the clips, when using the spacer tool

A note for c: I would like to be able to drag until a clip is "blocking" another clip, not the bounding box of the clips.

Oh, and the last d) in 1911 should have been an e, of course. Wont be doing a grab for that, because it is trivial to reproduce.
(0001914)
madsdyd (administrator)
2008-12-23 11:36

I can not reliable reproduce issue d) from 1911, but it did happen at one time. :-(
(0001916)
madsdyd (administrator)
2008-12-23 12:17

OK, issue e) from 1911 has been fixed in svn commit 2819. Thank you.
(0001939)
madsdyd (administrator)
2008-12-26 11:52

Svn rev 2821 fixes point b and c. Feels very very smooth.

I am unable to reliably reproduce d). e) has been fixed.

This leaves issue a), the thing about moving left of undragged clips. Now, when b) and c) works, it no longer "feels" like a problem that you can move left of unselected clips. It actually feels like more of a feature.

I am very content with this functionality and is happy to declare it resolved!

- Issue History
Date Modified Username Field Change
2008-10-23 20:13 madsdyd New Issue
2008-10-23 20:14 madsdyd Note Added: 0000632
2008-10-23 20:14 madsdyd Status new => acknowledged
2008-10-23 20:18 madsdyd Note Deleted: 0000632
2008-11-08 17:59 madsdyd Relationship added related to 0000188
2008-11-30 21:30 madsdyd Relationship added related to 0000317
2008-11-30 21:48 madsdyd Note Added: 0001466
2008-12-01 00:38 cinephiliac Note Added: 0001472
2008-12-03 20:03 cinephiliac Note Added: 0001515
2008-12-18 15:00 madsdyd Relationship added has duplicate 0000483
2008-12-18 15:00 madsdyd Note Added: 0001792
2008-12-20 20:16 madsdyd Note Added: 0001826
2008-12-20 20:18 madsdyd File Added: capture0004.ogv
2008-12-20 20:21 madsdyd Note Added: 0001827
2008-12-20 20:22 madsdyd Note Added: 0001828
2008-12-21 03:06 xzhayon Note Added: 0001833
2008-12-21 12:39 madsdyd Note Added: 0001856
2008-12-21 12:39 madsdyd Relationship added has duplicate 0000498
2008-12-21 12:41 madsdyd Note Added: 0001858
2008-12-22 18:45 madsdyd Note Added: 0001892
2008-12-23 11:11 madsdyd Note Added: 0001911
2008-12-23 11:12 madsdyd File Added: 271-1911-a+b.ogv
2008-12-23 11:26 madsdyd File Added: 271-1911-c.ogv
2008-12-23 11:30 madsdyd Note Added: 0001913
2008-12-23 11:36 madsdyd Note Added: 0001914
2008-12-23 12:17 madsdyd Note Added: 0001916
2008-12-26 11:52 madsdyd Note Added: 0001939
2008-12-26 11:52 madsdyd Status acknowledged => resolved
2008-12-26 11:52 madsdyd Fixed in Version => Recent git
2008-12-26 11:52 madsdyd Resolution open => fixed
2008-12-26 11:52 madsdyd Assigned To => madsdyd
2008-12-26 11:53 madsdyd Assigned To madsdyd =>
2008-12-29 15:36 madsdyd Fixed in Version Recent git => 0.7.1
2008-12-29 15:37 madsdyd Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker