Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002711KdenliveRenderingpublic2012-08-29 11:322013-01-28 19:51
Reporterevorster 
Assigned Toj-b-m 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSLinuxOS Version3.4.9
Product VersionRecent git 
Target VersionFixed in Version0.9.4 
Summary0002711: Video stabilization does not work.
DescriptionI have some really shaky video footage that I would like to stabilize.
I have never gotten video stabilize to work, but did not think too much of it, since I did not need it.
Steps To ReproduceTake shaky segment of a clip, and export it.
Add exported clip into project
Right-click on exported clip, and select one of the two stabilizers.
It does not matter which one, vstab is slow, and transcode fast.
Pick default settings, and tick "Add to project"
Watch progress meter go all the way across.
Kdenlive then adds the clip into the project, but there is a big "Clip Missing"
This happens with both stabilizers.
So, try transcoding the exported clip to DNxHD, and tried again, still the same result with both stabilizers.
Call for help.
Additional InformationFootage is 1080p, 50fps progressive, taken with Panasonic TM900. Project is 25fps
TagsNo tags attached.
Build/Install MethodManual build from Git
Attached Filespng file icon kdenlive_video_stab.png [^] (241,775 bytes) 2012-08-29 11:32


? file icon 00340_2697.MTS.mov.mlt [^] (7,586 bytes) 2012-08-29 11:32

- Relationships
has duplicate 0002863closedptitmain Stabilize (vstab) does not produce the stabilized video but just the .mlt file (same result for countdown generator) 

-  Notes
(0008234)
evorster (reporter)
2012-08-29 11:33

I have added a screenshot of the "Missing Clip", and also uploaded the output file of the video stabilization.
(0008235)
norms2 (reporter)
2012-08-31 18:05

I can confirm this. It's been doing it for a long time now, even though the Playlist file (eg. xxxx.MTS.mlt) is added to the clips folder.
(0008236)
jsvid (reporter)
2012-08-31 22:50

I can also confirm this. Both stabilizers add a xxx.MTS.mlt extension to the project but the files cannot be read and are labeled 'missing clip'.
(0008256)
j-b-m (administrator)
2012-09-02 21:52

Problem is caused by a change in MLT:
https://github.com/mltframework/mlt/commit/89ff4d149a0ac54deab4057178678b68bef1e92d [^]

I just sent a mail on MLT's devel mailing list to find a correct way to fix it.
(0008291)
yt (reporter)
2012-09-07 16:28

Ubuntu 12.04, kdenlive 0.9.2, melt 0.8.2
Same Problem here.
(0008292)
j-b-m (administrator)
2012-09-07 19:31

Should be fixed now in git, please test
(0008297)
evorster (reporter)
2012-09-08 10:24

I can confirm that it's fixed.

Now I just need to learn what each one of the options does.

:)

- Issue History
Date Modified Username Field Change
2012-08-29 11:32 evorster New Issue
2012-08-29 11:32 evorster File Added: kdenlive_video_stab.png
2012-08-29 11:32 evorster File Added: 00340_2697.MTS.mov.mlt
2012-08-29 11:33 evorster Note Added: 0008234
2012-08-31 18:05 norms2 Note Added: 0008235
2012-08-31 22:50 jsvid Note Added: 0008236
2012-09-02 19:03 j-b-m Assigned To => j-b-m
2012-09-02 19:03 j-b-m Status new => acknowledged
2012-09-02 21:52 j-b-m Note Added: 0008256
2012-09-07 16:28 yt Note Added: 0008291
2012-09-07 19:31 j-b-m Note Added: 0008292
2012-09-08 10:24 evorster Note Added: 0008297
2012-09-08 11:34 j-b-m Status acknowledged => resolved
2012-09-08 11:34 j-b-m Fixed in Version => Recent git
2012-09-08 11:34 j-b-m Resolution open => fixed
2012-12-15 17:50 ptitmain Relationship added has duplicate 0002863
2013-01-28 19:49 j-b-m Fixed in Version Recent git => 0.9.4
2013-01-28 19:51 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker