Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002724KdenliveUser Interfacepublic2012-09-06 16:162013-01-28 19:51
Reportereddrog 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityrandom
StatusclosedResolutionfixed 
Platformx64OSUbuntuOS Version12.04
Product VersionRecent git 
Target VersionRecent gitFixed in Version0.9.4 
Summary0002724: bad seeking on running/playing transport
DescriptionOn paused transport the new seeking is very smooth. On running transport if you just click in the timeline to make a greater jump very often the picture is very shaky and unstable.
With the old seeking the starting (of the playing) was more smooth.
Steps To Reproduce1) Load a clip in timeline.
2) Start play.
3) Click in the timeline to make a greater jump with playhead. Repeat until you see the shaky starting in the monitor
TagsNo tags attached.
Build/Install Method(select)
Attached Filespng file icon Shot-001.png [^] (65,269 bytes) 2012-09-08 16:14


png file icon Shot-003.png [^] (20,129 bytes) 2012-09-11 20:43


png file icon Shot-006.png [^] (21,640 bytes) 2012-09-28 21:32

- Relationships

-  Notes
(0008286)
twildottv (reporter)
2012-09-07 04:55

I've seen the same (or a similar) issue, demonstrated here: http://youtu.be/y6BjceoW_Fk [^]

I'm using the kdenlive-svn PPA from Sunab on Ubuntu 12.04, with the latest available updates. When jumping around with the video paused, I see no issues, but when I attempt to move the playhead while the video is playing back, it jumps almost a dozen times.
(0008287)
j-b-m (administrator)
2012-09-07 14:25

Should be fixed now, can you please test?
(0008305)
eddrog (developer)
2012-09-08 16:02

It is much better but sporadic I get some nervous starting (the playhead is jumping several time about the wished position) after a big jump. With this patch the shake is more quiet. I don't know if it can be optimized anymore.

By the way: the sqaure does not disappear after the playhead reaches the wished position. I think to make it clear the square should disappear or move with the playhead together like in the monitor. Its confusing sometimes there are several remaining squares. Moving with the mouse at this position lets them disappear
(0008306)
eddrog (developer)
2012-09-08 16:16

Another issue is (see screenshot): if you click in the near of the time (zoom 6/13) the time gets corrupted. After a time it gets ok again.
(0008308)
twildottv (reporter)
2012-09-09 06:47

I'm seeing improvement as well. It still jitters as I showed in my earlier video, but instead of almost a dozen times, it's 2-3 times.
(0008312)
j-b-m (administrator)
2012-09-09 18:26

Drawing of the timline cursors should work correctly now without painting artifacts.
(0008321)
eddrog (developer)
2012-09-10 19:35

1) The time artifact issue is fixed.
2) Sometimes the sqaure does not disappear after the playhead reaches the wished position => not fixed completly.

3) Now I have a strange behaviour if I want to seek from the zero position. Sometimes the playhead is magnetic to zero or the playhead is jumping between zero and wished pos. Seeking from non zero pos is just ok.
(0008323)
j-b-m (administrator)
2012-09-11 09:26

2) is now fixed.

3) I also saw this behavior yesterday but cannot reproduce it now. Let me know if you still have it and find a way to reproduce
(0008324)
eddrog (developer)
2012-09-11 20:44

2) is not fixed for me (see Shot-003.png)
(0008326)
eddrog (developer)
2012-09-11 21:01

3) Is still there for me.

Steps to reproduce:

a) Load some clips into timeline
b) Seek to zero pos while stopped
c) Keep left mouse-key pressed and try to move the playhead
(0008332)
j-b-m (administrator)
2012-09-13 10:12

Ok, hopefully everything is fixed now.
(0008343)
eddrog (developer)
2012-09-14 22:15

Sorry point 3) is not fixed for me.

c) Keep left mouse-key pressed and try to move the playhead => playhead is jumping between zero and wished pos. If you move the playhead enought to right the zero magnet loses
(0008344)
eddrog (developer)
2012-09-14 22:17

By the way: the random 2-3 times jitter on seeking while playing is still there
(0008351)
j-b-m (administrator)
2012-09-16 22:12

Ok I think I finally found the fix for point 3). I could also observe a small random jitter but not sure if it is related to an MLT change or to Kdenlive
(0008355)
eddrog (developer)
2012-09-18 09:19

The zero pos magnet is definitely eliminated now => so 3) is fixed.

One point else: the timeline square curser is very smooth now. The monitors (Clip/Project) is a little bit unclean. It disappears to early and isn't this smooth (low prio of course).
(0008382)
eddrog (developer)
2012-09-23 13:21

The monitors (Clip/Project) square curser is smooth now but doesn't disappear if you seek while playing.
(0008414)
eddrog (developer)
2012-09-28 21:32

Now seeking in the timeline and in the monitors is pretty cool except if you move the playhead in the timeline from left to right and vice versa sometimes the square curser appears in the monitor and remains.
To reproduce this you have to play with speed of the playhead move and the media (in my case: dnxhd 120) loaded (see Shot-006.png)
(0008420)
eddrog (developer)
2012-09-30 21:27

Cool - the monitors curser are clean now. Thanks j-b-m.

- Issue History
Date Modified Username Field Change
2012-09-06 16:16 eddrog New Issue
2012-09-06 16:16 eddrog Status new => assigned
2012-09-06 16:16 eddrog Assigned To => j-b-m
2012-09-07 04:55 twildottv Note Added: 0008286
2012-09-07 14:25 j-b-m Note Added: 0008287
2012-09-07 14:25 j-b-m Status assigned => feedback
2012-09-08 16:02 eddrog Note Added: 0008305
2012-09-08 16:02 eddrog Status feedback => assigned
2012-09-08 16:14 eddrog File Added: Shot-001.png
2012-09-08 16:16 eddrog Note Added: 0008306
2012-09-09 06:47 twildottv Note Added: 0008308
2012-09-09 18:26 j-b-m Note Added: 0008312
2012-09-10 19:35 eddrog Note Added: 0008321
2012-09-11 09:26 j-b-m Note Added: 0008323
2012-09-11 20:43 eddrog File Added: Shot-003.png
2012-09-11 20:44 eddrog Note Added: 0008324
2012-09-11 21:01 eddrog Note Added: 0008326
2012-09-13 10:12 j-b-m Note Added: 0008332
2012-09-14 22:15 eddrog Note Added: 0008343
2012-09-14 22:17 eddrog Note Added: 0008344
2012-09-16 22:12 j-b-m Note Added: 0008351
2012-09-18 09:19 eddrog Note Added: 0008355
2012-09-23 13:21 eddrog Note Added: 0008382
2012-09-28 21:32 eddrog File Added: Shot-006.png
2012-09-28 21:32 eddrog Note Added: 0008414
2012-09-30 21:27 eddrog Note Added: 0008420
2012-09-30 23:43 j-b-m Status assigned => resolved
2012-09-30 23:43 j-b-m Fixed in Version => Recent git
2012-09-30 23:43 j-b-m Resolution open => fixed
2013-01-28 19:49 j-b-m Fixed in Version Recent git => 0.9.4
2013-01-28 19:51 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker