Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002741KdenliveBuild Systempublic2012-09-19 03:192013-01-28 19:50
ReporterDavePhillips 
Assigned Toj-b-m 
PrioritynormalSeveritymajorReproducibilityN/A
StatusclosedResolutionfixed 
Platform32-bitOSDebianOS VersionSqueeze
Product VersionRecent git 
Target VersionFixed in Version0.9.4 
Summary0002741: build script fail: Unable to build mlt
Description9/18 build-kdenlive.sh fails at point indicated in error output (see Additional Information)
Additional Informationcc -I/home/dlphilp/kdenlive/20120918/include -I/usr/include/qt4 -Wall -DPIC -DUSE_MMX -DUSE_SSE -DUSE_SSE2 -g -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -fPIC -pthread -Wall -DPIC -DUSE_MMX -DUSE_SSE -DUSE_SSE2 -g -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -fPIC -pthread -I../.. -Wall -DPIC -DUSE_MMX -DUSE_SSE -DUSE_SSE2 -g -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -fPIC -pthread -DAVDATADIR=\"/home/dlphilp/kdenlive/20120918/share/ffmpeg/\" -I/home/dlphilp/kdenlive/20120918/include -I/home/dlphilp/kdenlive/20120918/include -I/home/dlphilp/kdenlive/20120918/include -DFILTERS -DCODECS -DSWSCALE -DAVDEVICE -c -o consumer_avformat.o consumer_avformat.c
consumer_avformat.c: In function 'consumer_start':
consumer_avformat.c:241:16: error: 'AVCodec' has no member named 'encode'
consumer_avformat.c:265:15: error: 'AVCodec' has no member named 'encode'
consumer_avformat.c: In function 'consumer_thread':
consumer_avformat.c:1596:8: warning: 'avcodec_encode_audio' is deprecated (declared at /home/dlphilp/kdenlive/20120918/include/libavcodec/avcodec.h:4189) [-Wdeprecated-declarations]
consumer_avformat.c:1663:8: warning: 'avcodec_encode_audio' is deprecated (declared at /home/dlphilp/kdenlive/20120918/include/libavcodec/avcodec.h:4189) [-Wdeprecated-declarations]
consumer_avformat.c:1803:8: warning: 'avcodec_encode_video' is deprecated (declared at /home/dlphilp/kdenlive/20120918/include/libavcodec/avcodec.h:4252) [-Wdeprecated-declarations]
consumer_avformat.c:1889:5: warning: 'avcodec_encode_audio' is deprecated (declared at /home/dlphilp/kdenlive/20120918/include/libavcodec/avcodec.h:4189) [-Wdeprecated-declarations]
consumer_avformat.c:1892:5: warning: 'avcodec_encode_audio' is deprecated (declared at /home/dlphilp/kdenlive/20120918/include/libavcodec/avcodec.h:4189) [-Wdeprecated-declarations]
consumer_avformat.c:1919:4: warning: 'avcodec_encode_video' is deprecated (declared at /home/dlphilp/kdenlive/20120918/include/libavcodec/avcodec.h:4252) [-Wdeprecated-declarations]
producer_avformat.c: In function 'decode_audio':
producer_avformat.c:2149:3: warning: 'avcodec_decode_audio3' is deprecated (declared at /home/dlphilp/kdenlive/20120918/include/libavcodec/avcodec.h:3832) [-Wdeprecated-declarations]
make[2]: *** [consumer_avformat.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/home/dlphilp/kdenlive/src/mlt/src/modules/avformat'
make[1]: *** [all] Error 1
make[1]: Leaving directory `/home/dlphilp/kdenlive/src/mlt/src/modules'
make: *** [all] Error 1
ERROR: Unable to build mlt
LOG: Process has finished. Reason: FAILURE Some kind of error occured: Unable to build mlt
TagsNo tags attached.
Build/Install Method(select)
Attached Files

- Relationships

-  Notes
(0008357)
j-b-m (administrator)
2012-09-19 11:03

Probably caused by an API change in FFmpeg git that will require some fixes in MLT
(0008359)
j-b-m (administrator)
2012-09-19 21:10

Fixed in MLT's git now

- Issue History
Date Modified Username Field Change
2012-09-19 03:19 DavePhillips New Issue
2012-09-19 11:03 j-b-m Note Added: 0008357
2012-09-19 11:03 j-b-m Assigned To => j-b-m
2012-09-19 11:03 j-b-m Status new => acknowledged
2012-09-19 21:10 j-b-m Note Added: 0008359
2012-09-19 21:10 j-b-m Status acknowledged => resolved
2012-09-19 21:10 j-b-m Fixed in Version => Recent git
2012-09-19 21:10 j-b-m Resolution open => fixed
2013-01-28 19:50 j-b-m Fixed in Version Recent git => 0.9.4
2013-01-28 19:50 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker