Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002747KdenliveFile Loadingpublic2012-09-22 01:412013-01-28 19:51
Reporteridragosani 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platform64 bitOSUbuntuOS Version12.04
Product VersionRecent git 
Target VersionFixed in Version0.9.4 
Summary0002747: Crashes when loading projects
DescriptionA small test project that I had made last week is now crashing with latest git version of kdenlive, built with latest git of ffmpeg and mlt. These were all built manually, without build script, on Ubuntu Studio 12.04 64-bit. Usually it crashes after effects stack is loaded and I try to playback the project, go to beginning of clip or just about anything. The project contains a single clip about 1 minute long, and uses these effects:

sepia
grain
old film
vignette
dust
scratches

Console output:

kdenlive(5286) Render::checkMaxThreads: // TRACTOR PROBLEM
KCrash: Application 'kdenlive' crashing...

Backtrace attached

TagsNo tags attached.
Build/Install MethodManual build from Git
Attached Files? file icon kdenlive-20120921-193756.kcrash [^] (7,405 bytes) 2012-09-22 01:41 [Show Content]
? file icon exploring.kdenlive [^] (7,655 bytes) 2012-09-22 19:02
? file icon the_birthday_party.kdenlive [^] (11,449 bytes) 2012-09-22 19:02

- Relationships

-  Notes
(0008374)
j-b-m (administrator)
2012-09-22 17:53

First try updating MLT & Kdenlive to today's version since there were some instabilities introduced in the past days.

If it still crashes, could you please attach the .kdenlive project file here or mail it to me: jb at kdenlive.org so that I can check some details of your project?
(0008376)
idragosani (reporter)
2012-09-22 19:10

MLT was already at latest git version, updated kdenlive this morning but it is still crashing whenever I load a previously created project and select a clip or try to playback the project with project monitor open. I attached two example projects that are exhibiting this behavior.

I also tested a new project, adding a clip, and playing back, that was fine. I reopened new project, it played back... but then immediately crashed when I tried to add an effect (Fun->Dust). Both of the crashing projects had this effect (and also Grain and Old Film). I added a Fade In to the new project but it worked fine, so I am suspecting some of the "Fun" effects modules are causing the issue. I can try editing the XML manually and remove the effects and see if the project behaves better.
(0008378)
j-b-m (administrator)
2012-09-22 19:31

Ok, I can reproduce too. Looks like we still have several problems related to recent MLT changes, I am working on it..
(0008379)
ddennedy (developer)
2012-09-22 20:49

fixed in mlt git commit 3643d00

- Issue History
Date Modified Username Field Change
2012-09-22 01:41 idragosani New Issue
2012-09-22 01:41 idragosani File Added: kdenlive-20120921-193756.kcrash
2012-09-22 17:53 j-b-m Note Added: 0008374
2012-09-22 17:53 j-b-m Assigned To => j-b-m
2012-09-22 17:53 j-b-m Status new => feedback
2012-09-22 19:02 idragosani File Added: exploring.kdenlive
2012-09-22 19:02 idragosani File Added: the_birthday_party.kdenlive
2012-09-22 19:10 idragosani Note Added: 0008376
2012-09-22 19:10 idragosani Status feedback => assigned
2012-09-22 19:31 j-b-m Note Added: 0008378
2012-09-22 20:49 ddennedy Note Added: 0008379
2012-09-22 20:49 ddennedy Status assigned => resolved
2012-09-22 20:49 ddennedy Resolution open => fixed
2013-01-28 19:49 j-b-m Fixed in Version => 0.9.4
2013-01-28 19:51 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker