Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002761KdenliveRenderingpublic2012-09-27 09:492013-01-28 19:51
Reportereddrog 
Assigned Toj-b-m 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platform64 bitOSUbuntuOS Version12.04
Product VersionRecent git 
Target Version0.9.4Fixed in Version0.9.4 
Summary0002761: Alpha channel broken in rendered file
DescriptionA title clip or a png (with alpha channel) is shown properly in project monitor with composite or dissolve. In the rendered file the transparent part becomes black.
Steps To Reproduce1) Load a title and a sample clip into timeline.
2) Overlap and add a composite transition.
3) Render this part to webm or mp4.
4) Play rendered file with vlc.
Additional InformationIn my jack branch I have an older version of kdenlive/mlt => works correct. Didn't have the time yesterday to figure out which commit (mlt/kdenlive) breaks the alpha in rendered output.
TagsNo tags attached.
Build/Install MethodBuild Script
Attached Filespng file icon composite.png [^] (9,102 bytes) 2012-09-27 21:46

- Relationships

-  Notes
(0008410)
j-b-m (administrator)
2012-09-27 21:46

I cannot reproduce, but there seem to be some strange issues with MLT rendering on 64bit. Can you reproduce the problem with melt? Try this in a terminal:

melt color:red out=100 -track pango:+hello out=100 -transition composite -consumer avformat:test.mp4

Will create a test.mp4 clip that should look like my attached picture.
(0008413)
eddrog (developer)
2012-09-28 21:21

The melt example works but its some how generic.

The commit 386e02aca066220dfa5a7323825371686066e2fd (fix yadif deinterlacer on streams with progressive & interlace) in mlt breaks it (Kdenlive latest git). Interlaced clips work but you have very bad luck with progressive one.

Steps to reporduce:

1) Load progressive or forced hdv to progressive clip into timeline
2) add title with composite transition
3) render and enjoy the alpha channel as black

Project settings:
HDV or HD25p
(0008431)
eddrog (developer)
2012-10-02 10:05

Checked it. Seems to be fixed in recent MLT git (deinterlacer regression fix). Some other tickets are related to this regression. This minor optimization caused some trouble. I hope its done now :-))

- Issue History
Date Modified Username Field Change
2012-09-27 09:49 eddrog New Issue
2012-09-27 09:49 eddrog Status new => assigned
2012-09-27 09:49 eddrog Assigned To => j-b-m
2012-09-27 21:46 j-b-m Note Added: 0008410
2012-09-27 21:46 j-b-m Status assigned => feedback
2012-09-27 21:46 j-b-m File Added: composite.png
2012-09-28 21:21 eddrog Note Added: 0008413
2012-09-28 21:21 eddrog Status feedback => assigned
2012-10-02 10:05 eddrog Note Added: 0008431
2012-10-02 10:16 eddrog Status assigned => resolved
2012-10-02 10:16 eddrog Fixed in Version => Recent git
2012-10-02 10:16 eddrog Resolution open => fixed
2013-01-28 19:49 j-b-m Fixed in Version Recent git => 0.9.4
2013-01-28 19:51 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker