Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002770KdenliveEffectspublic2012-10-06 19:482013-01-28 19:51
Reporternievous 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platform32 bit intel and alikeOSUbuntuOS Version10.10
Product VersionRecent git 
Target VersionFixed in Version0.9.4 
Summary0002770: kdenlive crash: select0r.so: undefined symbol: dist_eli
Descriptionkdenlive crashes applying "Color Selection" effect.
Steps To ReproduceOpen Kdenline with default settings
add video
add image
drag video into "video 2" field/track
drag image into "video 3" field/track
"expand" image to video length.
add "composite" transition to video.
"expand" composite to video length.
select "video 2"
click "effect list" tab
doble click "alpha manipulation" > "color selection"
Additional InformationTested with v0.9 and v0.9.2 in mint 10 (32bit) and latest mint debian (64bit)
TagsNo tags attached.
Build/Install MethodBuild Script
Attached Filestxt file icon start-kdenlive.gdb.output.txt [^] (15,347 bytes) 2012-10-06 19:48 [Show Content]

- Relationships
duplicate of 0002289closedj-b-m crash when using denoiser effect 
has duplicate 0002704closedj-b-m inserting color selection effect crashes kdenlive 

-  Notes
(0008446)
j-b-m (administrator)
2012-10-09 09:58

This is a problem with the compile flags in frei0r. Can be solved with the following patch, I am submitting it now on MLT's mailing list.

diff --git a/build/build-kdenlive.sh b/build/build-kdenlive.sh
index 810315e..8ee1c94 100755
--- a/build/build-kdenlive.sh
+++ b/build/build-kdenlive.sh
@@ -486,7 +486,7 @@ function set_globals {
   ####
   # frei0r
   CONFIG[3]="./configure --prefix=$FINAL_INSTALL_DIR --libdir=$FINAL_INSTALL_DIR/lib"
- CFLAGS_[3]=$CFLAGS
+ CFLAGS_[3]="$CFLAGS -O2"
   LDFLAGS_[3]=$LDFLAGS
 
   ####
(0008450)
j-b-m (administrator)
2012-10-10 18:08

Should be fixed in latest version of the build script, please update to the latest version.

- Issue History
Date Modified Username Field Change
2012-10-06 19:48 nievous New Issue
2012-10-06 19:48 nievous File Added: start-kdenlive.gdb.output.txt
2012-10-09 09:55 j-b-m Relationship added duplicate of 0002289
2012-10-09 09:58 j-b-m Note Added: 0008446
2012-10-09 09:58 j-b-m Assigned To => j-b-m
2012-10-09 09:58 j-b-m Status new => acknowledged
2012-10-10 18:08 j-b-m Note Added: 0008450
2012-10-10 18:08 j-b-m Status acknowledged => resolved
2012-10-10 18:08 j-b-m Fixed in Version => Recent git
2012-10-10 18:08 j-b-m Resolution open => fixed
2012-10-25 16:42 j-b-m Relationship added has duplicate 0002704
2013-01-28 19:49 j-b-m Fixed in Version Recent git => 0.9.4
2013-01-28 19:51 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker