Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002791KdenliveUser Interfacepublic2012-10-20 12:062013-01-28 19:51
Reportereddrog 
Assigned Toj-b-m 
PriorityhighSeveritymajorReproducibilityrandom
StatusclosedResolutionfixed 
Platform64 bitOSUbuntuOS Version12.04
Product VersionRecent git 
Target VersionFixed in Version0.9.4 
Summary0002791: timeline corruption using CTRL+LEFT_MOUSE key
DescriptionThe timeline becomes corrupted if ctrl+left_mouse key is used for grouping. Shift+Left_Mouse key work like expected.
Steps To Reproduce1) Load e.g. 10 clips into timeline
2) Start from left to right selecting clips (CTRL+LEFT_MOUSE key)
3) Vary selecting speed => timeline corruption
TagsNo tags attached.
Build/Install MethodBuild Script
Attached Filespng file icon Bildschirmfoto vom 2012-10-20 11:59:40.png [^] (40,891 bytes) 2012-10-20 12:06


png file icon Auswahl_006.png [^] (23,710 bytes) 2012-10-27 11:31

- Relationships

-  Notes
(0008518)
j-b-m (administrator)
2012-10-20 22:18

I fixed a bug when selecting several clips using CTRL, sometimes one of the clips could be moved independently resulting in timeline corruption. Can you please test if my last commit fixes your problem?
(0008548)
eddrog (developer)
2012-10-26 09:32

Back again. Ok selecting clips for grouping using CTRL+LEFT_MOUSE works now like expected for single track audio/video clips. Doing the same for splitted clips is something weird and moving the selected clips is not possible. CTRL+A and SHIFT+MOUSE_SELECT work like expected.
(0008549)
brm (reporter)
2012-10-27 11:29

I've got the same issue with verison 0.9.2.
I imported 25 picture and assigned a duration of 0.05s for each picture.
Then I added all pictures to the video track. The resulting duration should be 1.25s, but it is 4.25s! A closer look to the timeline shows that at every 0.25s edge the timeline jumps to the next second.
Example:
... 1.23 1.24 2.00 2.01 2.02 ...
(0008553)
j-b-m (administrator)
2012-10-27 23:29

I found & fixed several corruptions when dragging grouped / splitted clips. Can you please test again with current git?
(0008558)
eddrog (developer)
2012-10-30 07:54

Regression: Selecting with CTRL+A and moving does not work!

Need some time for other testing.
(0008559)
j-b-m (administrator)
2012-10-30 10:47

Unfortunately this code is quite complex... I just fixed the "Select All" and "Select all in track" problem, let me know if you find others.
(0008560)
eddrog (developer)
2012-10-30 11:00

Its true. I hope in refactoring we'll have better model and interfaces especially in the timeline :-))

At the moment I don't have too much time but as mentioned above I'll test it accurately.

Some plans and time schedule for feature and interface change freeze?
I think it makes sense to pronounce a "call for testing" after feature freeze and do in this phase just bug fixing because we had a lot of critical changes. For me it is not a bugfix version (0.9.x) it is a 0.10 version.
(0008624)
eddrog (developer)
2012-11-15 13:27

Tested. Fixed for both modes: splitted and embedded clips

- Issue History
Date Modified Username Field Change
2012-10-20 12:06 eddrog New Issue
2012-10-20 12:06 eddrog Status new => assigned
2012-10-20 12:06 eddrog Assigned To => j-b-m
2012-10-20 12:06 eddrog File Added: Bildschirmfoto vom 2012-10-20 11:59:40.png
2012-10-20 22:18 j-b-m Note Added: 0008518
2012-10-20 22:18 j-b-m Status assigned => feedback
2012-10-26 09:32 eddrog Note Added: 0008548
2012-10-26 09:32 eddrog Status feedback => assigned
2012-10-27 11:29 brm Note Added: 0008549
2012-10-27 11:31 brm File Added: Auswahl_006.png
2012-10-27 23:29 j-b-m Note Added: 0008553
2012-10-30 07:54 eddrog Note Added: 0008558
2012-10-30 10:47 j-b-m Note Added: 0008559
2012-10-30 11:00 eddrog Note Added: 0008560
2012-11-15 13:27 eddrog Note Added: 0008624
2012-11-17 19:40 j-b-m Status assigned => resolved
2012-11-17 19:40 j-b-m Fixed in Version => Recent git
2012-11-17 19:40 j-b-m Resolution open => fixed
2013-01-28 19:49 j-b-m Fixed in Version Recent git => 0.9.4
2013-01-28 19:51 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker