Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002794KdenliveBuild Systempublic2012-10-20 17:512013-01-28 19:51
Reporterichselbst 
Assigned Toj-b-m 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
Platform64 bitOSopenSUSEOS Version12.2
Product VersionRecent git 
Target VersionFixed in Version0.9.4 
Summary0002794: src/renderer.cpp: error: 'class Mlt::Profile' has no member named 'colorspace'
DescriptionHi,

recently I've been trying to build kdenlive from recent git, but it fails, see below...

Please let me know if I have missed anything.

Regards
Tom
Steps To Reproduce$ cmake -DCMAKE_SKIP_RPATH=ON -DCMAKE_INSTALL_PREFIX=/usr -DLIBEXEC_INSTALL_DIR:PATH=/usr/lib64/kde4/libexec -DLIB_SUFFIX=64 -DCMAKE_BUILD_TYPE=release .. -DWITH_V4L=OFF
$ make -j2 VERBOSE=1
...
[ 789s] [ 91%] Building CXX object src/CMakeFiles/kdenlive.dir/renderer.o
[ 789s] cd /home/abuild/rpmbuild/BUILD/kdenlive-0.9.3git.1350742544/build/src && /usr/bin/c++ -D_BSD_SOURCE -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -DQT_NO_STL -DQT_NO_CAST_TO_ASCII -D_REENTRANT -DKDE_DEPRECATED_WARNINGS -DKDE4_CMAKE_TOPLEVEL_DIR_LENGTH=27 -DQT_OPENGL_LIB -DQT_SCRIPT_LIB -DQT_SVG_LIB -DQT_GUI_LIB -DQT_DBUS_LIB -DQT_XML_LIB -DQT_CORE_LIB -DUSE_OPENGL -DUSE_NEPOMUK -DUSE_QJSON -DUSE_JOGSHUTTLE -DQT_NO_DEBUG -fmessage-length=0 -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables -g -Wnon-virtual-dtor -Wno-long-long -ansi -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -fno-exceptions -DQT_NO_EXCEPTIONS -fno-check-new -fno-common -Woverloaded-virtual -fno-threadsafe-statics -fvisibility=hidden -Werror=return-type -fvisibility-inlines-hidden -O2 -DNDEBUG -DQT_NO_DEBUG -I/home/abuild/rpmbuild/BUILD/kdenlive-0.9.3git.1350742544/build/src -I/home/abuild/rpmbuild/BUILD/kdenlive-0.9.3git.1350742544/src -I/home/abuild/rpmbuild/BUILD/kdenlive-0.9.3git.1350742544/build -I/usr/include/KDE -I/usr/include/QtXmlPatterns -I/usr/include/QtXml -I/usr/include/QtWebKit -I/usr/include/QtUiTools -I/usr/include/QtTest -I/usr/include/QtSvg -I/usr/include/QtSql -I/usr/include/QtScriptTools -I/usr/include/QtScript -I/usr/include/QtOpenGL -I/usr/include/QtNetwork -I/usr/include/QtMultimedia -I/usr/include/QtHelp -I/usr/include/QtDesigner -I/usr/include/QtDeclarative -I/usr/include/QtDBus -I/usr/include/Qt3Support -I/usr/include/QtGui -I/usr/include/QtCore -I/usr/include/Qt -I/usr/share/qt4/mkspecs/default -I/usr/include/mlt -I/usr/include/qjson -DMLT_PREFIX=\""/usr"\" -DMLT_DATADIR=\""/usr/share/mlt-5"\" -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -o CMakeFiles/kdenlive.dir/renderer.o -c /home/abuild/rpmbuild/BUILD/kdenlive-0.9.3git.1350742544/src/renderer.cpp
[ 793s] /home/abuild/rpmbuild/BUILD/kdenlive-0.9.3git.1350742544/src/renderer.cpp: In member function 'void Render::buildConsumer(const QString&)':
[ 793s] /home/abuild/rpmbuild/BUILD/kdenlive-0.9.3git.1350742544/src/renderer.cpp:198:42: error: 'class Mlt::Profile' has no member named 'colorspace'
[ 793s] /home/abuild/rpmbuild/BUILD/kdenlive-0.9.3git.1350742544/src/renderer.cpp: In member function 'void Render::processFileProperties()':
[ 793s] /home/abuild/rpmbuild/BUILD/kdenlive-0.9.3git.1350742544/src/renderer.cpp:886:72: error: 'class Mlt::Profile' has no member named 'colorspace'
[ 794s] make[2]: *** [src/CMakeFiles/kdenlive.dir/renderer.o] Error 1
[ 794s] make[2]: *** Waiting for unfinished jobs....
[ 794s] make[2]: Leaving directory `/home/abuild/rpmbuild/BUILD/kdenlive-0.9.3git.1350742544/build'
[ 794s] make[1]: *** [src/CMakeFiles/kdenlive.dir/all] Error 2
[ 794s] make[1]: Leaving directory `/home/abuild/rpmbuild/BUILD/kdenlive-0.9.3git.1350742544/build'
[ 794s] make: *** [all] Error 2
[ 794s] error: Bad exit status from /var/tmp/rpm-tmp.RTQ7wC (%build)
[ 794s]
[ 794s]
[ 794s] RPM build errors:
[ 794s] Bad exit status from /var/tmp/rpm-tmp.RTQ7wC (%build)
Additional InformationI get this error when trying to compile git snapshots since commit d92f43b96847b44c8efbb06cd889612ab7fee0f7.

The build also fails with the same error on openSUSE 12.1 no matter what architecture used.

See here for full build log:
https://build.opensuse.org/package/rawlog?arch=x86_64&package=kdenlive_unstable&project=home%3Aderselbst&repository=openSUSE_12.2_standard [^]
TagsNo tags attached.
Build/Install MethodManual build from Git
Attached Files

- Relationships

-  Notes
(0008514)
eddrog (developer)
2012-10-20 18:45

If would recommend dan's build script (https://github.com/mltframework/mlt-scripts/blob/master/build/build-kdenlive.sh [^]) if you don't use it. Compiling from scratch is pretty hard.
(0008517)
j-b-m (administrator)
2012-10-20 21:48

You are probably trying to build Kdenlive against an old version of MLT. Either update you MLT version or use the build script as recommanded in previous comment
(0008525)
ichselbst (reporter)
2012-10-21 11:21

I wouldn't call MLT 0.8.2 old but nevertheless you're right. Building kdenlive against MLT from recent git works fine.

Thanks!

- Issue History
Date Modified Username Field Change
2012-10-20 17:51 ichselbst New Issue
2012-10-20 18:45 eddrog Note Added: 0008514
2012-10-20 21:48 j-b-m Note Added: 0008517
2012-10-20 21:48 j-b-m Assigned To => j-b-m
2012-10-20 21:48 j-b-m Status new => feedback
2012-10-21 11:21 ichselbst Note Added: 0008525
2012-10-21 11:21 ichselbst Status feedback => assigned
2012-10-21 11:32 j-b-m Status assigned => resolved
2012-10-21 11:32 j-b-m Fixed in Version => Recent git
2012-10-21 11:32 j-b-m Resolution open => fixed
2013-01-28 19:49 j-b-m Fixed in Version Recent git => 0.9.4
2013-01-28 19:51 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker