Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002818KdenliveEffectspublic2012-11-07 21:262013-01-28 19:50
Reporterjappel 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformArchlinuxOSOS Version
Product Version0.9.2 
Target VersionFixed in Version0.9.4 
Summary0002818: Special characters in titles make titles disappear in render
DescriptionWhen creating a title clip with special character (ä / ü / ö, likely others) the title disappears from the render.

They are shown correctly in the project monitor.
Steps To ReproduceCreate a title clip with a special character

add to timeline, preview in project monitor
-> should work as expected

render to file
-> title clip disappeared
Additional InformationAdditional insights from mr_lou @irc:

It appears to be a bug in the script-generation. It cuts text when a special character comes along.
If you edit the generated script and replace characters with special characters, and then execute the script, then the rendered video will contain the special characters.

In my case though, for some reason executing the script gives me another problem. A way red picture. I suspect that's because I'm using an RGB-color correction on the video though, which for some reason gets messed up when doing it this way.
If I set kdenlive to execute the script, instead of executing it from bash, then I don't get that way too red picture.

Use placeholders (some other characters you know you won't be using anyway, and which doesn't appear in the script source tags either). Generate a script from kdenlive. Edit the script with an editor, and replace your placeholders with your special characters and save. Then execute the script from without kdenlive.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
(0008588)
j-b-m (administrator)
2012-11-07 22:28

Cannot reproduce with current git, I think it has been fixed. Just to make sure, can you tell me what is your system's locale? you can get it in a terminal by typing:

locale
(0008589)
jappel (reporter)
2012-11-08 01:40

$ locale
LANG=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=

I believe mr_lou was on stock 0.9.2 while I use the package provided by arch which returns for kdenlive --version
Qt: 4.8.3
KDE Development Platform: 4.9.2
Kdenlive: 0.9.3 (rev. v0.9.2-165-g56bef60)

When I render a simple title 5 - 30s, the title flashes for a micro second and then remains invisible. I can wait until $release and check again.
(0008595)
jappel (reporter)
2012-11-10 14:22

I just compiled the git version - the bug nolonger appears and therefore should be fixed when 0.9.3 is released.

please close the bug.

resulotion -> fixed
fixed in -> 0.9.3

- Issue History
Date Modified Username Field Change
2012-11-07 21:26 jappel New Issue
2012-11-07 22:28 j-b-m Note Added: 0008588
2012-11-07 22:28 j-b-m Assigned To => j-b-m
2012-11-07 22:28 j-b-m Status new => feedback
2012-11-08 01:40 jappel Note Added: 0008589
2012-11-08 01:40 jappel Status feedback => assigned
2012-11-10 14:22 jappel Note Added: 0008595
2012-11-10 14:52 j-b-m Status assigned => resolved
2012-11-10 14:52 j-b-m Fixed in Version => Recent git
2012-11-10 14:52 j-b-m Resolution open => fixed
2013-01-28 19:49 j-b-m Fixed in Version Recent git => 0.9.4
2013-01-28 19:50 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker