Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002828KdenliveFile Loadingpublic2012-11-15 02:332013-01-28 19:51
Reporterfermin 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platformi386OSFedoraOS Version17
Product VersionRecent git 
Target VersionFixed in Version0.9.4 
Summary0002828: Crash opening file
DescriptionI have a project a friend send me some time ago. He made with an older version of kdenlive (can't find what version). The project is located in other paths than original. Then, when I try to open the project, Kdenlive crashes.
Steps To Reproduce1- Open the old kdenlive project
2- Some clips are missing.
3- Clic search recursively, I found 2 videos of 7.
4- Clic Ok, then ask by other video (not found), I clic "keep as placeholder".
5- The old project directory doesn't exist, then ask me. I don't want create it.
6- Kdenlive informs me that will use my default directory for the project.
7- Kdenlive informs me that the project was updated from older version, and it will save a backup version.
8- When I clic "Ok", kdenlive crashes.
TagsNo tags attached.
Build/Install MethodBuild Script
Attached Files? file icon kdenlive-20121115-021645.kcrash [^] (6,625 bytes) 2012-11-15 02:33 [Show Content]

- Relationships

-  Notes
(0008619)
j-b-m (administrator)
2012-11-15 11:25

Could you please attach here or mail me (jb at kdenlive org) the .kdenlive project file?
(0008622)
fermin (reporter)
2012-11-15 13:00

I have mailed the project file.
I have done another test, that must be useful for you because you don't have the videos: in steps to reproduce, select use placeholders, then all missing videos get a checkmark (all ok). Then clic ok and follow the other steps (step 4). I tried and get same crash.
(0008626)
j-b-m (administrator)
2012-11-15 21:31

Ok, should be fixed now in git. It was a locale issue, the document version of your project file was "0,85", which was incorrectly converted to 0.
(0008627)
fermin (reporter)
2012-11-15 22:07

Oh, great! I will try tomorrow to build new git version and I would feedback with the result. Good job!
(0008628)
fermin (reporter)
2012-11-16 11:07

My friend was using an Spanish locale, but I use an English one.
New git version built and the project opens perfectly, the bug has gone!
Thanks!
(0008902)
fermin (reporter)
2012-12-26 14:12

This bug is solved, you can close it. Thanks!

- Issue History
Date Modified Username Field Change
2012-11-15 02:33 fermin New Issue
2012-11-15 02:33 fermin File Added: kdenlive-20121115-021645.kcrash
2012-11-15 11:25 j-b-m Note Added: 0008619
2012-11-15 11:25 j-b-m Assigned To => j-b-m
2012-11-15 11:25 j-b-m Status new => feedback
2012-11-15 13:00 fermin Note Added: 0008622
2012-11-15 13:00 fermin Status feedback => assigned
2012-11-15 21:31 j-b-m Note Added: 0008626
2012-11-15 21:31 j-b-m Status assigned => feedback
2012-11-15 22:07 fermin Note Added: 0008627
2012-11-15 22:07 fermin Status feedback => assigned
2012-11-16 11:07 fermin Note Added: 0008628
2012-12-26 14:12 fermin Note Added: 0008902
2012-12-26 14:15 j-b-m Status assigned => resolved
2012-12-26 14:15 j-b-m Fixed in Version => Recent git
2012-12-26 14:15 j-b-m Resolution open => fixed
2013-01-28 19:49 j-b-m Fixed in Version Recent git => 0.9.4
2013-01-28 19:51 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker