Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002843KdenliveUser Interfacepublic2012-11-20 20:372013-01-28 19:50
ReporterZuf 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.9.4 
Summary0002843: Wrong fadein/fadeout length after resizing clip
Description1. Create new project
2. Add audio clip to audio track
3. Resize clip (cut some first and last parts)
4. Add fadein and fadeout effect (by dragging a corners with mouse)
5. Resize clip a bit.
6. As result Fadein / fadeout lengthes goes wrong. They become 100% long.
TagsNo tags attached.
Build/Install MethodManual build from Git
Attached Files

- Relationships
has duplicate 0002862closedj-b-m Changing clip length in timeline changes duration of fades. 

-  Notes
(0008654)
GMaq (reporter)
2012-11-21 01:01

Hi,

I also have this issue and it has been present since at least 0.9.2. I can confirm that this can be reproduced always as well. (Kdenlive 0.9.3GIT 32bit)
(0008657)
rbckman (reporter)
2012-11-21 09:33

got the same issue on recent ppa:sunab/kdenlive-svn
(0008663)
moorsey (reporter)
2012-11-26 13:06

to confirm, I have also seen this over the last few versions, always have to check the fade length for audio and video to check it is correct
(0008710)
moorsey (reporter)
2012-12-09 16:38

Example: http://www.youtube.com/watch?v=IjTRE-GIJVw [^]
(0008718)
j-b-m (administrator)
2012-12-10 22:51

Should be fixed now in git, please test
(0008721)
GMaq (reporter)
2012-12-10 23:10

Hi,
 
Firstly sincere thanks for addressing this bug, it has been problematic.

Just tested from fresh GIT and the issue seems to be fixed however I noted that when a clip was resized the sliders on the Fade effects still move their positions slightly however their numerical values do not change. It has certainly improved greatly from how it was but the sliders moving without the values changing seems like something is still amiss.

Tested on Debian Squeeze/AV Linux 6.0 32bit only.
(0008724)
j-b-m (administrator)
2012-12-10 23:21

Well, the slider moves because when resizing a clip, the length of the clip changes.
The length of the slider represents the length of the clip. For example let's say you have a clip with length of 500 frames and set a fade in of 50 frames. The slider pos will be at 1/10 of total slider size.

If you resize the clip to 100 frames, the slider pos will move to 1/2 of slider length.

That seems normal to me...
(0008727)
GMaq (reporter)
2012-12-10 23:35

OK,

That does make sense now that you've explained it so sorry for the noise, with that cleared up I'd say it's fixed (here anyway). Thanks again!

- Issue History
Date Modified Username Field Change
2012-11-20 20:37 Zuf New Issue
2012-11-21 01:01 GMaq Note Added: 0008654
2012-11-21 09:33 rbckman Note Added: 0008657
2012-11-26 13:06 moorsey Note Added: 0008663
2012-12-09 16:38 moorsey Note Added: 0008710
2012-12-09 22:23 j-b-m Assigned To => j-b-m
2012-12-09 22:23 j-b-m Status new => acknowledged
2012-12-10 09:42 eddrog Relationship added has duplicate 0002862
2012-12-10 22:51 j-b-m Note Added: 0008718
2012-12-10 22:51 j-b-m Status acknowledged => feedback
2012-12-10 23:10 GMaq Note Added: 0008721
2012-12-10 23:21 j-b-m Note Added: 0008724
2012-12-10 23:35 GMaq Note Added: 0008727
2012-12-11 09:57 j-b-m Status feedback => resolved
2012-12-11 09:57 j-b-m Fixed in Version => Recent git
2012-12-11 09:57 j-b-m Resolution open => fixed
2013-01-28 19:49 j-b-m Fixed in Version Recent git => 0.9.4
2013-01-28 19:50 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker