Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002869KdenliveUser Interfacepublic2012-12-11 14:002013-01-28 19:51
Reporterkeremhd 
Assigned Toeddrog 
PrioritynormalSeveritytrivialReproducibilityalways
StatusclosedResolutionfixed 
Platform64 bitOSUbuntuOS Version12.04
Product VersionRecent git 
Target VersionFixed in Version0.9.4 
Summary0002869: Fast forward / backward buttons not working while paused, but still enabled
DescriptionWhile a clip is playing:
fast fwd / backward buttons work as expected.

While a clip is paused:
fast fwd / backward buttons cause the play/pause button icon to change as "playing", but the clip doesn't start.


Expected behavior:
The "paused" icon changes to "playing", so user expects clip to start playing in fast mode.

Or at least they should not change the play/pause button's icon
Steps To ReproduceCreate empty project
Add single clip
Play / pause it normally.
Click on forward/backward once. "Paused" icon changes to "Playing". Clip doesn't play.
TagsNo tags attached.
Build/Install MethodBuild Script
Attached Files

- Relationships
duplicate of 0002273feedbackeddrog Contour Shuttlexpress buttons trigger actions twice 

-  Notes
(0008737)
keremhd (reporter)
2012-12-11 17:07

Hi, this is marked as duplicate of a report related with shuttleexpress 2273.

I was mentioning the actual buttons on the clip view window & mouse click actions, not hardware/keyboard buttons of any kind
(0008739)
eddrog (developer)
2012-12-11 20:28

I know. In this case it does not matter from where you start forward in the background the same function is called => duplicate is ok.
(0008740)
j-b-m (administrator)
2012-12-12 01:31

Should be fixed now, the jkl keys should work correctly too.
(0008743)
keremhd (reporter)
2012-12-12 09:45

I checked out latest git from scratch, still the same problem exists

I noticed this: Just after you select a clip from project tree, the fwd/backward button works. But after you play&pause it once, fwd/backward don't work until you select another clip.

I compared it with the previous build I have, the behavior is exactly the same. Didn't check j k l
(0008744)
j-b-m (administrator)
2012-12-12 11:03

Strange, I cannot reproduce. It works fine for me. Just to be sure, can you reproduce starting with an empty project, simply adding a clip, do play pause then bug is here?

Also, how do you play / pause (using shortcuts, monitor buttons...)?

Does this also happen with simple color clips?
(0008746)
eddrog (developer)
2012-12-12 14:29

I looked into j-b-m's patch. Looks good for me. I'll test it today evening.
(0008748)
keremhd (reporter)
2012-12-12 20:40

Again I removed everything (except config files, if there are any in my home?), removed src and build directories, and started build script again

I start kdenlive with emty project and only add a colorclip. I don't save the project.

1. click on clip from project tree
2. click on fast forward in monitor buttons
It works, starts playing

1. click on clip
2. click play
3. click pause
4. click fast forward
Paused icon changes to playing, clip doesn't start playing

The problem seems to only happen after play/pause, but this is also same as old version?
(0008749)
eddrog (developer)
2012-12-12 20:41

j-k-l works so far.

>>> I noticed this: Just after you select a clip from project tree, the fwd/backward button works. But after you play&pause it once, fwd/backward don't work until you select another clip.

=> I can reproduce => still a problem.
(0008751)
eddrog (developer)
2012-12-12 20:53

@j-b-m: if you press the k key for stopping it works as expected. Stopping with space key or mouse-press on stop button don't work.
(0008753)
eddrog (developer)
2012-12-12 20:56

j-l keys don't work if stopped with space key. Sorry I would investige more but I'm absolutely out of time now.
(0008756)
j-b-m (administrator)
2012-12-12 21:31

Oh, ok I had a change not committed, I think that's why it worked only for me. Should be fixed, can you please update & test again?
(0008768)
keremhd (reporter)
2012-12-13 14:43

Ok, play-pause-fastfwd/backwd sequence is working now

But while testing I noticed two more problems

1. When fast backward playing, after the clip reaches 0s and stops, the play/pause icon stays as paused. Clicking on it, clip starts playing (just display icon issue)


2. Following sequence causes a blocking of all UI (but with no CPU or mem usage?) :

1. Create color clip
2. click backward (you can seek and then click, doesn't matter)
3. after it reaches 0 and stops, click backward again
4. click play, UI freezes completely

I tried the same with fastfwd instead, seemed not to freeze, but a few seconds later it crashed
(0008769)
eddrog (developer)
2012-12-13 17:23

@keremhd: Confirmed.

@j-b-m: Its much better but there are some more issues. Will provide test results later.
(0008805)
eddrog (developer)
2012-12-16 18:13

1) Stopping playback with SPACE key works as expected

2) Stopping playback with K-key plays a/several frame after stop request. As a side effect the colors are changing in the monitor while stopping.

Stopping with K-key should work like 1)
(0008811)
eddrog (developer)
2012-12-16 19:48

Looks good so far.
(0008844)
eddrog (developer)
2012-12-21 15:52

@keremhd: Can you acknowledge the fix?
(0008845)
keremhd (reporter)
2012-12-21 16:49

acknowledged, both tests (backward-backward and forward-forward) caused no issues

- Issue History
Date Modified Username Field Change
2012-12-11 14:00 keremhd New Issue
2012-12-11 15:30 eddrog Relationship added duplicate of 0002273
2012-12-11 17:07 keremhd Note Added: 0008737
2012-12-11 20:28 eddrog Note Added: 0008739
2012-12-11 20:28 eddrog Assigned To => eddrog
2012-12-11 20:28 eddrog Status new => acknowledged
2012-12-12 01:31 j-b-m Note Added: 0008740
2012-12-12 09:45 keremhd Note Added: 0008743
2012-12-12 11:03 j-b-m Note Added: 0008744
2012-12-12 14:29 eddrog Note Added: 0008746
2012-12-12 20:40 keremhd Note Added: 0008748
2012-12-12 20:41 eddrog Note Added: 0008749
2012-12-12 20:53 eddrog Note Added: 0008751
2012-12-12 20:56 eddrog Note Added: 0008753
2012-12-12 21:31 j-b-m Note Added: 0008756
2012-12-13 14:43 keremhd Note Added: 0008768
2012-12-13 17:23 eddrog Note Added: 0008769
2012-12-16 18:13 eddrog Note Added: 0008805
2012-12-16 19:48 eddrog Note Added: 0008811
2012-12-21 15:52 eddrog Note Added: 0008844
2012-12-21 15:52 eddrog Status acknowledged => feedback
2012-12-21 16:49 keremhd Note Added: 0008845
2012-12-21 16:49 keremhd Status feedback => assigned
2012-12-22 12:24 eddrog Status assigned => resolved
2012-12-22 12:24 eddrog Resolution open => fixed
2013-01-28 19:49 j-b-m Fixed in Version => 0.9.4
2013-01-28 19:51 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker