Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002871KdenliveUser Interfacepublic2012-12-12 22:072013-01-28 19:51
Reportercweiske 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platform64 bitOSUbuntuOS Version12.10
Product Version0.9.2 
Target VersionFixed in Version0.9.4 
Summary0002871: crash when zooming out timeline
DescriptionWhen zooming out the timeline to ~1/13 or 2/13 in a ~1h project, kdenlive crashes reproducably.

kdenlive version is 0.9.3, which is unfortunately not available in this bugtracker.
Additional InformationApplication: kdenlive (0.9.3)
KDE Platform Version: 4.9.2
Qt Version: 4.8.3
Operating System: Linux 3.5.0-17-generic x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:

The crash can be reproduced every time.

-- Backtrace:
Application: Kdenlive (kdenlive), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f47b0d88780 (LWP 3869))]

Thread 4 (Thread 0x7f4793fff700 (LWP 3871)):
#0 0x00007f47ab833303 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1 0x00007f47a8bc9d84 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000002 0x00007f47a8bca1e2 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000003 0x00007f47a01853b6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
0000004 0x00007f47a8bed645 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000005 0x00007f47ad2d9e9a in start_thread (arg=0x7f4793fff700) at pthread_create.c:308
0000006 0x00007f47ab83ecbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
0000007 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f477c0ca700 (LWP 3906)):
#0 pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:215
#1 0x00007f47ad724378 in mlt_consumer_get_frame (self=0x2f4f3c0) at mlt_consumer.c:575
0000002 0x00007f47ad724c7e in mlt_consumer_rt_frame (self=0x2f4f3c0) at mlt_consumer.c:1381
0000003 0x00007f4789483920 in consumer_thread (arg=<optimized out>) at consumer_sdl_still.c:572
0000004 0x00007f47ad2d9e9a in start_thread (arg=0x7f477c0ca700) at pthread_create.c:308
0000005 0x00007f47ab83ecbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
0000006 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f4798f9c700 (LWP 3907)):
#0 pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1 0x00007f4789483117 in consumer_thread (arg=0x2fa8ea0) at consumer_sdl_preview.c:457
0000002 0x00007f47ad2d9e9a in start_thread (arg=0x7f4798f9c700) at pthread_create.c:308
0000003 0x00007f47ab83ecbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
0000004 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f47b0d88780 (LWP 3869)):
[KCrash Handler]
0000006 0x00007f47ae5feb72 in operator QScopedPointer<QPainterPathPrivate, QPainterPathPrivateDeleter>::RestrictedBool (this=0x7fffc588c4c0) at ../../include/QtGui/../../src/gui/painting/qpainterpath.h:399
0000007 elementCount (this=0x7fffc588c4c0) at ../../include/QtGui/../../src/gui/painting/qpainterpath.h:399
0000008 clip<(<unnamed>::Edge)1u> (t=66, path=...) at painting/qpathclipper.cpp:2095
0000009 (anonymous namespace)::intersectPath (path=..., rect=...) at painting/qpathclipper.cpp:2131
0000010 0x00007f47ae5ff34a in intersect (rect=..., path=...) at painting/qpathclipper.cpp:2146
0000011 QPathClipper::clip (this=0x7fffc588ced0, operation=<optimized out>) at painting/qpathclipper.cpp:1646
0000012 0x00007f47ae5efb7e in QPainterPath::intersected (this=<optimized out>, p=...) at painting/qpainterpath.cpp:3236
0000013 0x0000000000765b2e in ?? ()
0000014 0x00007f47aea85c05 in QGraphicsScenePrivate::draw (this=this@entry=0x56c9180, item=item@entry=0x5d65310, painter=painter@entry=0x7fffc588d760, viewTransform=viewTransform@entry=0x7fffc588d8f0, transformPtr=transformPtr@entry=0x7fffc588d400, exposedRegion=exposedRegion@entry=0x56c9ca8, widget=0x56dd0f0, opacity=opacity@entry=1, effectTransform=effectTransform@entry=0x0, wasDirtyParentSceneTransform=wasDirtyParentSceneTransform@entry=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4964
0000015 0x00007f47aea86985 in QGraphicsScenePrivate::drawSubtreeRecursive (this=this@entry=0x56c9180, item=0x5d65310, painter=painter@entry=0x7fffc588d760, viewTransform=viewTransform@entry=0x7fffc588d8f0, exposedRegion=exposedRegion@entry=0x56c9ca8, widget=widget@entry=0x56dd0f0, parentOpacity=parentOpacity@entry=1, effectTransform=effectTransform@entry=0x0) at graphicsview/qgraphicsscene.cpp:4857
0000016 0x00007f47aea8745e in QGraphicsScenePrivate::drawItems (this=0x56c9180, painter=0x7fffc588d760, viewTransform=0x7fffc588d8f0, exposedRegion=0x56c9ca8, widget=0x56dd0f0) at graphicsview/qgraphicsscene.cpp:4739
0000017 0x00007f47aeaa3828 in QGraphicsView::paintEvent (this=0x56c95f0, event=<optimized out>) at graphicsview/qgraphicsview.cpp:3471
0000018 0x00007f47ae4dd802 in QWidget::event (this=0x56c95f0, event=0x7fffc588e3b0) at kernel/qwidget.cpp:8517
0000019 0x00007f47ae88cb66 in QFrame::event (this=0x56c95f0, e=0x7fffc588e3b0) at widgets/qframe.cpp:557
0000020 0x00007f47aeaa495b in QGraphicsView::viewportEvent (this=0x56c95f0, event=0x7fffc588e3b0) at graphicsview/qgraphicsview.cpp:2866
0000021 0x00007f47adaab6d6 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x56dd0f0, event=0x7fffc588e3b0) at kernel/qcoreapplication.cpp:1025
0000022 0x00007f47ae48de6c in QApplicationPrivate::notify_helper (this=this@entry=0x21385e0, receiver=receiver@entry=0x56dd0f0, e=e@entry=0x7fffc588e3b0) at kernel/qapplication.cpp:4558
0000023 0x00007f47ae49230a in QApplication::notify (this=0x7fffc58904d0, receiver=0x56dd0f0, e=0x7fffc588e3b0) at kernel/qapplication.cpp:4423
0000024 0x00007f47b07941d6 in KApplication::notify (this=0x7fffc58904d0, receiver=0x56dd0f0, event=0x7fffc588e3b0) at ../../kdeui/kernel/kapplication.cpp:311
0000025 0x00007f47adaab56e in QCoreApplication::notifyInternal (this=0x7fffc58904d0, receiver=0x56dd0f0, event=0x7fffc588e3b0) at kernel/qcoreapplication.cpp:915
0000026 0x00007f47ae4d9524 in sendSpontaneousEvent (event=0x7fffc588e3b0, receiver=0x56dd0f0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:234
0000027 QWidgetPrivate::drawWidget (this=0x56dd120, pdev=0x283d730, rgn=..., offset=..., flags=68, sharedPainter=0x0, backingStore=0x2c0ea20) at kernel/qwidget.cpp:5594
0000028 0x00007f47ae6a78fd in QWidgetBackingStore::sync (this=0x2c0ea20) at painting/qbackingstore.cpp:1365
0000029 0x00007f47ae4ce7f0 in QWidgetPrivate::syncBackingStore (this=this@entry=0x240b720) at kernel/qwidget.cpp:1892
0000030 0x00007f47ae4dde4c in QWidget::event (this=0x240b2b0, event=0x7fffc588efe0) at kernel/qwidget.cpp:8664
0000031 0x00007f47ae8a61cb in QMainWindow::event (this=0x240b2b0, event=0x7fffc588efe0) at widgets/qmainwindow.cpp:1478
0000032 0x00007f47b0885778 in KXmlGuiWindow::event (this=0x240b2b0, ev=0x7fffc588efe0) at ../../kdeui/xmlgui/kxmlguiwindow.cpp:126
0000033 0x00007f47ae48de9c in QApplicationPrivate::notify_helper (this=this@entry=0x21385e0, receiver=receiver@entry=0x240b2b0, e=e@entry=0x7fffc588efe0) at kernel/qapplication.cpp:4562
0000034 0x00007f47ae49230a in QApplication::notify (this=0x7fffc58904d0, receiver=0x240b2b0, e=0x7fffc588efe0) at kernel/qapplication.cpp:4423
0000035 0x00007f47b07941d6 in KApplication::notify (this=0x7fffc58904d0, receiver=0x240b2b0, event=0x7fffc588efe0) at ../../kdeui/kernel/kapplication.cpp:311
0000036 0x00007f47adaab56e in QCoreApplication::notifyInternal (this=0x7fffc58904d0, receiver=0x240b2b0, event=0x7fffc588efe0) at kernel/qcoreapplication.cpp:915
0000037 0x00007f47ae6a3043 in sendEvent (event=0x7fffc588efe0, receiver=0x240b2b0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
0000038 sendUpdateRequest (updateImmediately=true, widget=0x240b2b0) at painting/qbackingstore.cpp:534
0000039 QWidgetBackingStore::markDirty (this=<optimized out>, rect=..., widget=<optimized out>, updateImmediately=<optimized out>, invalidateBuffer=<optimized out>) at painting/qbackingstore.cpp:722
0000040 0x00007f47ae4cf419 in repaint (rect=..., this=0x27fd6f0) at kernel/qwidget.cpp:10466
0000041 QWidget::repaint (this=0x27fd6f0, rect=...) at kernel/qwidget.cpp:10444
0000042 0x00007f47ae4cf4d3 in QWidget::repaint (this=<optimized out>) at kernel/qwidget.cpp:10416
0000043 0x00007f47ae84c53d in QAbstractButtonPrivate::click (this=this@entry=0x34cd5d0) at widgets/qabstractbutton.cpp:536
0000044 0x00007f47ae84c7cc in QAbstractButton::mouseReleaseEvent (this=0x27fd6f0, e=0x7fffc588f920) at widgets/qabstractbutton.cpp:1123
0000045 0x00007f47ae90699a in QToolButton::mouseReleaseEvent (this=<optimized out>, e=<optimized out>) at widgets/qtoolbutton.cpp:718
0000046 0x00007f47ae4dd850 in QWidget::event (this=0x27fd6f0, event=0x7fffc588f920) at kernel/qwidget.cpp:8371
0000047 0x00007f47ae48de9c in QApplicationPrivate::notify_helper (this=this@entry=0x21385e0, receiver=receiver@entry=0x27fd6f0, e=e@entry=0x7fffc588f920) at kernel/qapplication.cpp:4562
0000048 0x00007f47ae492b6b in QApplication::notify (this=<optimized out>, receiver=0x27fd6f0, e=0x7fffc588f920) at kernel/qapplication.cpp:4105
0000049 0x00007f47b07941d6 in KApplication::notify (this=0x7fffc58904d0, receiver=0x27fd6f0, event=0x7fffc588f920) at ../../kdeui/kernel/kapplication.cpp:311
0000050 0x00007f47adaab56e in QCoreApplication::notifyInternal (this=0x7fffc58904d0, receiver=0x27fd6f0, event=0x7fffc588f920) at kernel/qcoreapplication.cpp:915
0000051 0x00007f47ae48ecd3 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
0000052 QApplicationPrivate::sendMouseEvent (receiver=0x27fd6f0, event=0x7fffc588f920, alienWidget=0x0, nativeWidget=0x27fd6f0, buttonDown=0x7f47aef6a308 <qt_button_down>, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3173
0000053 0x00007f47ae50c554 in QETWidget::translateMouseEvent (this=this@entry=0x27fd6f0, event=event@entry=0x7fffc58900a0) at kernel/qapplication_x11.cpp:4622
0000054 0x00007f47ae50b44f in QApplication::x11ProcessEvent (this=0x7fffc58904d0, event=0x7fffc58900a0) at kernel/qapplication_x11.cpp:3737
0000055 0x00007f47ae532fa2 in x11EventSourceDispatch (s=0x21355a0, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
0000056 0x00007f47a8bc9ab5 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000057 0x00007f47a8bc9de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#58 0x00007f47a8bc9ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000059 0x00007f47adad9bf6 in QEventDispatcherGlib::processEvents (this=0x210ebb0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
0000060 0x00007f47ae532c1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
0000061 0x00007f47adaaa2bf in QEventLoop::processEvents (this=this@entry=0x7fffc5890470, flags=...) at kernel/qeventloop.cpp:149
0000062 0x00007f47adaaa548 in QEventLoop::exec (this=0x7fffc5890470, flags=...) at kernel/qeventloop.cpp:204
0000063 0x00007f47adaaf708 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
0000064 0x000000000045484b in ?? ()
0000065 0x00007f47ab76c76d in __libc_start_main (main=0x453bf0, argc=1, ubp_av=0x7fffc5890b18, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffc5890b08) at libc-start.c:226
0000066 0x0000000000454e31 in _start ()
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files? file icon kdenlive-20121212-220858.kcrash [^] (10,939 bytes) 2012-12-12 22:09 [Show Content]

- Relationships
duplicate of 0002790assignedj-b-m Kdenlive crashes on project scalling 
has duplicate 0002895closedj-b-m UI crashes sometimes when scrolling the timeline 

-  Notes
(0008757)
cweiske (reporter)
2012-12-12 22:08

Might be the same as bug 0002790.
(0008759)
j-b-m (administrator)
2012-12-12 22:19

I am wondering if this is a 64bit issue only. I cannot reproduce the problem, and buf 0002790 also was with Ubuntu 64bit... My guess is that it's a Qt problem on 64bit platform, but I have no way to test now. I will probably set up a 64bit system in the next 2 weeks, so hopefully I can investigate this...
(0008788)
Zuf (reporter)
2012-12-15 14:23
edited on: 2012-12-15 14:25

I also have this issue.
It can be 100% reproduced in my environment (Arch linux x86_64) with very tiny project (only one colour clip).

My test project: https://dl.dropbox.com/u/59794362/zoom-bug.tar.gz [^]
And video with this bug: https://dl.dropbox.com/u/59794362/zoom-bug.ogv [^]

(0008791)
eddrog (developer)
2012-12-15 17:20

>> 64bit issue

Can't confirm. I did several tests with Zufs project => no crash.
(0008796)
Zuf (reporter)
2012-12-15 18:41

Hm... After rebuild kdenlive with latest git this issue is gone for me. Perfect!

- Issue History
Date Modified Username Field Change
2012-12-12 22:07 cweiske New Issue
2012-12-12 22:08 cweiske Note Added: 0008757
2012-12-12 22:09 cweiske File Added: kdenlive-20121212-220858.kcrash
2012-12-12 22:19 j-b-m Note Added: 0008759
2012-12-12 22:19 j-b-m Relationship added duplicate of 0002790
2012-12-15 14:23 Zuf Note Added: 0008788
2012-12-15 14:25 Zuf Note Edited: 0008788 View Revisions
2012-12-15 17:20 eddrog Note Added: 0008791
2012-12-15 18:41 Zuf Note Added: 0008796
2012-12-25 23:56 j-b-m Relationship added has duplicate 0002895
2012-12-26 12:45 j-b-m Status new => resolved
2012-12-26 12:45 j-b-m Fixed in Version => Recent git
2012-12-26 12:45 j-b-m Resolution open => fixed
2012-12-26 12:45 j-b-m Assigned To => j-b-m
2013-01-28 19:49 j-b-m Fixed in Version Recent git => 0.9.4
2013-01-28 19:51 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker