Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002876KdenliveUser Interfacepublic2012-12-16 17:452013-04-07 08:45
Reportereddrog 
Assigned Toj-b-m 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platform64 bitOSUbuntuOS Version12.10
Product VersionRecent git 
Target VersionFixed in Version0.9.6 
Summary0002876: seeking forward not possible after reaching zone end
DescriptionAfter reaching zone end (playback stop) seeking forward is not possible. Seeking backwards is no problem.
Steps To Reproduce1) Clip in timeline + set zone
2) Play zone (CTRL+SPACE)
3) After reaching zone end (playback stopped) try to seek forward
TagsNo tags attached.
Build/Install MethodBuild Script
Attached Files

- Relationships
related to 0002914closedj-b-m Clicking pause in last second of clip has no effect. 

-  Notes
(0008809)
j-b-m (administrator)
2012-12-16 19:24

Should be fixed
(0008810)
eddrog (developer)
2012-12-16 19:45

Sorry. Is not solved yet for me!
(0008812)
j-b-m (administrator)
2012-12-16 20:01

Oh, I just re-read your bug description. In fact I just fixed forward / backwards playing, not seeking wich is much worse... should be done in a few minutes
(0008814)
eddrog (developer)
2012-12-16 21:24

It works only one time :-((

You have to start playback to be able to seek at all (forward and backward)

We are getting closer to the solution :-)))
(0008816)
j-b-m (administrator)
2012-12-16 23:44

It seems to work correctly for me. Can you please describe exactly the steps to reproduce (also let me know how you are trying to seek - using monitor button, keyboard shotcut,...)
(0008820)
eddrog (developer)
2012-12-17 10:15

Oh I see.

1) Clip in timeline + set zone
2) Play zone (CTRL+SPACE)
3) After reaching zone end (playback stopped) => seeking is ok
4) Play zone (CTRL+SPACE)
5) After reaching zone end (playback stopped)

=> try to seek forward/backward with dragging mouse (left key pressed) in timeline.
I didn't try the other methods. Perhaps it just does not work with dragging in timeline. Toggling playback reenables seeking.
(0008823)
j-b-m (administrator)
2012-12-17 17:38

Ok, I think I really fixed it now, please test.
(0008826)
eddrog (developer)
2012-12-17 21:06

Sorry. No change :-(((
(0008828)
j-b-m (administrator)
2012-12-18 01:25

Are you using OpenGL for video display (in Settings > Configure Kdenlive > Playback) ?
(0008830)
eddrog (developer)
2012-12-18 10:00

No. I have the default settings => sdl_preview consumer.

If you can't reproduce it I take a closer look at it next days.
(0008842)
j-b-m (administrator)
2012-12-21 02:22

I just did a cleanup of play / pause stuff, can you please try again now?
(0008843)
eddrog (developer)
2012-12-21 15:49

Sorry I'm on a business trip.

I saw that you replaced the producer->stop() call. I had trouble with it either. I think the set speed to zero approach is more performant [and more robust - I hope].

Ok this weekend I'll be home and I'll test it.

Hopefully the transport is clean now :-))
(0008847)
eddrog (developer)
2012-12-22 12:49

Now it is fixed for me too.

@j-b-m: there is still a minor issue in transport stopping. Sometimes the picture jumps to the next/previous after stopping.
(0008849)
eddrog (developer)
2012-12-22 19:26

I was to fast. I found some more problems with seeking in the zone mode. Will report after some more tests.
(0008876)
j-b-m (administrator)
2012-12-25 23:53

Ok, I just noticed that the problem happens when you try to seek just before the playhead reaches the zone end. It seems an MLT issue, in the same way that you cannot pause the clip monitor just before it reaches a clip's end.

Note that this is only an issue when using the SDL consumer, not when enabling OpenGL in Kdenlive's display settings.
(0008881)
j-b-m (administrator)
2012-12-26 00:45

Just pushed a workaround the MLT bug, please test when you can.
(0008903)
eddrog (developer)
2012-12-26 14:14

You got it. It was only a sdl consumer problem. The workaround works so far for me. But I want to do some more tests before closing this ticket.

I'm working on a video project the next days with the current git version. I'll gather all issues and fixes.
(0008915)
eddrog (developer)
2012-12-27 15:21

There must be still a little gap. Sporadic I get the problem but the steps are very very hard to reproduce. I'll be loud if I have the sequence. Otherwise it is only solvable in an analytic way :-(((
(0009187)
eddrog (developer)
2013-02-05 18:06

Cant reproduce it anymore. Ready for close.

- Issue History
Date Modified Username Field Change
2012-12-16 17:45 eddrog New Issue
2012-12-16 17:45 eddrog Status new => assigned
2012-12-16 17:45 eddrog Assigned To => j-b-m
2012-12-16 19:24 j-b-m Note Added: 0008809
2012-12-16 19:24 j-b-m Status assigned => feedback
2012-12-16 19:45 eddrog Note Added: 0008810
2012-12-16 19:45 eddrog Status feedback => assigned
2012-12-16 20:01 j-b-m Note Added: 0008812
2012-12-16 21:24 eddrog Note Added: 0008814
2012-12-16 23:44 j-b-m Note Added: 0008816
2012-12-17 10:15 eddrog Note Added: 0008820
2012-12-17 17:38 j-b-m Note Added: 0008823
2012-12-17 21:06 eddrog Note Added: 0008826
2012-12-18 01:25 j-b-m Note Added: 0008828
2012-12-18 10:00 eddrog Note Added: 0008830
2012-12-21 02:22 j-b-m Note Added: 0008842
2012-12-21 15:49 eddrog Note Added: 0008843
2012-12-22 12:49 eddrog Note Added: 0008847
2012-12-22 19:26 eddrog Note Added: 0008849
2012-12-25 23:53 j-b-m Note Added: 0008876
2012-12-26 00:45 j-b-m Note Added: 0008881
2012-12-26 14:14 eddrog Note Added: 0008903
2012-12-27 15:21 eddrog Note Added: 0008915
2012-12-30 17:59 j-b-m Relationship added related to 0002914
2013-02-05 18:06 eddrog Note Added: 0009187
2013-02-05 18:06 eddrog Status assigned => resolved
2013-02-05 18:06 eddrog Resolution open => fixed
2013-04-07 08:45 j-b-m Fixed in Version => 0.9.6
2013-04-07 08:45 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker