Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002885KdenliveBuild Systempublic2012-12-22 17:182013-05-02 15:46
Reporterasilnevs 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilitysometimes
StatusassignedResolutionopen 
Platform64bitOSUbuntuOS Version12.04
Product VersionRecent git 
Target VersionFixed in Version 
Summary0002885: Kdenlive crashes immediate after starting up, probably due to ShuttlePro v2 connection
DescriptionIf I start up Kdenlive (via terminal) then the program will immediate stop gives this message in the terminal, it's the result of a few trials before it keeps working:
jef@jef-desktop:~$ kdenlive
QWidget::insertAction: Attempt to insert null action
QWidget::insertAction: Attempt to insert null action
[xcb] Unknown sequence number while appending request
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
kdenlive: ../../src/xcb_io.c:160: append_pending_request: Controletest '!xcb_xlib_unknown_seq_number' faalt.
kdenlive: Fatal IO error 9 (Ongeldige bestandsdescriptor) on X server :0.
KCrash: Application 'kdenlive' crashing...
Fatal Error: Accessed global static 'KGlobalPrivate *globalData()' after destruction. Defined at ../../kdecore/kernel/kglobal.cpp:127
Unable to start Dr. Konqi
jef@jef-desktop:~$ kdenlive
QWidget::insertAction: Attempt to insert null action
QWidget::insertAction: Attempt to insert null action
[mpegts @ 0x46844a0] max_analyze_duration reached
[mpegts @ 0x4686d80] max_analyze_duration reached
[mpegts @ 0x46a6320] max_analyze_duration reached
[mpegts @ 0x469b660] max_analyze_duration reached
[mpegts @ 0x46a3e20] max_analyze_duration reached
[mpegts @ 0x47e48c0] max_analyze_duration reached
[mpegts @ 0x47d57a0] max_analyze_duration reached
[mpegts @ 0x47db700] max_analyze_duration reached
[mpegts @ 0x47dbe00] max_analyze_duration reached
[mpegts @ 0x4b792a0] max_analyze_duration reached
[mpegts @ 0x4b7d440] max_analyze_duration reached
[mpegts @ 0x4b96fc0] max_analyze_duration reached
[mpegts @ 0x4b9e560] max_analyze_duration reached
[mpegts @ 0x4cd9f60] max_analyze_duration reached
[mpegts @ 0x4cc7940] max_analyze_duration reached
[mpegts @ 0x4cc96a0] max_analyze_duration reached
[mpegts @ 0x4cce340] max_analyze_duration reached
[mpegts @ 0x4e015a0] max_analyze_duration reached
[mpegts @ 0x4e07dc0] max_analyze_duration reached
[mpegts @ 0x4f46b40] max_analyze_duration reached
[mpegts @ 0x4f349c0] max_analyze_duration reached
[mpegts @ 0x4f372e0] max_analyze_duration reached
[mpegts @ 0x507ed20] max_analyze_duration reached
[mpegts @ 0x7feb80005740] max_analyze_duration reached
[mpegts @ 0x7feb8000d700] max_analyze_duration reached
[mpegts @ 0x7feb80028be0] max_analyze_duration reached
kdenlive(19232)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
kdenlive(19232)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
jef@jef-desktop:~$ kdenlive
QWidget::insertAction: Attempt to insert null action
QWidget::insertAction: Attempt to insert null action
[xcb] Unknown sequence number while appending request
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
kdenlive: ../../src/xcb_io.c:160: append_pending_request: Controletest '!xcb_xlib_unknown_seq_number' faalt.
kdenlive: Fatal IO error 9 (Ongeldige bestandsdescriptor) on X server :0.
kDebugStream called after destruction (from virtual void ShuttleThread::run() file kdenlive-0.9.3+git20121219.836ab975/src/jogshuttle.cpp line 129)
Onderbroken systeemaanroep
 
jef@jef-desktop:~$ kdenlive
QWidget::insertAction: Attempt to insert null action
QWidget::insertAction: Attempt to insert null action
[xcb] Unknown sequence number while appending request
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
kdenlive: ../../src/xcb_io.c:160: append_pending_request: Controletest '!xcb_xlib_unknown_seq_number' faalt.
kdenlive: Fatal IO error 9 (Ongeldige bestandsdescriptor) on X server :0.
kDebugStream called after destruction (from virtual void ShuttleThread::run() file kdenlive-0.9.3+git20121219.836ab975/src/jogshuttle.cpp line 129)
Onderbroken systeemaanroep
 
KCrash: Application 'kdenlive' crashing...
Fatal Error: Accessed global static 'KGlobalPrivate *globalData()' after destruction. Defined at ../../kdecore/kernel/kglobal.cpp:127
Unable to start Dr. Konqi
jef@jef-desktop:~$ kdenlive
QWidget::insertAction: Attempt to insert null action
QWidget::insertAction: Attempt to insert null action
[mpegts @ 0x4492460] max_analyze_duration reached
[mpegts @ 0x4498440] max_analyze_duration reached
[mpegts @ 0x44b63c0] max_analyze_duration reached
[mpegts @ 0x44ac380] max_analyze_duration reached
[mpegts @ 0x44b26c0] max_analyze_duration reached
[mpegts @ 0x45d78c0] max_analyze_duration reached
[mpegts @ 0x46028c0] max_analyze_duration reached
[mpegts @ 0x4607a80] max_analyze_duration reached
[mpegts @ 0x4725460] max_analyze_duration reached
[mpegts @ 0x4986de0] max_analyze_duration reached
[mpegts @ 0x498ee40] max_analyze_duration reached
[mpegts @ 0x49a54a0] max_analyze_duration reached
[mpegts @ 0x49abf00] max_analyze_duration reached
[mpegts @ 0x4ae7540] max_analyze_duration reached
[mpegts @ 0x4ad5440] max_analyze_duration reached
[mpegts @ 0x4ad9160] max_analyze_duration reached
[mpegts @ 0x4add460] max_analyze_duration reached
[mpegts @ 0x4c0eac0] max_analyze_duration reached
[mpegts @ 0x4c14900] max_analyze_duration reached
[mpegts @ 0x4d4e7a0] max_analyze_duration reached
[mpegts @ 0x4d44a40] max_analyze_duration reached
[mpegts @ 0x4d48140] max_analyze_duration reached
[mpegts @ 0x4d4ada0] max_analyze_duration reached
[mpegts @ 0x7ff414005740] max_analyze_duration reached
[mpegts @ 0x7ff41400d700] max_analyze_duration reached
[mpegts @ 0x7ff414028be0] max_analyze_duration reached

Steps To ReproduceIt's hard to explain because sometimes it works from the first time and there are times that I have to try 4 times before Kdenlive keeps working.
Additional InformationKdenlive is installed with: http://ppa.launchpad.net/sunab/kdenlive-svn/ubuntu [^]
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Filestxt file icon crashreport1_FreezingAfterStartup.txt [^] (2,732 bytes) 2012-12-23 08:24 [Show Content]
txt file icon crashreport2.txt [^] (3,149 bytes) 2012-12-27 13:37 [Show Content]
? file icon kdenlive-20121230-140656.kcrash [^] (7,520 bytes) 2012-12-30 14:34 [Show Content]
? file icon kdenlive-20130101-140258.kcrash [^] (7,273 bytes) 2013-01-01 14:36 [Show Content]

- Relationships
related to 0002936new Kdenlive crahes when selecting 'Insert track', 'Delete track' or 'Modify track' in the menu. 

-  Notes
(0008848)
eddrog (developer)
2012-12-22 18:53

I don't think its the jogshuttle. But to be sure can you disable it in the config and try to start kdenlive. Please give feedback.
(0008850)
asilnevs (reporter)
2012-12-22 20:40

I did some tests with activating and deactivating the jogshuttle in the setup and also switching on and off the automatic startup of the last project I worked on. So this are 4 different situations. Everytime I did 10 tests (starting up Kdenlive in the terminal) and this is the result:
1)shuttle OFF and automatic startup of last project also OFF: 10 x ok
2)shuttle ON and automatic startup of last project OFF: 10 x ok
3)shuttle OFF and automatic startup of last project ON: 5 x ok and 5 x nok
4)shuttle ON and automatic startup of last project ON: 2 x ok and 8 x nok
If I will do this last 2 test over again I am sure the result could be very different.
I must say that Kdenlive crashes a lot in the beginning when I am starting with a new project (making a new map, loading the first clip....). But I don't know that this has something to do with my major problem (starting Kdenlive).
I think it's better to first focus on the starting of Kdenlive, and when that problem could be solved then look for the other crashes and freezes.
If you need more info just ask and I will try to give it.
Thanks anyway.
(0008851)
eddrog (developer)
2012-12-22 20:52

I'm just wondering. You start "kdenlive" in the shell. If you use the build script you should go to the directory of the build date and call "start-kdenlive". Otherwise the environment is not set properly and it can have a lot of side effects with another installation.

e.g. ~/kdenlive-build-ng/20121222$ start-kdenlive or

bash# cd ~/kdenlive-build-ng/20121222/bin
bash# . ./kdenlive_env
bash# ./kdenlive
(0008852)
asilnevs (reporter)
2012-12-22 21:29

Now it's getting difficult for me to understand your technical explication ;-) .
In the last week I did a lot of videoediting and I always started Kdenlive in the normal way, this means with the icon on the left side off the screen. But because Kdenlive did sometimes freezes and I could not exit it in the normal way, I had to startup the Systemmonitor and distroy the proces (i am working with a Dutch installation so i am translating some things to English), I could not stop the proces only distroy it. Because this happened a lot of times I decided to startup Kdenlive in the terminal and then it was difficult for me to stop a freezed Kdenlive just by closing the terminal.
So I just did the above test again just by starting with the normal icon and this is the result:
1)shuttle OFF and automatic startup of last project also OFF: 10 x ok
2)shuttle ON and automatic startup of last project OFF: 10 x ok
3)shuttle OFF and automatic startup of last project ON: 1 x ok and 9 x nok
4)shuttle ON and automatic startup of last project ON: 7 x ok and 3 x nok
So there is no real difference as before.
If you want me to do some things in the terminal you have to tell me exact what to type because I am not familiar with those commandos.
(0008853)
eddrog (developer)
2012-12-22 21:39

I thought you use dan's build script. Ok how did you install recent git kdenlive?
(0008854)
asilnevs (reporter)
2012-12-22 21:51

Sorry for the confusion but I added the ppa like I told in the above "Additional information" and I think the discription is over here: https://launchpad.net/~sunab/+archive/kdenlive-svn [^]
Thanks for your quick responses.
(0008855)
eddrog (developer)
2012-12-22 22:33

Sorry overlooked the description. Please start kdenlive in gdb and send the log.

bash# gdb kdenlive
gdb# run

proceed until crash

gdb# thread apply all bt

copy crash report and upload the file here
(0008856)
asilnevs (reporter)
2012-12-23 08:34

I just uploaded crashreport1.
After the run command, Kdenlive started uo, but immediatly freezes. There was no project loaded although it should.
I don't know that this is the same bug as I originally posted, because Kdenlive always crashed before (and disappears), now it freezes.
I hope you can find something with the crashreport.
(0008913)
eddrog (developer)
2012-12-27 12:51

@j-b-m: this is pretty weird. Do you have an idea?
(0008914)
asilnevs (reporter)
2012-12-27 13:37

I just updated with todays git: 20121227 and did the test again with ShuttleProV2 connected and automatic startup of latest project.
The result is still te same, 5 times a good startup and 5 times Kdenlive crashes (= just dissappears).
So I started again with:
bash# gdb kdenlive
gdb# run
But in this way Kdenlive starts up and freezes with a normal screen without my project loaded.
Then I did:
gdb# thread apply all bt
and this gives crashreport2 that I uploaded.
I thought that this problem would also be solved with all the other bugs of the last days that you guys repaired but it's not :-)
(0008918)
j-b-m (administrator)
2012-12-27 23:06

Well I don't really know what is happening here but from your reports, the problem only seems to happen when "Open last project" is enabled. I just committed a small change in the order things are done when opening Kdenlive that might help. Can you test it on the next sunab's update?
(0008953)
asilnevs (reporter)
2012-12-30 14:33
edited on: 2012-12-30 14:36

I just update Kdenlive with the latest GIT (20121230) and I still have the same problem, so 4 times off 10 Kdenlive crashed when starting (with automatic loading of the latest project). I will upload a crashreport. I also tested the starting of Kdenlive without a project and afterwards starting and loading a project manually, in these cases there are no problems.
Could the problem be related to a very fast computer?
These are the components:
Corsair Midi Tower Carbide 500R ATX, No PSU (zwart)
Corsair Voeding HX850W 850W, Modulair
Asus P8P67 PRO B3 Rev.3.1 iP67, SATA600 , USB3.0
Intel Core i7 2600K 3.40GHz 8MB Box
Corsair 4x4GB, DDR3, PC12800, CL9, Vengeance, LP
EVGA Videokaart PCI-e GeForce GTX560 Ti 2GB 2xDVI/HDMI
Crucial SSD 2.5", 128GB, SATA600, m4 (for Ubuntu and the programs)
Hitachi Harddisk 3.5" 2TB, SATA600, 7200rpm, HDS723020BLA642 (for my source files)
Seagate Harddisk 3.5" 500GB, SATA600, 7200rpm, ST500DM002 (for my rendered files)
Lite-On DVD-/+/RAM IHAS324-32 24x/24x/12x SATA (zwart)
Sweex Card Reader CR005V3 All-in-1 Intern 3,5" USB2.0

Anyway, thanks for your effort and this great program :-)

(0008954)
eddrog (developer)
2012-12-30 15:21

Thank you. Jean-Baptiste's guess was correct and now we have the proof.

>> Could the problem be related to a very fast computer?

Maybe. Because I can't reproduce it. Fact is we have a gap in the loading. We have to take a closer look to it.

Please stay tuned.

BTW: you have a ShuttlePro v2 - does all buttons work and the jog/shuttle like expected? I contributed some patches but could not test. I just own a ShuttleXpress.
(0008957)
asilnevs (reporter)
2012-12-30 15:55

So, faster is not always better :-)
The ShuttlePro v2 works fantastic besides that it sometimes stops working.
Then I have to go to the menu: Settings - Configure Kdenlive and just click OK and then it starts working again. This sometimes appears after a long time, or sometimes after a few seconds working. I want to make a bugreport in the future but I will wait until I have more experience with it.
Thanks for asking.
And yes, I will stay tuned.
(0008958)
j-b-m (administrator)
2012-12-30 16:02

This bug is not that easy to fix since I cannot reproduce despite having a really fast PC. I just committed a small change that might reduce possible concurrency issues when loading a project, let us know when you can test it.
(0008959)
asilnevs (reporter)
2012-12-30 16:07

ok, I will test this as soon as new updates arrive.
Thanks
(0008974)
eddrog (developer)
2012-12-31 10:07

>> The ShuttlePro v2 works fantastic besides that it sometimes stops working.

I would very appreciate test reports. With ShuttleXpress it works just perfect with no exits. It sounds for me that you run in a condition for exiting the shuttle thread. But before investigating I'll wait for more infos.
(0008978)
asilnevs (reporter)
2012-12-31 11:00

Eddrog: I added a new bug report concerning the ShuttlePro v2 because I don't want to mess up this bugreport.
http://www.kdenlive.org/mantis/view.php?id=2918 [^]
(0008989)
asilnevs (reporter)
2013-01-01 14:36

Bad news, I just tested the new version (git-20121231) and Kdenlive is still crashing at startup (automatic startup of last project enabled).
I also have a laptop with the same software as my fast desktop computer, but with a Intel DUO T9600 CPU 2.8GHz and only 4Gig of RAM and Kdenlive crashes just a few times. Compared to the fast computer it's 1 to 10 and I did this with the same videofiles on both systems.
I also has a feeling that because off the fast system, a lot off other crashes appear at just pressing a button in Kdenlive ( at saving, add a file to the timeline, beginning a new project.....).
The Shuttle Pro v2 also stops working more often on my fast computer compared to my laptop.
This is a very annoying bug to solve but one time I hope it can be solved.
I just bought this computer especially for video editing , but I think it's a little bit to fast.
I did a succesfully memory test today to be sure that there are no problems with it.
I will upload a new crashreport (= crash at starting up).
Thanks and Happy New Year.
(0009121)
j-b-m (administrator)
2013-01-25 19:30

The crashes seem related to SDL's display and I am wondering if the issue is related to your nvidia drivers. If you have a fast computer, you can try using the OpenGL display in Kdenlive. It is not optimized but might solve some of your crashes.

Enable it in Kdenlive through: Settings > Configure Kdenlive > Playback > Use OpenGL
(0009122)
asilnevs (reporter)
2013-01-25 21:51

Yes, this seems to be a solution. Kdenlive did not crash anymore when starting up with the last used project.
Also this problem seems to be solved: http://kdenlive.org/mantis/view.php?id=2936 [^]
Is that possible?
Thanks for the suggestion.
(0009123)
asilnevs (reporter)
2013-01-26 11:57

Unfortunately changing to OpenGL gives more freezes of Kdenlive.
(0009130)
j-b-m (administrator)
2013-01-27 23:33

Hmmm, too bad. Still I am wondering if you problems come from the nvidia drivers. Are you using the last version of these drivers?

Is it possible for you to try using the open source nouveau driver to see if Kdenlive also crashes with this driver?
(0009517)
owo (reporter)
2013-05-02 15:43
edited on: 2013-05-02 15:46

> Unfortunately changing to OpenGL gives more freezes of Kdenlive.

Same here, with NVIDIA-Linux-x86_64-310.44

(Should I open a new bug-report?)


- Issue History
Date Modified Username Field Change
2012-12-22 17:18 asilnevs New Issue
2012-12-22 18:50 eddrog Assigned To => eddrog
2012-12-22 18:50 eddrog Status new => assigned
2012-12-22 18:53 eddrog Note Added: 0008848
2012-12-22 20:40 asilnevs Note Added: 0008850
2012-12-22 20:52 eddrog Note Added: 0008851
2012-12-22 21:29 asilnevs Note Added: 0008852
2012-12-22 21:39 eddrog Note Added: 0008853
2012-12-22 21:51 asilnevs Note Added: 0008854
2012-12-22 22:33 eddrog Note Added: 0008855
2012-12-23 08:24 asilnevs File Added: crashreport1_FreezingAfterStartup.txt
2012-12-23 08:34 asilnevs Note Added: 0008856
2012-12-27 12:50 eddrog Assigned To eddrog => j-b-m
2012-12-27 12:51 eddrog Note Added: 0008913
2012-12-27 13:37 asilnevs Note Added: 0008914
2012-12-27 13:37 asilnevs File Added: crashreport2.txt
2012-12-27 23:06 j-b-m Note Added: 0008918
2012-12-30 14:33 asilnevs Note Added: 0008953
2012-12-30 14:34 asilnevs File Added: kdenlive-20121230-140656.kcrash
2012-12-30 14:36 asilnevs Note Edited: 0008953 View Revisions
2012-12-30 15:21 eddrog Note Added: 0008954
2012-12-30 15:55 asilnevs Note Added: 0008957
2012-12-30 16:02 j-b-m Note Added: 0008958
2012-12-30 16:07 asilnevs Note Added: 0008959
2012-12-31 10:07 eddrog Note Added: 0008974
2012-12-31 11:00 asilnevs Note Added: 0008978
2013-01-01 14:36 asilnevs Note Added: 0008989
2013-01-01 14:36 asilnevs File Added: kdenlive-20130101-140258.kcrash
2013-01-25 19:30 j-b-m Note Added: 0009121
2013-01-25 21:51 asilnevs Note Added: 0009122
2013-01-26 11:57 asilnevs Note Added: 0009123
2013-01-26 16:27 j-b-m Relationship added related to 0002936
2013-01-27 23:33 j-b-m Note Added: 0009130
2013-05-02 15:43 owo Note Added: 0009517
2013-05-02 15:46 owo Note Edited: 0009517 View Revisions


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker