Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002893KdenliveUser Interfacepublic2012-12-24 18:552013-01-28 19:51
ReporterGMaq 
Assigned Toj-b-m 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformDebian Linux 6.0 Squeeze 32bitOSAV LinuxOS Version6.0
Product VersionRecent git 
Target VersionFixed in Version0.9.4 
Summary0002893: Clicking on monitor ruler causes GUI to go unresponsive
DescriptionOn GIT build from Dec 23 rev. v0.9.2-337-gcc750a2 if any scrolling or activity is done on the monitor ruler Kdenlive's GUI ceases to respond, further to that if I switch between workspaces and return to the Kdenlive workspace the GUI has lots of missing portions. This particular build is completely unusable. Also the in point and out point indicators (in red) will display above the monitor ruler at inapprpriate times (ie when an in or out point has not been selected)

If I revert back to a previous GIT build from December 19 then Kdenlive behaves as normal. I am using the nVidia nouveau driver for my display and I don't have OpenGL enabled in the Kdenlive preferences. I'm pretty sure there was a commit relating to using the project monitor with OpenGL between these versions, whether that has anything to do with this issue I can't say.
Steps To Reproduce1. Build rev. v0.9.2-337-gcc750a2 from GIT source
2. Install over previous GIT build
3. Open Kdenlive without importing any clips
4. Drag the mouse on the timeline ruler under the clip monitor
5. Kdenlive UI goes unresponsive and display is corrupted
Additional InformationTerminal output from a session where this happens (Appears to be not very useful)

glen@av6devdesk:~$ kdenlive
kdenlive(30425) MainWindow::parseProfiles: RESULTING MLT PATH: "/usr/share/mlt/profiles/"
kdenlive(30425) RecMonitor::RecMonitor: /////// BUILDING MONITOR, ID: 73400614
Object::connect: No such signal NotesWidget::aboutToShowContextMenu(QMenu *)
kdenlive(30425) MainWindow::loadPlugins: Parsing plugin folder: "/usr/lib/kde4/"
kdenlive(30425) MainWindow::loadPlugins: Found plugin: "libkdenlive_sampleplugin.so"
kdenlive(30425) MainWindow::addToMenu: // ADD to MENU ("Countdown", "Noise")
QWidget::insertAction: Attempt to insert null action
QWidget::insertAction: Attempt to insert null action
kdenlive(30425) KdenliveDoc::setProfilePath: Kdenlive document, init timecode from path: "dv_ntsc" , 29.97
kdenlive(30425) TrackView::slotAddProjectTrack: ************* ADD DOC TRACK 4 , DURATION: 0
kdenlive(30425) TrackView::slotAddProjectTrack: ************* ADD DOC TRACK 3 , DURATION: 0
kdenlive(30425) TrackView::slotAddProjectTrack: ************* ADD DOC TRACK 2 , DURATION: 0
kdenlive(30425) TrackView::slotAddProjectTrack: ************* ADD DOC TRACK 1 , DURATION: 0
kdenlive(30425) TrackView::slotAddProjectTrack: ************* ADD DOC TRACK 0 , DURATION: 0
kdenlive(30425) TrackView::parseDocument: /////////// TOTAL PROJECT DURATION: 300
kdenlive(30425) Render::resetProfile: reset to same profile, nothing to do
kdenlive(30425) Render::checkMaxThreads: // MLT threads updated to: 10
kdenlive(30425) Render::setSceneList: // NEW SCENE LIST DURATION SET TO: 2
kdenlive(30425) MainWindow::connectDocument: /////////////////// CONNECTING DOC TO PROJECT VIEW ////////////////
TagsNo tags attached.
Build/Install MethodManual build from Git
Attached Files

- Relationships
related to 0002892assignedj-b-m Constant segfaults and crashing with todays (24th Dec) sunab 'unstable' build 

-  Notes
(0008870)
j-b-m (administrator)
2012-12-25 01:29

Should be fixed in current git, please test
(0008872)
GMaq (reporter)
2012-12-25 17:46
edited on: 2012-12-25 17:47

Tested with GIT Version 0.9.3 (rev. v0.9.2-338-gb473496) and the issue is resolved. Repeated scrolling/scrubbing on monitor ruler and timeline work as normal.

Thanks and Merry Christmas!


- Issue History
Date Modified Username Field Change
2012-12-24 18:55 GMaq New Issue
2012-12-25 00:37 j-b-m Assigned To => j-b-m
2012-12-25 00:37 j-b-m Status new => acknowledged
2012-12-25 01:29 j-b-m Relationship added related to 0002892
2012-12-25 01:29 j-b-m Note Added: 0008870
2012-12-25 01:29 j-b-m Status acknowledged => feedback
2012-12-25 17:46 GMaq Note Added: 0008872
2012-12-25 17:46 GMaq Status feedback => assigned
2012-12-25 17:47 GMaq Note Edited: 0008872 View Revisions
2012-12-26 00:00 j-b-m Status assigned => resolved
2012-12-26 00:00 j-b-m Fixed in Version => Recent git
2012-12-26 00:00 j-b-m Resolution open => fixed
2013-01-28 19:49 j-b-m Fixed in Version Recent git => 0.9.4
2013-01-28 19:51 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker