Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002895KdenliveUser Interfacepublic2012-12-25 23:402013-01-28 19:51
Reporterlxvidcut 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformIntel 64BitOSOpenSUSEOS Version12.2
Product VersionRecent git 
Target VersionFixed in Version0.9.4 
Summary0002895: UI crashes sometimes when scrolling the timeline
DescriptionUI crashes sometimes when I scroll the project timeline.
Steps To ReproduceFresh kdenlive start.
Load a project file with active proxy files.
(I suspect this crash won't appear with a project without proxies. I've cutted several old DV projects without proxies...)
Move timline scrollbar -> crash
TagsNo tags attached.
Build/Install MethodManual build from Git
Attached Files? file icon kdenlive-20121225-233054.kcrash [^] (8,413 bytes) 2012-12-25 23:40 [Show Content]

- Relationships
duplicate of 0002871closedj-b-m crash when zooming out timeline 
duplicate of 0002790assignedj-b-m Kdenlive crashes on project scalling 

-  Notes
(0008877)
j-b-m (administrator)
2012-12-25 23:57

Which graphic card / driver are you using?
(0008879)
lxvidcut (reporter)
2012-12-26 00:15

This is an Intel Core i7-2640M Laptop using processor graphic.
Driver is standard, which is provided with OpenSuse 12.2
Hope this lspci and insmod output will help. Otherwise please provide a command which I should type in.


lspci
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

insmod
Module Size Used by
des_generic 21415 0
ecb 12815 0
md4 12595 0
md5 12627 2
nls_utf8 12557 5
cifs 314953 6
xt_tcpudp 12884 4
xt_pkttype 12504 3
xt_LOG 17471 10
xt_limit 12711 10
af_packet 39358 2
nfs 458541 1
lockd 98018 1 nfs
fscache 61245 1 nfs
auth_rpcgss 45444 1 nfs
nfs_acl 12837 1 nfs
sunrpc 289968 14 nfs,lockd,auth_rpcgss,nfs_acl
snd_hda_codec_hdmi 36102 1
snd_hda_codec_realtek 81862 1
ip6t_REJECT 12939 3
nf_conntrack_ipv6 14497 4
nf_defrag_ipv6 18107 1 nf_conntrack_ipv6
ip6table_raw 12683 1
ipt_REJECT 12541 3
iptable_raw 12678 1
xt_CT 12717 4
iptable_filter 12810 1
ip6table_mangle 12700 0
nf_conntrack_netbios_ns 12665 0
nf_conntrack_broadcast 12589 1 nf_conntrack_netbios_ns
nf_conntrack_ipv4 15005 4
nf_defrag_ipv4 12729 1 nf_conntrack_ipv4
ip_tables 27239 2 iptable_raw,iptable_filter
xt_conntrack 12760 8
nf_conntrack 97545 6 nf_conntrack_ipv6,xt_CT,nf_conntrack_netbios_ns,nf_conntrack_broadcast,nf_conntrack_ipv4,xt_conntrack
ip6table_filter 12815 1
ip6_tables 27207 3 ip6table_raw,ip6table_mangle,ip6table_filter
x_tables 33967 15 xt_tcpudp,xt_pkttype,xt_LOG,xt_limit,ip6t_REJECT,ip6table_raw,ipt_REJECT,iptable_raw,xt_CT,iptable_filter,ip6table_mangle,ip_tables,xt_conntrack,ip6table_filter,ip6_tables
cpufreq_conservative 13783 0
cpufreq_userspace 13162 0
cpufreq_powersave 12618 0
fuse 86852 7
tpm_infineon 17536 0
arc4 12529 2
ppdev 17678 0
snd_hda_intel 33312 2
snd_hda_codec 136135 3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 13602 1 snd_hda_codec
snd_pcm 109282 3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_seq 69746 0
qcserial 12868 0
usb_wwan 20410 1 qcserial
acpi_cpufreq 18857 0
mperf 12667 1 acpi_cpufreq
snd_timer 29370 2 snd_pcm,snd_seq
snd_seq_device 14497 1 snd_seq
coretemp 13444 0
crc32c_intel 12901 0
ghash_clmulni_intel 13180 0
aesni_intel 51522 3
cryptd 16306 2 ghash_clmulni_intel,aesni_intel
aes_x86_64 17208 1 aesni_intel
usbserial 47315 2 qcserial,usb_wwan
sg 36394 0
qmi_wwan 13559 0
usbnet 36407 1 qmi_wwan
cdc_wdm 18805 1 qmi_wwan
uvcvideo 76392 0
videobuf2_core 32851 1 uvcvideo
videodev 111306 1 uvcvideo
videobuf2_vmalloc 13020 1 uvcvideo
videobuf2_memops 13608 1 videobuf2_vmalloc
snd 87206 13 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_seq,snd_timer,snd_seq_device
iwlwifi 354023 0
pcspkr 12718 0
joydev 17457 0
serio_raw 13371 0
mac80211 555559 1 iwlwifi
i2c_i801 17779 0
iTCO_wdt 17948 0
iTCO_vendor_support 13718 1 iTCO_wdt
rts_pstor 446046 0
sdhci_pci 22792 0
sdhci 38242 1 sdhci_pci
mmc_core 117686 2 sdhci_pci,sdhci
cfg80211 208339 2 iwlwifi,mac80211
rfkill 26009 2 cfg80211
soundcore 15047 1 snd
snd_page_alloc 18484 2 snd_hda_intel,snd_pcm
e1000e 210771 0
mei 80083 0
battery 18691 0
parport_pc 37265 0
parport 46310 2 ppdev,parport_pc
tpm_tis 19129 0
tpm 27104 2 tpm_infineon,tpm_tis
tpm_bios 13637 1 tpm
fujitsu_laptop 18947 0
ac 13097 0
microcode 35772 0
autofs4 42753 2
i915 505525 3
drm_kms_helper 51052 1 i915
drm 272508 4 i915,drm_kms_helper
i2c_algo_bit 13413 1 i915
video 19345 1 i915
xhci_hcd 141588 0
button 13906 1 i915
processor 44907 1 acpi_cpufreq
thermal_sys 24703 2 video,processor
scsi_dh_hp_sw 12894 0
scsi_dh_rdac 17408 0
scsi_dh_alua 17121 0
scsi_dh_emc 17258 0
scsi_dh 14554 4 scsi_dh_hp_sw,scsi_dh_rdac,scsi_dh_alua,scsi_dh_emc
(0008885)
j-b-m (administrator)
2012-12-26 01:31

I cannot reproduce the problem. The crash happens while drawing one of the transition in timeline. I don't know if the problem is a bug in Qt or something wrong elsewhere. I just committed a small change that might improve the situation but not sure. Which Qt version are you using?
(0008893)
lxvidcut (reporter)
2012-12-26 09:14

This is standard qt which is provided with OpenSuse 12.2
libqt 4.8.1 - 2.4.1-x86_64

After your small change in recent git I can not reproduce anymore. I tried several heavy scrolls and zooms. Seems to be stable now.

Thanks
Christian

- Issue History
Date Modified Username Field Change
2012-12-25 23:40 lxvidcut New Issue
2012-12-25 23:40 lxvidcut File Added: kdenlive-20121225-233054.kcrash
2012-12-25 23:56 j-b-m Relationship added duplicate of 0002871
2012-12-25 23:56 j-b-m Relationship added duplicate of 0002790
2012-12-25 23:57 j-b-m Note Added: 0008877
2012-12-25 23:57 j-b-m Assigned To => j-b-m
2012-12-25 23:57 j-b-m Status new => feedback
2012-12-26 00:15 lxvidcut Note Added: 0008879
2012-12-26 00:15 lxvidcut Status feedback => assigned
2012-12-26 01:31 j-b-m Note Added: 0008885
2012-12-26 09:14 lxvidcut Note Added: 0008893
2012-12-26 12:44 j-b-m Status assigned => resolved
2012-12-26 12:44 j-b-m Fixed in Version => Recent git
2012-12-26 12:44 j-b-m Resolution open => fixed
2013-01-28 19:49 j-b-m Fixed in Version Recent git => 0.9.4
2013-01-28 19:51 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker