Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002899KdenliveRenderingpublic2012-12-26 12:532013-01-07 17:55
Reporterpatkoscsaba 
Assigned Toj-b-m 
PriorityurgentSeveritymajorReproducibilityalways
StatusassignedResolutionopen 
Platform64 bitsOSSabayon LinuxOS Version10
Product Version0.9.2 
Target VersionFixed in Version 
Summary0002899: Audio clips are not cut where I visually cut them
DescriptionLet's say I record myself saying 'A-B-C-D-E-F-G' and save the result into an audio file (I tried ac3, mp3, flaac for this experiment).
 Than I bring up a new project and I add my audio file into it. Finally I add the audio file into an audio track. So far so good. The audio is indexed and the visual preview is correctly created. I see and hear what was recorded.

Next step I will cut the audio file into 7 pieces. One for each letter. Finally I will remove B and D. The remaining pieces can be sticked together, or left with spaces between them, it doesn't matter.

What I expect to hear is 'A-C-E-F-G'.

However, 4 out of 5 attempts to do a cut like this, I will hear: 'A-B-C-D-E'. F and G are cut out.

It's like the original sound track continues playing over the cut in half pieces. Sometimes it happens that it realizes this and tries to correct it, so I end up with even a bigger mess. Something like 'A-B-C-F-G'. Not only wrong, but also unpredictable.

A month or so ago I had no problems like this, but since than there were a lot of updates to my Linux... Here are the versions of the applications related to this problem:

localhost ~ # ffmpeg --version
 ffmpeg version 0.8.4, Copyright (c) 2000-2012 the Libav developers
 built on Oct 28 2012 14:08:59 with gcc 4.6.3

localhost ~ # melt --version
 melt 0.8.6

KDEnlive is v0.9.2, installed from Sabayon binary. KDE is v4.9.4. Pulse Audio is used. Audio hardware is on-board Intel Corporation NM10/ICH7 Family High Definition Audio Controller.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Filesgz file icon BugDemo.tar.gz [^] (1,136,726 bytes) 2013-01-07 17:55

- Relationships

-  Notes
(0008900)
patkoscsaba (reporter)
2012-12-26 12:54

There is also a thread on the KDEnlive forums I opened a while ago. 4000+ views and no answer. http://kdenlive.org/forum/sound-clips-are-not-cut-where-i-visually-cut-them [^]
(0008912)
patkoscsaba (reporter)
2012-12-27 11:42

Here are some further details. I observed 2 other audio problems that may be related to this bug:
- After I cut the audio and I play it from the beginning I hear, as I mentioned, something like "A-B-C-D-E". However, if I start to play inside the second slice, where "C" is now. I hear "C-D-E-F", so, KDEnlive somehow knows that there should be the sound "C" in the second slice. But again, it will fail to notice that "D" was cut out and will continue to play the original track. This is another "stone in the way" because even if I want to make occasional cuts, I have to listen again to at least 2 slices of before in order to be able to determine if there is actually a problem. Try to do that with 30 minutes soundtrack where you have to do 10 or more cuts... It will take half a day.
- I observed that the generated audio thumbnail is getting out of sync from the sound itself. I see this happen usually at around minutes 8-10 and than rising exponentially. However, the actual sound seems to remain in sync with the video. Only the thumbnail is messed up. Again, making sound cutting difficult, especially if you have to do micro-cuts where I am just trying to make some sentences sound more cursive.
(0008919)
patkoscsaba (reporter)
2012-12-28 11:58
edited on: 2012-12-28 11:59

I compiled the latest development version available at Dec. 27th 2012. In this one the problem is partially solved. If I cut bigger chunks out of the audio, it is cutting it properly.

However, with chunks less than 1 (one) second, or so, the problem is still present. I confirm this on 2 different computers, both my PC and my Laptop.

(0008936)
j-b-m (administrator)
2012-12-29 12:43

I cannot reproduce this with current development version. When switching to Kdenlive from 27th of december, did you also upgrade MLT?
(0008939)
patkoscsaba (reporter)
2012-12-29 14:03

When I switched to the development version I used your automated build script, without any options, it downloaded and recompiled MLT, ffmpeg, and a bunch of other stuff.

Here is an idea for an easier way to reproduce this. Record yourself talking a little bit slower. Record about 5 sentences or more, so that you have some material to work with. Save to ac3, or whatever format you want. Import clip and start cutting out the silence between the words. There will be a lot of small cuts. Do more than 10 such cuts. Than play from the beginning. And you will see that if not at the first 2-3 cut points, but later, it will surely do as I described.

If you will still not be able to reproduce this, I will provide you with a sound sample + the already cut kdenlive project which demonstrates the problem. But I can do this only next week, and I will do it only if you request it.

Thanks for the reply.
(0008940)
j-b-m (administrator)
2012-12-29 14:26

I still cannot reproduce, so rI would be interested in your files. You can create a simple project with cuts reproducing the bug and the in the "Project" menu, select "Archive Project".

Enable the "Compressed archive" option and it will create a .tar.gz file with project file and source clips that contains all I need.
(0009060)
patkoscsaba (reporter)
2013-01-07 17:54

Here you go. I recorded myself talking with small pauses between words, dropped the ac3 file into kdenlive, dragged it into an Audio track and started to cut out the small silent parts between the words so that there should be almost no silence.

When I set the cursor to the start of the file and hit space for play. It happens on the second or 3rd cut. You can actually hear the silence, and than it looses sync. Finally, somewhere at sec. 3-4 it tries to resync and you can here me "repeat" some word there. I did not cut the rest of the audio because this was enough.

Attachment in a minute...

- Issue History
Date Modified Username Field Change
2012-12-26 12:53 patkoscsaba New Issue
2012-12-26 12:54 patkoscsaba Note Added: 0008900
2012-12-27 11:42 patkoscsaba Note Added: 0008912
2012-12-28 11:58 patkoscsaba Note Added: 0008919
2012-12-28 11:59 patkoscsaba Note Edited: 0008919 View Revisions
2012-12-29 12:43 j-b-m Note Added: 0008936
2012-12-29 12:43 j-b-m Assigned To => j-b-m
2012-12-29 12:43 j-b-m Status new => feedback
2012-12-29 14:03 patkoscsaba Note Added: 0008939
2012-12-29 14:03 patkoscsaba Status feedback => assigned
2012-12-29 14:26 j-b-m Note Added: 0008940
2013-01-07 17:54 patkoscsaba Note Added: 0009060
2013-01-07 17:55 patkoscsaba File Added: BugDemo.tar.gz


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker