Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002915KdenliveFile Loadingpublic2012-12-30 11:572013-01-28 19:51
ReporterJuergen_Riedl 
Assigned Toj-b-m 
PriorityimmediateSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformIntelOSOpenSUSEOS Version12.1
Product Version0.9.2 
Target VersionFixed in Version0.9.4 
Summary0002915: Programm crashes by reading a 9GB mpeg2 ts Videofile
DescriptionI have recorded a HD Videofile from television using Kaffeine. After adding the clip into kdenlive the program chrases always. Working with video files up to 3GB there is no issue.
Steps To Reproducestart program, add clip into left window, a second later the program crashes
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files? file icon kdenlive-20121230-112324.kcrash [^] (5,849 bytes) 2012-12-30 11:57 [Show Content]

- Relationships

-  Notes
(0008949)
Juergen_Riedl (reporter)
2012-12-30 12:29

It chrases also by small files 40MB. It seems to be in issue reagarding H264 coding. avidemux-qt chrashes also, and in that index file it detects a h264 payload.
(0008956)
j-b-m (administrator)
2012-12-30 15:51

For some reason, looks like MLT is trying to use VDPAU which is an acceleration used on some NVidia cards, and that seems to cause the crash.
MLT provides a workaround to disable use of VDPAU through a environnment variable.
Can you try to start Kdenlive from a terminal using the following command and let me know if it fixes the crash?

export MLT_NO_VDPAU=1;kdenlive
(0008967)
j-b-m (administrator)
2012-12-30 18:02

The reporter confirmed that:
export MLT_NO_VDPAU=1

Fixes the crash. Maybe we should add an option in Kdenlive to disable VDPAU?

- Issue History
Date Modified Username Field Change
2012-12-30 11:57 Juergen_Riedl New Issue
2012-12-30 11:57 Juergen_Riedl File Added: kdenlive-20121230-112324.kcrash
2012-12-30 12:29 Juergen_Riedl Note Added: 0008949
2012-12-30 15:51 j-b-m Note Added: 0008956
2012-12-30 15:51 j-b-m Assigned To => j-b-m
2012-12-30 15:51 j-b-m Status new => feedback
2012-12-30 18:02 j-b-m Note Added: 0008967
2012-12-30 18:02 j-b-m Status feedback => resolved
2012-12-30 18:02 j-b-m Fixed in Version => Recent git
2012-12-30 18:02 j-b-m Resolution open => fixed
2013-01-28 19:49 j-b-m Fixed in Version Recent git => 0.9.4
2013-01-28 19:51 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker