Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002917KdenliveUser Interfacepublic2012-12-31 10:222013-04-07 08:45
Reportereddrog 
Assigned Toj-b-m 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platform64 bitOSUbuntuOS Version12.10
Product VersionRecent git 
Target VersionRecent gitFixed in Version0.9.6 
Summary0002917: Grouped clips in timeline can not be ungrouped
DescriptionGrouped clips in timeline can not be ungrouped after moving whole group. Solution was to edit project file and remove the group tags in xml [only possible for superuser :-)))]
Steps To Reproduce1) load (here) 50 clips into timeline
2) group clips
3) move whole group
4) try to ungroup => not possible => do changes in grouped clips not possible anymore :-(((
Additional InformationUngrouping should be possible always otherwise editing becomes a nightmare.
TagsNo tags attached.
Build/Install MethodBuild Script
Attached Files

- Relationships
has duplicate 0002919closededdrog Ungroup clip impossible 

-  Notes
(0008979)
j-b-m (administrator)
2012-12-31 11:33

Should be fixed now
(0008981)
eddrog (developer)
2012-12-31 13:35

Ungrouping works but it is possible to resize grouped clips - is this so wanted?
(0008982)
eddrog (developer)
2012-12-31 13:39

Another thing. If I select with CTRL+A and I have some locked tracks this function becomes useless (e.g. move clips not possible and so on). I guess the way it should work is - all not locked tracks should be selected and all functions like move ... should work! What do you think?
(0008984)
j-b-m (administrator)
2012-12-31 14:01

Good point. Should be fixed now
(0008991)
eddrog (developer)
2013-01-01 16:43

@jbm: How about the point http://www.kdenlive.org/mantis/view.php?id=2917#c8981 [^] ?

Steps to reproduce:

1) add several clips into timeline
2) group them
3) use the resize hotspot (drag with left mouse key pressed) => all grouped clips are resized. Is this so wanted?
(0008992)
eddrog (developer)
2013-01-01 16:50

Confirm fix for http://www.kdenlive.org/mantis/view.php?id=2917#c8982. [^]
(0008993)
eddrog (developer)
2013-01-01 16:57
edited on: 2013-01-01 17:20

resizing in this way http://www.kdenlive.org/mantis/view.php?id=2917#c8991 [^] causes timeline corruptions => bad

(0009036)
j-b-m (administrator)
2013-01-05 22:19

Ok, I admit that group resizing was behaving weirdly. I did not get timeline corruption but it was not what one expects. I now changed it to allow group resize only if all clips in group start or end at the same position, that way we can still resize clips with split audio. Ok for you?
(0009037)
eddrog (developer)
2013-01-05 22:28

Merged. I'll test it. Sorry had no time last days.

>>> I now changed it to allow group resize only if all clips in group start or end at the same position, that way we can still resize clips with split audio. Ok for you?

Yap - this is what I wanted to propose.
(0009038)
eddrog (developer)
2013-01-05 22:57

Looks good so far.

Ok one point. If several grouped splitted clips are ungrouped - the audio track gets ungrouped to. Is this so wanted?

Grouping audio with video has to be done separately for all clips that were grouped.
(0009039)
eddrog (developer)
2013-01-05 23:01

I whould suggest two ungrouping actions:

1) select group => ungroup (video + audio remain grouped) only the clip grouping becomes ungrouped

2) select clips for ungrouping video from audio
(0009177)
eddrog (developer)
2013-02-05 10:28

@j-b-m: what do you think about: http://www.kdenlive.org/mantis/view.php?id=2917#c9039 [^]
(0009253)
j-b-m (administrator)
2013-02-11 18:46

Before the 0.9.4 release, I tried to implement something like your proposal, but due to the awful code reponsible for timeline it was impossible. In fact, we currently cannot have groups in groups.

I plan to have this correctly implemented in the refactoring version, I have not yet looked at Till's new timeline code but for sure we need to have a more powerful grouping feature.
(0009255)
eddrog (developer)
2013-02-11 21:17

Oh I understand.

- Issue History
Date Modified Username Field Change
2012-12-31 10:22 eddrog New Issue
2012-12-31 10:22 eddrog Status new => assigned
2012-12-31 10:22 eddrog Assigned To => j-b-m
2012-12-31 11:33 j-b-m Note Added: 0008979
2012-12-31 11:36 eddrog Relationship added has duplicate 0002919
2012-12-31 13:35 eddrog Note Added: 0008981
2012-12-31 13:39 eddrog Note Added: 0008982
2012-12-31 14:01 j-b-m Note Added: 0008984
2013-01-01 16:43 eddrog Note Added: 0008991
2013-01-01 16:50 eddrog Note Added: 0008992
2013-01-01 16:57 eddrog Note Added: 0008993
2013-01-01 17:20 eddrog Note Edited: 0008993 View Revisions
2013-01-05 22:19 j-b-m Note Added: 0009036
2013-01-05 22:28 eddrog Note Added: 0009037
2013-01-05 22:57 eddrog Note Added: 0009038
2013-01-05 23:01 eddrog Note Added: 0009039
2013-02-05 10:28 eddrog Note Added: 0009177
2013-02-11 18:46 j-b-m Note Added: 0009253
2013-02-11 21:17 eddrog Note Added: 0009255
2013-02-11 21:17 eddrog Status assigned => resolved
2013-02-11 21:17 eddrog Resolution open => fixed
2013-04-07 08:45 j-b-m Fixed in Version => 0.9.6
2013-04-07 08:45 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker