Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002918KdenliveUser Interfacepublic2012-12-31 10:582013-09-08 11:54
Reporterasilnevs 
Assigned Toeddrog 
PrioritynormalSeverityminorReproducibilityrandom
StatusresolvedResolutionfixed 
PlatformUbuntu 12.04OSUbuntu LinuxOS Version12.04
Product VersionRecent git 
Target VersionFixed in Version 
Summary0002918: ShuttloPro v2 sometimes stops working after a while
DescriptionThe ShuttlePro v2 works fantastic besides that it sometimes stops working.
Then I have to go to the menu: Settings - Configure Kdenlive and just click OK and then it starts working again. This sometimes appears after a long time, or sometimes after a few seconds working.
I added this bug report because of Eddrog's question from another bug report: http://www.kdenlive.org/mantis/view.php?id=2885#bugnotes [^]
What can I do to help you to investigate this?
Thanks in advance.
Steps To ReproduceI can't reproduce because it seems that this happens randomly.
Additional InformationKdenlive is installed with: http://ppa.launchpad.net/sunab/kdenlive-svn/ubuntu [^]
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
(0008994)
eddrog (developer)
2013-01-01 17:19

Start kdenlive from console and process with kdenlive until jogshuttle stops to work. Copy output in console and upload it here to this ticket.
(0009046)
asilnevs (reporter)
2013-01-06 20:22

Until now I always started from console like you told me, but I never had the problem again. This is strange.
I hope the problem stays away otherwise I wil report it here.
(0009056)
eddrog (developer)
2013-01-07 10:08

Ok.
(0009179)
eddrog (developer)
2013-02-05 10:32

Some feedback here - otherwise I'll close the ticket as resolved!
(0009181)
asilnevs (reporter)
2013-02-05 16:08

That's fine for me. I suppose that this ticket can be reopened in case I can give you some usefull feedback?
Thanks anyway.
(0009182)
eddrog (developer)
2013-02-05 16:36

What does it mean: it works without problems until now or it is hard to reproduce and describe?
(0009183)
asilnevs (reporter)
2013-02-05 16:53

The problem sometimes appears but in that case I can't give you some feedback because I started Kdenlive in a normal way (with the icon on the left side).
And the times I started Kdenlive with the terminal the problem did not appear.
At this moment I don't have much videos to edit so it's hard to test.
(0009185)
eddrog (developer)
2013-02-05 16:57

Ok. I'll let the ticket open. If you have some usefull info let me know.
Thanks.
(0009263)
asilnevs (reporter)
2013-02-13 19:58

I had the problem 3 times in a few minutes.
The first was after I rendered a file, the 2nd was after I changed the height of the tracks and the 3thd was after I deleted a cutted video from the timeline.
Every time I just had to go to the JogShuttle menu and click on the OK button.
So everytime the next message appears in the timeline:
Failed to read event from Jog Shuttle FILE DESCRIPTOR (repeated 1 times)
Failed to read from Jog Shuttle FILE DESCRIPTOR. Stop thread: Onjuist apparaat
(0009264)
eddrog (developer)
2013-02-13 20:53

Thanks. I will see what I can do:

>> Failed to read from Jog Shuttle FILE DESCRIPTOR. Stop thread: Onjuist apparaat

Can you translate this: "Onjuist apparaat"
(0009265)
asilnevs (reporter)
2013-02-13 21:01

That's something like "improper device" or "incorrectly device"
(0009266)
eddrog (developer)
2013-02-13 21:14

Ok I found the exit criteria:

/* exit if device is not available */
if (errno == ENODEV)

This is the only error which exits the loop and it means that your device looses the connection. Is it an old one? Do you have another one for testing?

For me it looks like it is a hw problem.

Ok what we have to check if the device looses the connection for a short time or forever.

Are you able to use the build script?
(0009267)
asilnevs (reporter)
2013-02-13 21:28

My ShuttlePro V2 is brand new, 2 months old I think.
I'm not sure what you mean with: Are you able to use the build script?
My Kdenlive is installed very easy with the PPA that is explained over here:
https://launchpad.net/~sunab/+archive/kdenlive-svn [^]
What is it that you have in mind with the build script?
(0009270)
eddrog (developer)
2013-02-14 12:51

With this script you can build kdenlive from source and changes can be applied easy without pushing them to mainstream.

I don't have a ShuttlePro V2 I just have a Xpress and it works just fine without problems. I want to figure out what's wrong with ShuttlePro V2 and for this I have to do some test code. This I don't want to push to master repository. The PPA you are using is build from master repository.

Ok I'll think how to find a solution.
(0009274)
eddrog (developer)
2013-02-16 14:57

I pushed to repository a test software. I disabled the thread exit on enodev error. I want to see if the problem is for short time or permanent.

I think tomorrow you should have it in:

https://launchpad.net/~sunab/+archive/kdenlive-svn [^]

Please test it and give feedback. Start kdenlive from console.
(0009296)
asilnevs (reporter)
2013-02-18 19:57
edited on: 2013-02-18 20:14

I updated Kdenlive a few hours ago and started Kdenlive in the terminal.
At first sight it looked ok but after an hour that I was not working on this computer I wanted to continue to play with the Shuttle and I saw that it was generating continues messages:
Failed to read from Jog Shuttle FILE DESCRIPTOR. Stop thread: Onjuist apparaat
Failed to read from Jog Shuttle FILE DESCRIPTOR. Stop thread: Onjuist apparaat
Failed to read from Jog Shuttle FILE DESCRIPTOR. Stop thread: Onjuist apparaat
Failed to read from Jog Shuttle FILE DESCRIPTOR. Stop thread: Onjuist apparaat
......
After pressing OK in the Jogshuttle menu it was ok again.
During typing this Note the Shuttle again produces the above messages.
So unfortunatly the problem still exists.

(0009297)
eddrog (developer)
2013-02-18 22:44

I didn't disable the message. Ok this is "normal" if you get this message.

What is interesting: do you have a lot of this messages - some hundred or so?

And: Does the shuttle work though you get this error message or is the device dead?
(0009299)
asilnevs (reporter)
2013-02-19 08:21

The messages keeps going on and on, during this time the Shuttle is dead.
Only after I press OK in the Jogshuttle menu it's working again and no more messages appear.
Thanks for your time doing this.
(0009301)
eddrog (developer)
2013-02-19 19:34

This is what I expected but I wanted to be sure. The bad consequence is that the device looses the connection for permanent.

Do you have the possibility to try the device on a newer/other ubuntu version? I want to make sure that we don't have a device problem on your system.

I'll see what I can do to locate the problem!
(0009304)
asilnevs (reporter)
2013-02-19 22:39

I only can try it on another computer (laptop) but it's with the same Ubuntu 12.04 and also 64 bit.
Can this help?
(0009307)
eddrog (developer)
2013-02-20 20:53

Yes. If it is not to hard for you. Any info is appreciated.
(0009319)
eddrog (developer)
2013-02-23 16:43
edited on: 2013-02-23 16:44

Hi. Can you call the following command in console:

tail -f /var/log/kern.log | grep usb

and:

I)

a) unplug shuttle form usb
b) plug shuttle to usb

Provide me the info.

II)

can you play with the shuttle in kino
a) load some dv files and play around => bug reproducable?
b) let kino run with active shuttle => perhaps we reproduce this error on your machine with another programm => than it is a device problem and not a kdenlive one.

(0009329)
asilnevs (reporter)
2013-02-24 10:35

This is the info from I:
jef@jef-desktop:~$ tail -f /var/log/kern.log | grep usb
Feb 24 10:15:15 jef-desktop kernel: [ 2277.755776] usb 4-2: USB disconnect, device number 2
Feb 24 10:29:48 jef-desktop kernel: [ 3150.755569] usb 2-1.4: USB disconnect, device number 4
Feb 24 10:30:03 jef-desktop kernel: [ 3165.537670] usb 2-1.4: new low-speed USB device number 7 using ehci_hcd
Feb 24 10:30:03 jef-desktop kernel: [ 3165.639786] input: Contour Design ShuttlePRO v2 as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.4/2-1.4:1.0/input/input10
Feb 24 10:30:03 jef-desktop kernel: [ 3165.639957] generic-usb 0003:0B33:0030.0003: input,hidraw1: USB HID v1.10 Device [Contour Design ShuttlePRO v2] on usb-0000:00:1d.0-1.4/input0

II)I want to wait to try Kino because we are very busy with preparing our annually Filmgala of our videoclub and I don't want to mess up my pc's. For the first time we want to show all our shortfilms with Ubuntu instead of Microsoft :-)
So please to everyone, cross your fingers for me.
Afterwards I will continue testing the ShuttlePro.
(0009590)
asilnevs (reporter)
2013-08-10 08:25

At this moment I don't have any problems with the ShuttlePro so you can close this bug if you want. I am working with the Development install.
Thanks for the good work.

- Issue History
Date Modified Username Field Change
2012-12-31 10:58 asilnevs New Issue
2013-01-01 17:07 eddrog Assigned To => eddrog
2013-01-01 17:07 eddrog Status new => assigned
2013-01-01 17:19 eddrog Note Added: 0008994
2013-01-06 20:22 asilnevs Note Added: 0009046
2013-01-07 10:08 eddrog Note Added: 0009056
2013-01-07 10:08 eddrog Status assigned => feedback
2013-02-05 10:32 eddrog Note Added: 0009179
2013-02-05 16:08 asilnevs Note Added: 0009181
2013-02-05 16:08 asilnevs Status feedback => assigned
2013-02-05 16:36 eddrog Note Added: 0009182
2013-02-05 16:53 asilnevs Note Added: 0009183
2013-02-05 16:57 eddrog Note Added: 0009185
2013-02-13 19:58 asilnevs Note Added: 0009263
2013-02-13 20:53 eddrog Note Added: 0009264
2013-02-13 21:01 asilnevs Note Added: 0009265
2013-02-13 21:14 eddrog Note Added: 0009266
2013-02-13 21:28 asilnevs Note Added: 0009267
2013-02-14 12:51 eddrog Note Added: 0009270
2013-02-16 14:57 eddrog Note Added: 0009274
2013-02-18 19:57 asilnevs Note Added: 0009296
2013-02-18 20:14 asilnevs Note Edited: 0009296 View Revisions
2013-02-18 22:44 eddrog Note Added: 0009297
2013-02-19 08:21 asilnevs Note Added: 0009299
2013-02-19 19:34 eddrog Note Added: 0009301
2013-02-19 22:39 asilnevs Note Added: 0009304
2013-02-20 20:53 eddrog Note Added: 0009307
2013-02-23 16:43 eddrog Note Added: 0009319
2013-02-23 16:44 eddrog Note Edited: 0009319 View Revisions
2013-02-24 10:35 asilnevs Note Added: 0009329
2013-08-10 08:25 asilnevs Note Added: 0009590
2013-09-08 11:54 eddrog Status assigned => resolved
2013-09-08 11:54 eddrog Resolution open => fixed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker