Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002924KdenliveEffectspublic2013-01-01 22:592014-09-16 15:19
Reportercamillem 
Assigned Tosunab 
PrioritynormalSeveritycrashReproducibilityalways
StatusassignedResolutionopen 
Platform64 bitOSUbuntuOS Version12.04
Product VersionRecent git 
Target VersionFixed in Version 
Summary0002924: Crash when using Stabilize transcode
DescriptionThe application crashes when trying to stabilize a clip with transcode option
Steps To ReproduceAdd clip to project
Right Click > Clip jobs > Stabilize (transcode)
Leave default options
Validate
Crash
Additional InformationUsing kdenlive 0.9.3 (sunab's ppa)
Crash report attached
TagsNo tags attached.
Build/Install Method3rd party package
Attached Files? file icon kdenlive-20130101-224617.kcrash [^] (13,953 bytes) 2013-01-01 22:59 [Show Content]
? file icon kdenlive-20130122-084637.kcrash [^] (12,044 bytes) 2013-01-22 09:09 [Show Content]
? file icon kdenlive-20130129-224008.kcrash [^] (11,190 bytes) 2013-01-29 12:45 [Show Content]

- Relationships
duplicate of 0002900resolvedvpinon Crash when doing clip stabilize (transcode) 

-  Notes
(0009040)
ttguy (reporter)
2013-01-05 23:40

I can't reproduce this. Stabilze - transcode works for me

kdenlive 0.9.3+git20130104.5794e725-0ubuntu0~sunab~precise1
mlt 0.8.7+git20130101.40125287-0ubuntu0~sunab~precise1
frei0r 1.3.0+git20121105.496b4ee6-0ubuntu0~sunab~precise1
ffmpeg version 0.8.4-4:0.8.4-0ubuntu0.12.04.1

ubuntu 12.04
(0009050)
farid (developer)
2013-01-07 02:36

cant reproduce either.

using kdenlive-git and mlt-git.
(0009066)
ttguy (reporter)
2013-01-08 14:56
edited on: 2013-01-08 14:57

camillem - are you using the default values for parameters to destabilize transcode. Because I was just playing with the show parameter using show = 2 (which is supposed to be valid) but this caused the transcode to crash. When I said I could not reproduce I was accepting the defaults.

Running with non zero show is not something that is that useful according to transcodes author.

whoops. Just read your report again. - "Leave the default options - crash"

So I guess that is not it.

(0009067)
camillem (reporter)
2013-01-08 15:04

@ttguy : I can't reproduce it since I updated yesterday, but yes, that was using default settings.
 So maybe the best thing is to close this issue.
(0009071)
ttguy (reporter)
2013-01-09 15:00

This is a duplicate of http://www.kdenlive.org/mantis/view.php?id=2900 [^] (proably)
(0009114)
ttguy (reporter)
2013-01-22 09:08
edited on: 2013-01-22 09:09

Well now I can reproduce this.
kdenlive 0.9.3+git20130117.91ea0353-0ubuntu0~sunab~precise1
mlt 0.8.7+git20130109.ba392dac-0ubuntu0~sunab~precise1
frei0r 1.3.0+git20130119.c3fdd674-0ubuntu0~sunab~precise1

I am getting the crash every time

see backtrace kdenlive-20130122-084637.kcrash

(0009141)
ttguy (reporter)
2013-01-29 12:45
edited on: 2013-01-29 12:46

Still get this with 0.9.4 see kdenlive-20130129-224008.kcrash

mlt 0.8.8-0ubuntu0~sunab~precise1
kdenlive 0.9.4-ubuntu0~sunab~precise1
frei0r 1.3.0+git20130119.c3fdd674-0ubuntu0~sunab~precise1

(0009324)
fermin (reporter)
2013-02-23 21:40

Yep ttguy, I think your bug is a duplicate of my.
With last version (v0.9.4 from rpmfusion repo in fedora 18), I get same crash (segmentation fault). I attached a bugtrace in my report.
(0010319)
ttguy (reporter)
2014-09-12 17:06

vpinion has closed the duplicate with the comments "first stabilizers were not always stable, the latest one acivated in mlt & kdenlive is solving most issues"
I have a 30 Aug 2014 daily build of kdenlive so I looked in it to see if stabilize was working. But I can't find where it is now. Used to be in the "clip jobs" menu https://userbase.kde.org/images.userbase/thumb/4/48/Kdenlive_Right_click_project_tree_menu_0.9.6.png/300px-Kdenlive_Right_click_project_tree_menu_0.9.6.png [^]
But in my daily build this just has "Automatic Scene Split" and "reverse clip"
Where is the stablise options now ?
(0010322)
vpinon (administrator)
2014-09-15 12:14

It seems the daily builds don't include vid.stab library, neither in meltytech archives nor in sunab PPA...
could you update your scripts guys?
(I had difficulties to build it myself!)
(0010323)
pez4brian (developer)
2014-09-16 04:43

The build script is updated:
https://github.com/mltframework/mlt-scripts/commit/699694876a61e19eb4fd5de91a5409fb03ab36d1 [^]
vid.stab should be included in the daily builds starting tomorrow.
(0010325)
sunab (developer)
2014-09-16 15:19

The unstable ppa now includes vid.stab, mlt have been rebuilt against it.

@ttguy, stabilize(vid.stab) is back in "clip jobs".

- Issue History
Date Modified Username Field Change
2013-01-01 22:59 camillem New Issue
2013-01-01 22:59 camillem File Added: kdenlive-20130101-224617.kcrash
2013-01-05 23:40 ttguy Note Added: 0009040
2013-01-07 02:36 farid Note Added: 0009050
2013-01-08 14:56 ttguy Note Added: 0009066
2013-01-08 14:57 ttguy Note Edited: 0009066 View Revisions
2013-01-08 15:04 camillem Note Added: 0009067
2013-01-09 15:00 ttguy Note Added: 0009071
2013-01-22 09:08 ttguy Note Added: 0009114
2013-01-22 09:09 ttguy File Added: kdenlive-20130122-084637.kcrash
2013-01-22 09:09 ttguy Note Edited: 0009114 View Revisions
2013-01-29 12:45 ttguy Note Added: 0009141
2013-01-29 12:45 ttguy File Added: kdenlive-20130129-224008.kcrash
2013-01-29 12:46 ttguy Note Edited: 0009141 View Revisions
2013-02-23 21:40 fermin Note Added: 0009324
2013-02-23 21:46 j-b-m Relationship added duplicate of 0002900
2014-09-12 17:06 ttguy Note Added: 0010319
2014-09-15 12:14 vpinon Assigned To => pez4brian
2014-09-15 12:14 vpinon Status new => assigned
2014-09-15 12:14 vpinon Note Added: 0010322
2014-09-15 12:15 vpinon Assigned To pez4brian => sunab
2014-09-16 04:43 pez4brian Note Added: 0010323
2014-09-16 15:19 sunab Note Added: 0010325


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker