Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002925KdenliveFile Loadingpublic2013-01-02 22:372013-04-07 08:45
Reporterttguy 
Assigned Toj-b-m 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platform32 bit intel and alikeOSUbuntuOS Version12.04
Product VersionRecent git 
Target VersionFixed in Version0.9.6 
Summary0002925: kdenlives suggests project profile changes do not take effect as the clip loads into project tree
DescriptionSo I captured a H.264 / AVC / MPEG-4 clip without audio using Kazam screen caster.
And when you add this clip to the project tree kdenlive suggests I change my project profile to one that matches the clip - which I do. And then kdenlive reports "loading thumbnails" forever. If you to drop the file on the time line it complains "clip not ready". If you play the file in clip monitor the play head moves but the screen is blank.

Now if you select reload clip in the project tree the thumbnail of the clip changes its aspect ratio and you can then drop the clip on the time line and it will play. But the clip still on plays black in the clip monitor.
But if you delete clip from project and then reload it. Then it is playable in the clip monitor.

It looks like this is all to do with the project settings in place when you add the clip to the project tree. Because if I manually make my project settings match the clip I am about to add then I don't see this behaviour. It is only when Kdenlive suggests to change the project profile settings do I see the behaviour.

It seems to me that kdenlive does not make the project profile changes early enough in the load process.
Additional Informationkdenlive 0.9.3+git20130102.543c6a23-0ubuntu0~sunab~precise1
mlt 0.8.7+git20130101.40125287-0ubuntu0~sunab~precise1
TagsNo tags attached.
Build/Install Method(select)
Attached Files? file icon kazam_screen cast.mp4 [^] (2,454,172 bytes) 2013-01-02 22:37

- Relationships

-  Notes
(0009005)
ttguy (reporter)
2013-01-02 22:41

kazam_screen cast.mp4 is the file I was playing with when I discovered this. My default profile is DV/DVD Widescreen PAL and I have a custom profile of 1280 x 1024 15fps that matches the kazam_screen cast.mp4 file
(0009012)
j-b-m (administrator)
2013-01-03 19:24

I just pushed a change that should improve the situation, can you please test?
(0009027)
ttguy (reporter)
2013-01-05 10:04

Awesome. I just tested this and it is now fixed. Clip is not black in the clip monitor. Clip can be dragged to the time line. Clip updates its aspect ratio in the project tree preview automatically.

Sweet.

kdenlive 0.9.3+git20130104.5794e725-0ubuntu0~sunab~precise1
mlt 0.8.7+git20130101.40125287-0ubuntu0~sunab~precise1
frei0r 1.3.0+git20121105.496b4ee6-0ubuntu0~sunab~precise1
(0009355)
ttguy (reporter)
2013-02-27 14:57

This fix is still fixed on ...

frei0r 1.3.0+git20130119.c3fdd674-0ubuntu0~sunab~precise1
kdenlive 0.9.5+git20130226.ff989e5b-0ubuntu0~sunab~precise1
melt 0.8.8+git20130220.f03d0f54-0ubuntu0~sunab~precise1

You could close this mantis!

- Issue History
Date Modified Username Field Change
2013-01-02 22:37 ttguy New Issue
2013-01-02 22:37 ttguy File Added: kazam_screen cast.mp4
2013-01-02 22:41 ttguy Note Added: 0009005
2013-01-03 19:24 j-b-m Note Added: 0009012
2013-01-03 19:24 j-b-m Assigned To => j-b-m
2013-01-03 19:24 j-b-m Status new => feedback
2013-01-05 10:04 ttguy Note Added: 0009027
2013-01-05 10:04 ttguy Status feedback => assigned
2013-02-27 14:57 ttguy Note Added: 0009355
2013-02-27 21:05 j-b-m Status assigned => resolved
2013-02-27 21:05 j-b-m Fixed in Version => 0.9.4
2013-02-27 21:05 j-b-m Resolution open => fixed
2013-04-07 08:45 j-b-m Fixed in Version 0.9.4 => 0.9.6
2013-04-07 08:45 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker