Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002928KdenliveUser Interfacepublic2013-01-06 16:162013-01-28 19:51
ReporterGMaq 
Assigned Toj-b-m 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformDebian Squeeze 32bitOSAV LinuxOS Version6.0
Product VersionRecent git 
Target VersionFixed in Version0.9.4 
Summary0002928: Video thumbnails and Audio waveforms broken when changing track sizes
DescriptionIf I add a clip to the timeline with the tracks set to the default track size there are no video thumbnails but the audio waveforms are displayed, If I expand the track to a larger view then both Video thumbnails and Audio waveforms disappear.

Screen shots attached below.
Steps To Reproduce1. Open a project
2. Add clip to a video track
3. Thumbnails will be missing at either end of the clip
4. Expand track viewing size with track expander buttons
5. Video waveforms will disappear
Additional InformationScreenshots:

http://bandshed.net/images/screenshots/thumbs1.png [^]
http://bandshed.net/images/screenshots/thumbs2.png [^]
TagsNo tags attached.
Build/Install MethodManual build from Git
Attached Files

- Relationships

-  Notes
(0009045)
GMaq (reporter)
2013-01-06 16:59

Could this be related to this commit?:
http://quickgit.kde.org/?p=kdenlive.git&a=commit&h=d1019376c0152c14e307f52413152d538163ccf7 [^]
(0009062)
GMaq (reporter)
2013-01-07 18:53

OK,

I can confirm that the above commit has caused the issue (in my case anyway), if I revert and install a GIT build from January 3rd the track Video Thumbnails and Audio waveforms display as normal and even when tracks are expanded in size the Video thumbnails and Audio waveforms display as usual. Possible this is an issue only affecting older QT/KDE versions?
(0009068)
GMaq (reporter)
2013-01-08 22:08

OK, as an experiment I pulled GIT from 20120108 and did 'git revert d1019376c0152c14e307f52413152d538163ccf7' which reverted the track scaling changes and quite surprisingly I ended up with a source tree that still compiled properly and fixed the issue. Of course this is a band-aid fix and I have no intentions of starting my own branch...;-), hopefully this issue can be fixed going forward but in the meantime this is a stable reliable build to work with.
(0009085)
j-b-m (administrator)
2013-01-14 16:45

I cannot reproduce your problem, and yes I think it is probably caused by a bug in an old Qt version. Can you please let me know which Qt version you have?
(0009087)
GMaq (reporter)
2013-01-14 18:34

Thanks for looking into this, my version of QT4 is 4.6.3 from Debian Squeeze 32bit.
(0009092)
j-b-m (administrator)
2013-01-15 02:19

Should be fixed now, please test
(0009093)
GMaq (reporter)
2013-01-15 05:10

j-b-m does it again! Just compiled and the issue is fixed, the new expanded waveforms look great. Thanks once again for accommodating these older QT4/KDE4 lib versions.

- Issue History
Date Modified Username Field Change
2013-01-06 16:16 GMaq New Issue
2013-01-06 16:59 GMaq Note Added: 0009045
2013-01-07 18:53 GMaq Note Added: 0009062
2013-01-08 22:08 GMaq Note Added: 0009068
2013-01-14 16:45 j-b-m Note Added: 0009085
2013-01-14 16:45 j-b-m Assigned To => j-b-m
2013-01-14 16:45 j-b-m Status new => feedback
2013-01-14 18:34 GMaq Note Added: 0009087
2013-01-14 18:34 GMaq Status feedback => assigned
2013-01-15 02:19 j-b-m Note Added: 0009092
2013-01-15 05:10 GMaq Note Added: 0009093
2013-01-15 13:47 j-b-m Status assigned => resolved
2013-01-15 13:47 j-b-m Fixed in Version => Recent git
2013-01-15 13:47 j-b-m Resolution open => fixed
2013-01-28 19:49 j-b-m Fixed in Version Recent git => 0.9.4
2013-01-28 19:51 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker