Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000293KdenliveMLTpublic2008-10-29 10:122008-12-29 15:37
Reporterjmpoure 
Assigned To 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformDebianOSGNU/LinuxOS VersionSID
Product VersionRecent git 
Target VersionRecent gitFixed in Version0.7.1 
Summary0000293: Render does not start with a full frame
DescriptionDear friends,

When rendering, exported files do not start with a full frame.
Bug is reproduceable.

Download example:
http://devel.bulle-immobiliere.org/~jmpoure/kdenlive-bug-293.mp4 [^]

MLT seems to work fine, with any codec:

inigo tutorial.kdenlive -consumer avformat:test.avi f=avi acodec=libmp3lame ab=128k ar=44100 vcodec=libxvid minrate=0 b=200k bd=2 trell=1 mv4=1 progressive=1

I consider this a blocking bug for 0.7.
Besides, the solution should be easy, as inigo works well.

See attached file for example (the video has nothing to do).
Just notice that the beginning is dark and blank video.

So let's fix it!

Kind regards,
Jean-Michel
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0000745)
jmpoure (developer)
2008-10-29 10:59

I am uploading a short movie.
Bug acknowledged.
(0000748)
madsdyd (administrator)
2008-10-29 12:19

Setting to blocker - I am not sure I agree, actually, but if it is a blocker bug, it should be set to block :-)
(0000750)
jmpoure (developer)
2008-10-29 12:50
edited on: 2008-10-29 12:51

Could you checkout latest MLT + Kdenlive.
Can you reproduce the bug?

You may not see it as in some settings g is set to rather low values, less that 30 (one second). Try h264 export, this is more obvious.

Kind regards,
JMP

(0000758)
administrator (administrator)
2008-10-29 22:51

Hi JMP.

Looking at your video, it looks like the render zone (green zone in timeline ruler) starts before 0. I fixed that so that now the green zone cannot go under zero, that might fix your problem, please let me know
(0000781)
jmpoure (developer)
2008-10-31 01:20
edited on: 2008-10-31 01:22

I just bought a new laptop and cannot confirm
as I am reinstalling Debian and all needed software.
I moved the issue to 0.7.1, hoping it is fixed.

Kind regards, JMP

(0000802)
jmpoure (developer)
2008-11-01 22:23
edited on: 2008-11-01 22:24

Not fixing the issue unfortunately. I tried todays SVN on a new project, during export, the first 2 seconds are black frames. Is there a rendering log somewhere, to make sure that the correct options are send to inigo?

(0000803)
jmpoure (developer)
2008-11-02 16:48

Have a look at my last tutorial on Vimeo;
http://vimeo.com/2131880 [^]

This is not an issue of codec (h264) or transcoding from Vimeo.
All media has the same problem.

The rendering does not start with a full frame.
(0000810)
administrator (administrator)
2008-11-05 19:07

Ok, I found the problem. It happens when you try to render a zone of the project. In fact, the problem is visible with inigo too, and is probably related to ogg seeking issues in MLT or FFmpeg.

You can reproduce the problem easily with any ogg video file:
inigo video.ogg in=100

The first frames will display a white screen.
(0000942)
ddennedy (developer)
2008-11-09 02:50

Definitely, your mileage will vary depending upon the type of media you want to edit. While it would be nice to support everything, it just is not gonna happen. We may want to consider adding an import function that transcodes for working with difficult media. This is basically what I do for Kino - I tried to come up with a simple, solid, comprehensive solution using a combo of mencoder (optional) and ffmpeg, but even that has trouble. Still, there is going to be a lot of people trying to use Ogg Theora, so I will look into this further, but I already put in a bunch of effort about 1.5 years ago to improve Ogg Theora seeking.
(0000946)
ddennedy (developer)
2008-11-09 04:04

Ogg Theora is still suffering in FFmpeg:

http://thread.gmane.org/gmane.comp.video.ffmpeg.devel/65030/focus=70277 [^]
(0000956)
madsdyd (administrator)
2008-11-09 10:58

I am a bit confused about the state of this bug?

Is this only an ogg theora issue? The original report tended to indicate that this was an issue for all rendering?
(0000965)
jmpoure (developer)
2008-11-09 12:30

To reproduce bugs, we need raw files from camcorders.
I already uloaded HDV and DV PAL wide media.
More media is needed to reproduce bugs.
(0000985)
ddennedy (developer)
2008-11-09 20:34

I already have DV and HDV files. I added a HDV and trimmed it, rendered to MPEG-4 MP4, and it looks fine. This bug is not well qualified. It says "reproducible," but it is not 100% reproducible. OTOH, I can reproduce this bug using Ogg Theora source videos.

This bug will never close as long as you can add any media that FFmpeg supports. Therefore, we need to qualify the bug - under exactly which conditions - and possibly kdenlive should consider limiting which media it will allow the user to add until the media is qualified as mostly working.
(0000990)
jmpoure (developer)
2008-11-09 21:13

Tanks I understand now.

I will upload some screencast source media, to help reproduce.
Not right now, tomorrow.
(0001003)
cinephiliac (updater)
2008-11-10 00:50

Moving this back to Feedback, until Dan has the info needed to qualify.
(0001175)
ddennedy (developer)
2008-11-13 18:50

bug moderators, you should consider not classifying severity as "block." Do you really want to block a subsequent release until you can reliably use *any* media that kdenlive/MLT will load? IOW, are you sure you want to make a hole you can not dig yourself out of?
(0001232)
madsdyd (administrator)
2008-11-17 16:36

We are not blocking on this bug (Thanks ddennedy).
(0001855)
madsdyd (administrator)
2008-12-21 12:20

I believe we still need details on this bug in order to fix it. jmpoure?
(0001865)
jmpoure (developer)
2008-12-21 13:39

This does not exist any longer on recent versions of MLT/FFmpeg/Kdenlive.
Sorry for not closing it. I am closing the bug rigt now.

- Issue History
Date Modified Username Field Change
2008-10-29 10:12 jmpoure New Issue
2008-10-29 10:12 jmpoure Status new => feedback
2008-10-29 10:13 jmpoure File Added: kdenlive-bug-293.avi
2008-10-29 10:14 jmpoure Description Updated
2008-10-29 10:55 jmpoure Description Updated
2008-10-29 10:59 jmpoure Note Added: 0000745
2008-10-29 10:59 jmpoure Status feedback => acknowledged
2008-10-29 11:04 jmpoure Category MLT => Rendering
2008-10-29 11:08 jmpoure File Deleted: kdenlive-bug-293.avi
2008-10-29 11:08 jmpoure Description Updated
2008-10-29 11:14 jmpoure Description Updated
2008-10-29 11:51 jmpoure Description Updated
2008-10-29 12:19 madsdyd Note Added: 0000748
2008-10-29 12:19 madsdyd Severity minor => block
2008-10-29 12:50 jmpoure Note Added: 0000750
2008-10-29 12:51 jmpoure Note Edited: 0000750
2008-10-29 22:51 administrator Note Added: 0000758
2008-10-31 01:20 jmpoure Note Added: 0000781
2008-10-31 01:21 jmpoure Target Version 0.7.0 => 0.7.1
2008-10-31 01:22 jmpoure Note Edited: 0000781
2008-11-01 22:23 jmpoure Note Added: 0000802
2008-11-01 22:24 jmpoure Note Edited: 0000802
2008-11-02 16:48 jmpoure Note Added: 0000803
2008-11-05 19:07 administrator Note Added: 0000810
2008-11-05 19:08 administrator Category Rendering => MLT
2008-11-09 02:50 ddennedy Note Added: 0000942
2008-11-09 04:04 ddennedy Note Added: 0000946
2008-11-09 10:58 madsdyd Note Added: 0000956
2008-11-09 12:30 jmpoure Note Added: 0000965
2008-11-09 20:34 ddennedy Note Added: 0000985
2008-11-09 21:13 jmpoure Note Added: 0000990
2008-11-10 00:50 cinephiliac Note Added: 0001003
2008-11-10 00:51 cinephiliac Status acknowledged => feedback
2008-11-12 22:40 madsdyd Target Version 0.7.1 => Recent git
2008-11-13 18:50 ddennedy Note Added: 0001175
2008-11-17 16:36 madsdyd Note Added: 0001232
2008-11-17 16:36 madsdyd Severity block => major
2008-12-21 12:20 madsdyd Note Added: 0001855
2008-12-21 13:39 jmpoure Note Added: 0001865
2008-12-21 13:40 jmpoure Build/Install Method => Manual build from SVN
2008-12-21 13:40 jmpoure Status feedback => resolved
2008-12-21 13:40 jmpoure Resolution open => fixed
2008-12-22 22:12 madsdyd Fixed in Version => Recent git
2008-12-29 15:36 madsdyd Fixed in Version Recent git => 0.7.1
2008-12-29 15:37 madsdyd Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker