Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002976KdenliveUser Interfacepublic2013-02-04 10:342013-04-07 08:45
Reporterpdq 
Assigned Toj-b-m 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platformgnu/linuxOSarchlinuxOS Versionlatest updated
Product VersionRecent git 
Target VersionFixed in Version0.9.6 
Summary0002976: Importing .wmv files corrupts project
DescriptionProject becomes corrupted and can't be opened.

Error dialog shows:
Cannot open the project file, error is:
unexpected character
Do you want to open a backup file?
Steps To ReproduceImport .wmv file(s) into any project, save project.
Additional InformationThis happens to me whether using latest stable version of kdenlive (kdenlive 0.9.4-1
) or the development version(s) (kdenlive-git 20120923-1).

This happens whether using latest stable version of mlt (mlt 0.8.8-1
) or the development version (mlt-git 20120912-1).

I have removed/updated/installed kdenlive as well as removing adding new project locations to no positive effect.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files? file icon aproject.kdenlive [^] (3,669 bytes) 2013-02-04 13:57

- Relationships

-  Notes
(0009169)
j-b-m (administrator)
2013-02-04 13:11

I cannot reproduce. can you please attach here a .kdenlive project file that gives this error message?
(0009170)
pdq (reporter)
2013-02-04 13:57

Sure thing attached, I did notice that a few local wmv files did in fact work, but the majority did not, they are from various sources and of different resolutions and aspect ratios.
I use dolphin file browser and when I save the file with a 'bad' wmv file the thumbnail for the project in dolphin turns into the default kdenlive filetype icon indicating that if I was to open this project it would fail, which it does.
(0009171)
j-b-m (administrator)
2013-02-04 14:42

Thanks. I see the problem, it is caused be some FFmpeg properties for that file that contain a space in their name, something I have not seen before. Could you attach here or mail me ( jb at kdenlive org ) one of there wmv file so that I can make further tests?
(0009172)
pdq (reporter)
2013-02-04 15:13
edited on: 2013-02-04 15:14

Thanks!

Found a few wmv samples from this site, here is a link to one https://flightpass.higherplaneproductions.com/g2data/albums/FreeAll/freewmv/JoeNall10_3DH-_W640.wmv [^]

(0009174)
j-b-m (administrator)
2013-02-04 16:17

Should be fixed in Kdenlive git now, please test. Broken project will still be broken but from now on you should be able to work correctly with these clips.

Please test
(0009175)
pdq (reporter)
2013-02-04 16:37

Awesome, tested a majority of the files that failed for me before and they all imported with no problems. :D Thanks and love the project.

- Issue History
Date Modified Username Field Change
2013-02-04 10:34 pdq New Issue
2013-02-04 13:11 j-b-m Note Added: 0009169
2013-02-04 13:11 j-b-m Assigned To => j-b-m
2013-02-04 13:11 j-b-m Status new => feedback
2013-02-04 13:57 pdq File Added: aproject.kdenlive
2013-02-04 13:57 pdq Note Added: 0009170
2013-02-04 13:57 pdq Status feedback => assigned
2013-02-04 14:42 j-b-m Note Added: 0009171
2013-02-04 15:13 pdq Note Added: 0009172
2013-02-04 15:14 pdq Note Edited: 0009172 View Revisions
2013-02-04 16:17 j-b-m Note Added: 0009174
2013-02-04 16:37 pdq Note Added: 0009175
2013-02-04 18:28 j-b-m Status assigned => resolved
2013-02-04 18:28 j-b-m Fixed in Version => Recent git
2013-02-04 18:28 j-b-m Resolution open => fixed
2013-04-07 08:45 j-b-m Fixed in Version Recent git => 0.9.6
2013-04-07 08:45 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker