Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003003KdenliveFile Loadingpublic2013-03-05 13:102013-04-07 09:34
ReporterfranciscoLuz 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platform32 bit intel and alikeOSUbuntuOS Version12.10
Product Version 
Target VersionFixed in Version0.9.6 
Summary0003003: Cannot open the project file, error is: unexpected character Do you want to open a backup file?
DescriptionI did some work on a project and closed it. The next day tried to open it again and got the error message above.

I opened the .kdenlive project file in a text editor and noticed html entities in it, like < and "

In a process of elimination I tracked down which clip file caused the corruption. It turned out to be a MP3 audio file ( find it attached ). The issue was specifically with the MP3 metadata.

To fix the problem I opened the MP3 file on Audacity and removed all its Metadata ( Go File -> Export | Give a name to the output file | The metadata window pops up ).
Steps To ReproduceREPRODUCE:

Attached MP3 file:

https://www.dropbox.com/s/ds5hf9stiqyjwos/soccer_crowed.mp3?m [^]

1. Create a new project;
2. Add the attached MP3 file into your audio track;
3. Close the project;
4. Try to open it again;

WORK AROUND FIX:
1. Open the attached MP3 file on Audacity;
2. Go File -> Export | Then give a name for the output file
3. A Metadata window will popup. Delete all the metadata.
Additional InformationAttached MP3 file:

https://www.dropbox.com/s/ds5hf9stiqyjwos/soccer_crowed.mp3?m [^]
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships
has duplicate 0002937closedj-b-m kdenlive crashes causes project file corruption 

-  Notes
(0009378)
lokifacio (reporter)
2013-03-12 21:34

I had the same problem with one of my projects. The issue is related with id3 tag names containing white spaces. This results in invalid kdenlive project files (xml attributes using spaces for those tags).

It seems it has been fixed in current development version.
To fix this error in current version, you can remove your mp3 tags (only those with withe spaces). Or you can edit your kdenlive files with a text editor and remove those xml attributes containing white spaces (they are spotted by the error message).

- Issue History
Date Modified Username Field Change
2013-03-05 13:10 franciscoLuz New Issue
2013-03-12 21:34 lokifacio Note Added: 0009378
2013-04-07 09:33 j-b-m Relationship added has duplicate 0002937
2013-04-07 09:34 j-b-m Status new => resolved
2013-04-07 09:34 j-b-m Fixed in Version => 0.9.6
2013-04-07 09:34 j-b-m Resolution open => fixed
2013-04-07 09:34 j-b-m Assigned To => j-b-m
2013-04-07 09:34 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker