Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003054KdenliveEffectspublic2013-04-09 22:472013-05-22 18:51
Reporterjappel 
Assigned Toddennedy 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Platform64 bitOSArchlinuxOS Version09. Apr 2013
Product Version0.9.6 
Target VersionFixed in VersionRecent git 
Summary0003054: Videomaterial at 120fps from Gopro Hero 3 cannot be slowed down.
DescriptionChanging a 720p @ 120 fps clips speed to a value below 100% does not show the expected behaviour (ie smooth slowmo at half speed with 50% = 60fps ) but results in roughly one frame per second to be shown.
Steps To ReproduceAdd a 720p @ 120fps. I selected 720p@60fps as profile (see additional info).

Since the video material has twice as much frame's, i would expect the video to play at half speed, but that s a different matter.

The video plays at normal speed (1s = 1s).

Add the effect to change the clip speed. Change the clips speed to 90%, 80% or 50%. Roughly 1fps is shown.
Additional InformationAs of Kdenlive 0.9.6 no profiles for the recording modes of 720p @ 120fps or 2.7k @ 30fps are included.

The option "adapt profile to current clip" doesnt do anything (likely because it can only adjust to existing profiles, not create new ones).

Unfortunately there doesn t appear to be a way to create a new profile within the GUI.

The Clip itself is detected as 720p @ 119,88fps

kdenlive --version
Qt: 4.8.4
KDE: 4.10.2
Kdenlive: 0.9.6

melt --version
melt 0.8.8

I can provide raw video clips if needed.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
(0009523)
evorster (reporter)
2013-05-07 12:38

Hi there...

Video playback is by time code, so kdenlive would just throw away the extra frames, and try to play back the video in the same time as it was recorded. This is intentional, as we don't want time artifacts when mixing footage with different framerates.

To slow down or speed up video, please do the following:
Place the clip on the timeline,
Right-click
Add Effect
Motion
Speed

and then set the playback speed to 50%
Give us an update if this works for you.
(0009560)
jappel (reporter)
2013-05-18 23:02

Hello Everett, thanks for taking the time.

What you suggest is exactly what I was trying to do, adding the motion speed effect and changing its value.

The result was always a video with 1 frame per secound, it did not matter whether the speed was set to 90%, 80% or 50%.

I am currently away (thus the late response), I ll try to render a video and see if a rendered video works as expected. But after applying the speed filter, the timeline remains responsive and advances in normal time, there is no stuttering / locks etc, just 1 fps in the video monitor is shown. So I have little hope for the rendered video.
(0009561)
evorster (reporter)
2013-05-19 03:55

I can confirm this bug.

Funny, though. It works fine in my preview window, but I just see the first frame of the clip when I play back the rendered clip.
The only way I can get 120fps is to switch my HD3 into NTSC mode. I took one clip at 24fps, and that worked fine, both in preview and render, and all the PAL modes that the camera has to offer.
For me it looks like a rendering bug. I'll get on to the dev that got support for slowing down high fps video in kdenlive in the first place, and see if we can get it to work.

In the meantime, I have a blog entry that might get you underway while you wait:
http://evorster.blogspot.com/ [^]
(0009563)
evorster (reporter)
2013-05-22 12:14

Right...

Please pull a new git version of mlt & kdenlive, and see if your problem has gone away?

Thanks!
(0009564)
jappel (reporter)
2013-05-22 14:41

Great! Looking forward to it! Can check in roughly 2 weeks, thank you!
(0009565)
evorster (reporter)
2013-05-22 18:47

I can confirm the issue on my workstation is now gone with the latest git. Let's see if jappel is happy, too.
(0009566)
ddennedy (developer)
2013-05-22 18:49

fixed in mlt git commit 27e3ae8c691bcffa71dfab507eb608cb8c8ad07c
(0009567)
ddennedy (developer)
2013-05-22 18:51

You can also try a nightly build http://kdenlive.org/download-development [^] when it updates to reflect a version 20130522 or later.

- Issue History
Date Modified Username Field Change
2013-04-09 22:47 jappel New Issue
2013-05-07 12:38 evorster Note Added: 0009523
2013-05-18 23:02 jappel Note Added: 0009560
2013-05-19 03:55 evorster Note Added: 0009561
2013-05-22 12:14 evorster Note Added: 0009563
2013-05-22 14:41 jappel Note Added: 0009564
2013-05-22 18:47 evorster Note Added: 0009565
2013-05-22 18:49 ddennedy Note Added: 0009566
2013-05-22 18:49 ddennedy Status new => resolved
2013-05-22 18:49 ddennedy Fixed in Version => Recent git
2013-05-22 18:49 ddennedy Resolution open => fixed
2013-05-22 18:49 ddennedy Assigned To => ddennedy
2013-05-22 18:51 ddennedy Note Added: 0009567


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker