Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003121KdenliveFile Loadingpublic2013-06-05 23:032014-05-13 00:30
Reportermaen71 
Assigned To 
PrioritynormalSeveritymajorReproducibilitysometimes
StatusnewResolutionopen 
Platform64 bitOSKubuntuOS Version12.04
Product Version0.9.6 
Target VersionFixed in Version 
Summary0003121: Big H.264/MPEG-4 AVC File (1.7GB) not previewable, searchable, cuttable
DescriptionCapture device: Panasonic HDC SD-5.
File format: H.264/MPEG-4 AVC (part 10) - 1440x1080 @ 50fps

I have a 1.7Gigabyte clip (44:13 min) from this device, and it is not possible to jump to random frames in it and preview them, or playback from the desired position at all. However it IS possible to playback the clip from the beginning to the end. The clip is always played from the beginning or from the paused position, no matter to which timeline position I navigate within the clip.

This affects the clip monitor as well as the project monitor. I tried navigating the clip both through the slider beneath the clip/project monitor, as well as through the video track where I added the clip.

It is subsequently also not possible to cut/render this clip correctly "blindly".

By contrast, VLC can play and seek within said file just fine.

On another note, all the other, smaller clip files, which were captured which the same camera/configuration/codec, can be handled by kdenlive just fine, it seems. I even have a 1GB file from the same capture device, which I can seek from within kdenlive just fine.

Maybe the reason of this bug is not the file size alone, but it is the only difference I can spot as a layman.

Thanks for looking into this.
Steps To Reproduce1. add file as clip
2. through the slider of the clip monitor, or through the digit inputfield, try to navigate to, say, minute 20 (of 44). Expected result: frame/scene from minute 20 is shown in preview. Actual result: Frame from the beginning of the clip is still shown.
3. Try to playback from the newly selected position. Expected result: Playback starts from minute 20. Actual result: Playback starts from the beginning of the clip
4. add clip to video track 1
5. try steps 2-3 by using the project monitor instead of the clip monitor. same results
6. Trying to navigate by mouse within the video track 1 produces the same results
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
(0010041)
pooky2483 (reporter)
2014-05-12 16:33
edited on: 2014-05-12 16:38

May be a simple solution such as to give it time to actually 'get to the selected clip'.

I have recently installed a Phenom II X4 965 3400 and have noticed a huge difference in speed. It (Arista) used to take about 30 minutes to convert a 45 video. Now it takes just 6 minutes.

I have a 3Tb Hd and I edit clips saved on it. anything from 20 seconds to 35 minutes (in car camera) to 45 minutes (TV Series) to 2 hours (a film). I do however still have to wait some time before the Kdenlive has actually caught up to where I want it. This is due to my Hard Drive being an external one and going into some sort of 'sleep' due to a time of inactivity and needs time to spin up to speed before being accessed.

You need to take into account your setup.
Try from a clean boot with minimal programs installed. Load up Kdenlive and then the clip you're having problems with. Am I correct in thinking you're editing it directly from the camera? Then that <could> be your problem. Try copying it to one of your Hard Drives and then editing it.

(0010047)
vpinon (administrator)
2014-05-13 00:30

Do you use proxy clips? This helps to handle large media with limited hardware power.
An important factor navigation in compressed video is GOP size (number of frames between I-frames, ie full images). For high compression GOP is often around 200, while for smooth navigation I recommend proxy transcoding with GOP size <20 (non linear read needs to recalculate all "history" from last I-frame).
=> in my proxy commandline I use "-g 5"...

- Issue History
Date Modified Username Field Change
2013-06-05 23:03 maen71 New Issue
2014-05-12 16:33 pooky2483 Note Added: 0010041
2014-05-12 16:38 pooky2483 Note Edited: 0010041 View Revisions
2014-05-13 00:27 vpinon Note Added: 0010045
2014-05-13 00:29 vpinon Note Added: 0010046
2014-05-13 00:29 vpinon Note Deleted: 0010045
2014-05-13 00:30 vpinon Note Deleted: 0010046
2014-05-13 00:30 vpinon Note Added: 0010047


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker