Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003174KdenliveUser Interfacepublic2013-10-07 17:432014-08-23 20:53
Reporterasilnevs 
Assigned Topez4brian 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Platform64 bitOSUbuntuOS Version12.04
Product VersionRecent git 
Target VersionFixed in Version0.9.10 
Summary0003174: Example (Audio) off the Online resources doesn't work
DescriptionIt's not possible to hear the audio of an Online resource with the latest daily builds of Kdenlive. With the stable version 0.9.6 there is no problem.
Steps To ReproduceClick on Project.....Online Resources.....and then search for a sound and click on Example.
TagsNo tags attached.
Build/Install MethodManual build from Git
Attached Files

- Relationships

-  Notes
(0009857)
asilnevs (reporter)
2014-03-31 17:32

It's just to mention that this problem still exists in the daily builds Version 0.9.7 (rev. v0.9.4-352-g13bffad)
(0010209)
asilnevs (reporter)
2014-08-07 19:59

I just installed the latest build http://builds.meltytech.com/kdenlive/kdenlive-ubuntu12.04-x86_64-20140807.tar.bz2 [^] but the problem still exists.
If I test this in the stable version 0.9.8 then it is ok.
(0010232)
vpinon (administrator)
2014-08-14 23:42

sorry but works for me with any of the versions I try (0.9.6, 0.9.8, and 3 builds since then... on Debian Jessie)
Maybe something wrong with the libraries linked with the build?
(0010234)
asilnevs (reporter)
2014-08-15 08:50

This is all very weird. And there are other strange things. In the past when I looked which version the daily build was then I could see something like Version 0.9.7 (rev. v0.9.4-352-g13bffad) . But now only Version 0.9.8 is shown. Is this normal. And also during installing a new daily build version a screen pops up that is saying that it could not find MLT profile. Then I change that to the correct path and that's ok.
A next thing I saw was in the configuration wizard that the DV module (libdv) is not checked (so not installed). But if I look in Synaptic then I see that libdv4 version 1.0.0-6 is installed.
I always thought that everything was included in a daily build version.
I also can say that I am working with Ubuntu 14.04 LTS and not any more with 12.04 like it is mentioned when I started this bug.
The problem mentioned in this bug is not really important for me because I always work with the stable 0.9.8 version but I hope that when a new stable version is released that this will be working.
Thanks for your hard work on Kdenlive.
(0010236)
vpinon (administrator)
2014-08-15 10:21

OK, with daily build I also don't get sound, nor DV support, these are build issues (to report to MLT team), then it should not happen with a release package.

Regarding the version shown on title, I didn't re-enable that feature after release because I was finding this annoying while developing: it creates config changes at every commit and makes the compiler re-run on huge files for nothing else, and my machine is rather slow… +I get the wizard popping up every time I switch between stable and development version…

Thanks for the testings and report!
(0010237)
vpinon (administrator)
2014-08-15 10:22

Brian, if I'm not wrong, you handle the build scripts?
(0010239)
pez4brian (developer)
2014-08-16 17:42

I committed a change to the build script which should fix the profile problem:
https://github.com/mltframework/mlt-scripts/commit/c8705edd820a1a5566b57fabca63b8637965d398 [^]
Please try again with tomorrow's daily build.

We have disabled libdv by default in the latest MLT because libav/ffmpeg support dv very well. libdv is now deprecated. My advice would be to remove the specifc libdv check from KDENLIVE.

I haven't looked at the audio issue yet.
(0010240)
vpinon (administrator)
2014-08-16 22:02

Many thanks Brian, I will see what to change regarding libdv (was it to control tape player over FireWire?).
For audio in online resources it is unclear: the audio preview is just calling ffplay (or avplay), as pointed in Kdenlive preferences, which are overridden in daily builds… I will try to debug this and let you know.
(0010241)
vpinon (administrator)
2014-08-17 09:07

from the MLT builds:
ffplay http://www.freesound.org/data/previews/220/220890_2022935-hq.mp3 [^]
=> Protocol not found

from distro package:
avplay …
=> works fine

so HTTP should be enabled in ffmpeg build.

Brian is this possible ?
(0010246)
pez4brian (developer)
2014-08-18 04:53

Doesn't the "Online Resources" feature actually download the file and store it on the hard drive? If so, enabling HTTP wouldn't help.

I gave it a quick try and the download succeeded. But no sound came out when I tried to play it. Is it possible that audio files don't work at all?
(0010258)
vpinon (administrator)
2014-08-19 23:14

according to src/utils/freesound.cpp, ffplay reads directly the http url…
and this works for me with debian's avplay that has http enabled.
(0010265)
pez4brian (developer)
2014-08-20 14:04

I committed a change to the build script which enables the network features:
https://github.com/mltframework/mlt-scripts/commit/1b972d82f90912dab9f6adc34c9bcd2a8da8dc1e [^]
Please try again with tomorrow's daily build.
(0010268)
asilnevs (reporter)
2014-08-21 22:01

Ok, the sound is working again.
Thanks for fixing this bug.
Is it also possible to fix this problem that I mentioned in 0010234 : "....during installing a new daily build version a screen pops up that is saying that it could not find MLT profile. Then I change that to the correct path and that's ok."
Thanks guys
(0010269)
pez4brian (developer)
2014-08-21 22:14

Is the MLT profile dialog still popping up in the latest version? I thought I had fixed that previously:
http://www.kdenlive.org/mantis/view.php?id=3174#c10239 [^]

Please confirm that that the very latest daily build still pops up the MLT profile dialog - if so, I can have another look.
(0010270)
asilnevs (reporter)
2014-08-21 22:23

Yes, it still pops up.
It's the version from Aug 21: http://builds.meltytech.com/kdenlive/kdenlive-ubuntu12.04-x86_64-20140821.tar.bz2 [^]
(0010271)
pez4brian (developer)
2014-08-22 23:06

Sorry. I had a typo in my profile fix. Please try again with tomorrow's build.
(0010273)
asilnevs (reporter)
2014-08-23 19:45

Ok, also the problem with the popup screen that appears for the MLT profiles is solved.
I think this bug can be closed :-)
Thank you very much guys.
(0010274)
vpinon (administrator)
2014-08-23 20:53

Thanks a lot Brian!

- Issue History
Date Modified Username Field Change
2013-10-07 17:43 asilnevs New Issue
2014-03-31 17:32 asilnevs Note Added: 0009857
2014-08-06 00:54 vpinon Status new => resolved
2014-08-06 00:54 vpinon Fixed in Version => 0.9.8
2014-08-06 00:54 vpinon Resolution open => fixed
2014-08-06 00:54 vpinon Assigned To => vpinon
2014-08-07 19:59 asilnevs Note Added: 0010209
2014-08-07 19:59 asilnevs Status resolved => feedback
2014-08-07 19:59 asilnevs Resolution fixed => reopened
2014-08-14 23:42 vpinon Note Added: 0010232
2014-08-15 08:50 asilnevs Note Added: 0010234
2014-08-15 08:50 asilnevs Status feedback => assigned
2014-08-15 10:21 vpinon Note Added: 0010236
2014-08-15 10:21 vpinon Assigned To vpinon => pez4brian
2014-08-15 10:22 vpinon Note Added: 0010237
2014-08-15 10:58 vpinon Assigned To pez4brian => vpinon
2014-08-16 17:42 pez4brian Note Added: 0010239
2014-08-16 22:02 vpinon Note Added: 0010240
2014-08-17 09:07 vpinon Note Added: 0010241
2014-08-18 04:53 pez4brian Note Added: 0010246
2014-08-19 23:14 vpinon Note Added: 0010258
2014-08-19 23:21 vpinon Status assigned => feedback
2014-08-20 14:04 pez4brian Note Added: 0010265
2014-08-21 22:01 asilnevs Note Added: 0010268
2014-08-21 22:01 asilnevs Status feedback => assigned
2014-08-21 22:14 pez4brian Note Added: 0010269
2014-08-21 22:23 asilnevs Note Added: 0010270
2014-08-22 23:06 pez4brian Note Added: 0010271
2014-08-23 19:45 asilnevs Note Added: 0010273
2014-08-23 20:53 vpinon Note Added: 0010274
2014-08-23 20:53 vpinon Status assigned => resolved
2014-08-23 20:53 vpinon Fixed in Version 0.9.8 => 0.9.10
2014-08-23 20:53 vpinon Resolution reopened => fixed
2014-08-23 20:53 vpinon Assigned To vpinon => pez4brian


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker