Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003207KdenliveFile Loadingpublic2014-01-20 18:432014-03-12 20:26
ReporterNikinger 
Assigned Tovpinon 
PrioritynormalSeverityblockReproducibilityalways
StatusresolvedResolutionno change required 
PlatformLinux 3.4.47-2.38-desktop x86_64OS64bit OpenSuse 12.2OS VersionKDE 4.8.5 r2
Product Version0.9.6 
Target VersionFixed in Version 
Summary0003207: avformat-module (FFmpeg) not found by wizard
DescriptionI know, an old problem, but any description do not help!

I have hopefully every codec and or packages installed.
I have every thing needed of kdenlive installed form packman.


...

nikolaus@linux-4qhx:~> kdenlive
QWidget::insertAction: Attempt to insert null action
QWidget::insertAction: Attempt to insert null action


...

nikolaus@linux-4qhx:~> zypper se -si mlt ffmpeg kdenlive
Daten des Repositories laden ...
Installierte Pakete lesen ...

S | Name | Typ | Version | Arch | Repository
--+-------------------------------+-------+-----------------+--------+---------------
i | ffmpeg | Paket | 2.1.2-1.2 | x86_64 | packman-x86_64
i | ffmpeg-debuginfo | Paket | 2.1.2-1.2 | x86_64 | packman-x86_64
i | ffmpeg-debugsource | Paket | 2.1.2-1.2 | x86_64 | packman-x86_64
i | ffmpeg-tools | Paket | 2.1.2-1.2 | x86_64 | packman-x86_64
i | ffmpeg-tools-debuginfo | Paket | 2.1.2-1.2 | x86_64 | packman-x86_64
i | gstreamer-0_10-plugins-ffmpeg | Paket | 0.10.13-2000.11 | x86_64 | packman-x86_64
i | kdenlive | Paket | 0.9.6-5.1 | x86_64 | packman-x86_64
i | kdenlive-debuginfo | Paket | 0.9.6-5.1 | x86_64 | packman-x86_64
i | kdenlive-debugsource | Paket | 0.9.6-5.1 | x86_64 | packman-x86_64
i | libmlt++-devel | Paket | 0.9.0-9.2 | x86_64 | packman-x86_64
i | libmlt++3 | Paket | 0.9.0-9.2 | x86_64 | packman-x86_64
i | libmlt++3-debuginfo | Paket | 0.9.0-9.2 | x86_64 | packman-x86_64
i | libmlt-debugsource | Paket | 0.9.0-9.2 | x86_64 | packman-x86_64
i | libmlt-devel | Paket | 0.9.0-9.2 | x86_64 | packman-x86_64
i | libmlt6 | Paket | 0.9.0-9.2 | x86_64 | packman-x86_64
i | libmlt6-data | Paket | 0.9.0-9.2 | noarch | packman-x86_64
i | libmlt6-debuginfo | Paket | 0.9.0-9.2 | x86_64 | packman-x86_64
i | libmlt6-modules | Paket | 0.9.0-9.2 | x86_64 | packman-x86_64
i | libmlt6-modules-debuginfo | Paket | 0.9.0-9.2 | x86_64 | packman-x86_64
i | python-mlt | Paket | 0.9.0-9.2 | x86_64 | packman-x86_64
i | python-mlt-debuginfo | Paket | 0.9.0-9.2 | x86_64 | packman-x86_64


...

nikolaus@linux-4qhx:~/mlt> ./configure --prefix=/usr --enable-gpl
Configuring framework:
Configuring modules:
Configuring modules/avformat:
- libavformat not found: disabling
Configuring modules/core:
Configuring modules/decklink:
Configuring modules/dgraft:
Configuring modules/dv:
Configuring modules/effectv:
Configuring modules/feeds:
Configuring modules/frei0r:
Configuring modules/gtk2:
Configuring modules/jackrack:
Configuring modules/kdenlive:
Configuring modules/kino:
Configuring modules/linsys:
Configuring modules/lumas:
Configuring modules/motion_est:
Configuring modules/normalize:
Configuring modules/oldfilm:
Configuring modules/opengl:
- movit not found: disabling
Configuring modules/plus:
Configuring modules/qt:
- Qt version 4.x detected
Configuring modules/resample:
Configuring modules/rotoscoping:
Configuring modules/rtaudio:
Configuring modules/sdl:
Configuring modules/sox:
Configuring modules/swfdec:
Configuring modules/videostab:
Configuring modules/vmfx:
Configuring modules/vorbis:
Configuring modules/xine:
Configuring modules/xml:
Configuring mlt++:
Configuring swig:
GPLv2 license used; GPLv3 components disabled
Steps To ReproduceFor example, every time when I want to insert a mp3 file into a project!
Additional InformationIntel Core i7-3770K 3,5Ghz
 15,8 GB RAM
 nvidia 304.88
TagsNo tags attached.
Build/Install Method3rd party package
Attached Files

- Relationships

-  Notes
(0009664)
vpinon (administrator)
2014-01-21 11:25

I don't understand your problem. Is it an error message at startup ?
(0009665)
Nikinger (reporter)
2014-01-21 18:45

Sorry for my bad English, and or description.

Kdenlive cannot find the avformat-modul (ffmpeg)!

And because of that, it is impossible to import for example mp3 files. kdenlive is currently for me not usable and I have no idea what I can do to change this situation.

Above are some thing I tried, because I read a lot of about this problem, but nothing helped!
(0009693)
vpinon (administrator)
2014-02-13 23:15

I'm not used to Suse, but isn't a ffmpeg-devel package missing to build mlt?
To avoid missing others, you might try "zypper build-deps-install mlt" or "zypper build-deps-install libmlt6".
To build from source you may try build script found on mltframework page, or else try to find recent binary packages for your distro (official or contributed)?
(0009707)
Nikinger (reporter)
2014-02-16 19:47

Hey, thank you.

I was trying some things.
I don not have:
libavformat-dev
libavcodec-dev
libavdevice-dev

If i want to install:
libavutil-dev
libswscale-dev
I get more than 500 conflicts

I changed to opensuse13.1; my kdenlive problem do exist anymore....
(0009708)
Nikinger (reporter)
2014-02-16 19:49

"zypper build-deps-install mlt" or "zypper build-deps-install libmlt6"

dont work under suse

?

I'am a Linux-looser; using only Yast and like it ...
mmmh
(0009709)
Nikinger (reporter)
2014-02-16 19:56

libffmpeg-devel offer:
ffmpeg-devel = 2.1.3
libav-devel = 2.1.3
libavutil-devel = 2.1.3
libffmpeg-devel = 2.1.3-1.2
libffmpeg-devel(x86-64) = 2.1.3-1.2
libffmpeg0-devel = 2.1.3
(0009711)
vpinon (administrator)
2014-02-17 16:04

Sorry I can't help you much with a distro I don't know.
I searched a few, it seems that you should use zypper to resolve build deps, yast being more for basic day-to-day use.

Suse ships kdenlive binaries, don't they fit your needs? Building from git won't bring you much functionality as development has been on hold during several months.

You might want to run the build script from
http://www.mltframework.org/bin/view/MLT/BuildScripts [^]
but still you have to install the build deps (listed for debian/ubuntu or fedora, but for suse you have to find help on their forums)
(0009744)
vpinon (administrator)
2014-03-02 21:22

Dan replied to another bug reporter that you can up-to-date builds from:
http://builds.meltytech.com/kdenlive/latest.rss [^]

even if it doesn't match your distro it is based on 2-years old system and embeds multimedia libs so there are great chances it should run on any rather recent system?
(extract archive anywhere -home dir for example- an run start-kdenlive script)

Hope this helps you at last?
(0009756)
Nikinger (reporter)
2014-03-11 17:37

Hello, Thank you very much; I take my hat off to you for helping me,

And sorry for late answer,
I download konquerorp17664.04-x86-20140311.tar.bz2
--> extract --> and start kdenlive first in normal mode --> nothing --> than in debug mode

this was the result:





This is a logfile of running kdenlive through gdb. You may want to visit http://www.kdenlive.org/mantis/view_all_bug_page.php [^] and attach this file to a proper bug
Kdenlive was installed by Kdenlive Builder Wizard 20
The following configuration variables was used
INSTALL_DIR="/home/nikolaus/Dokumente/daskannmannvielleichtbaldloeschen/kdenlive/kdenlive/kdenlive" AUTO_APPEND_DATE=0 SOURCE_DIR="/home/nikolaus/Dokumente/daskannmannvielleichtbaldloeschen/kdenlive/kdenlive/src"
Information about revisions of modules at the time of compilation:
lame: Warning: No http-tgz information found in /opt/buildAgent/work/bbab7a538eb594f3/src/lame.
libvpx: commit 1f08824d6db735e4cacb0419785a789395e42b2b Date: Mon Mar 10 20:50:58 2014 -0700
x264: commit d967c09cd93a230e03ec1e0f0f696975d15a01c0 Date: Tue Dec 11 16:05:34 2012 +0100
frei0r: commit b1faa09f4dfcf63d19d2cb9fc598a583e1df1c33 Date: Mon Apr 15 16:32:00 2013 +0200
FFmpeg: commit e161c1bbfce904cd8e6683c4eeaadb634dd4c8e7 Date: Tue Mar 11 04:20:23 2014 +0100
mlt: commit 234d3e7f9969098b33f9c1293d5cf1f1d53f864f Date: Sat Mar 8 22:37:17 2014 +0100
kdenlive: commit a7a883757867c177be234cb2a05bb9ce47cc562c Date: Sat Mar 8 21:18:42 2014 +0100
uname -a at time of compilation:
Linux teamcity-ubuntu12 3.2.0-38-generic-pae 0000061-Ubuntu SMP Tue Feb 19 12:39:51 UTC 2013 i686 i686 i386 GNU/Linux
Information about cc at the time of compilation:
Using built-in specs.
COLLECT_GCC=cc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/i686-linux-gnu/4.6/lto-wrapper
Target: i686-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu/Linaro 4.6.3-1ubuntu5' --with-bugurl=file:///usr/share/doc/gcc-4.6/README.Bugs [^] --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.6 --enable-shared --enable-linker-build-id --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.6 --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --enable-gnu-unique-object --enable-plugin --enable-objc-gc --enable-targets=all --disable-werror --with-arch-32=i686 --with-tune=generic --enable-checking=release --build=i686-linux-gnu --host=i686-linux-gnu --target=i686-linux-gnu
Thread model: posix
gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5)
/usr/bin/dpkg
Found dpkg - running dpkg -l to grep libc6
ii libc6 2.15-0ubuntu10.4 Embedded GNU C Library: Shared libraries
ii libc6-dev 2.15-0ubuntu10.4 Embedded GNU C Library: Development Libraries and Header Files
Information about kde 4 at the time of compilation:
Qt: 4.8.1
KDE Development Platform: 4.8.5 (4.8.5)
kde4-config: 1.0
uname -a at runtime:
Linux linux-4qhx 3.11.10-7-desktop #1 SMP PREEMPT Mon Feb 3 09:41:24 UTC 2014 (750023e) x86_64 x86_64 x86_64 GNU/Linux
/etc/lsb-release not found
Information about kde 4 at runtime:
Qt: 4.8.5
KDE Development Platform: 4.11.5
kde4-config: 1.0
Information about kde 3 at runtime:
Qt: 3.3.8c
KDE: 3.5.10 "release 76"
kde-config: 1.0
INSTALL_DIR=/home/nikolaus/Dokumente/daskannmannvielleichtbaldloeschen/kdenlive/kdenlive
PATH=/home/nikolaus/Dokumente/daskannmannvielleichtbaldloeschen/kdenlive/kdenlive/bin:/sbin:/bin:/usr/sbin:/usr/bin:/home/nikolaus/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/opt/kde3/bin
LD_LIBRARY_PATH=/home/nikolaus/Dokumente/daskannmannvielleichtbaldloeschen/kdenlive/kdenlive/lib:/home/nikolaus/Dokumente/daskannmannvielleichtbaldloeschen/kdenlive/kdenlive/lib/frei0r-1:
MLT_AVFORMAT_THREADS=
MLT_REPOSITORY=/home/nikolaus/Dokumente/daskannmannvielleichtbaldloeschen/kdenlive/kdenlive/lib/mlt
MLT_DATA=/home/nikolaus/Dokumente/daskannmannvielleichtbaldloeschen/kdenlive/kdenlive/share/mlt
MLT_PROFILES_PATH=/home/nikolaus/Dokumente/daskannmannvielleichtbaldloeschen/kdenlive/kdenlive/share/mlt/profiles
FREI0R_PATH=/home/nikolaus/Dokumente/daskannmannvielleichtbaldloeschen/kdenlive/kdenlive/lib/frei0r-1/:/usr/lib/frei0r-1:/usr/local/lib/frei0r-1:/opt/local/lib/frei0r-1
PKG_CONFIG_PATH=/home/nikolaus/Dokumente/daskannmannvielleichtbaldloeschen/kdenlive/kdenlive/lib/pkgconfig/:
KDEHOME=/home/nikolaus/Dokumente/daskannmannvielleichtbaldloeschen/kdenlive/kdenlive/.kde
KDEDIRS=/home/nikolaus/Dokumente/daskannmannvielleichtbaldloeschen/kdenlive/kdenlive
Running ldd /home/nikolaus/Dokumente/daskannmannvielleichtbaldloeschen/kdenlive/kdenlive/bin/kdenlive
    linux-gate.so.1 (0xf7794000)
    libkdeui.so.5 => not found
    libkio.so.5 => not found
    libknewstuff3.so.4 => not found
    libknotifyconfig.so.4 => not found
    libsolid.so.4 => not found
    libQtOpenGL.so.4 => /usr/lib/libQtOpenGL.so.4 (0xf7663000)
    libQtScript.so.4 => /usr/lib/libQtScript.so.4 (0xf73e2000)
    libQtSvg.so.4 => /usr/lib/libQtSvg.so.4 (0xf738e000)
    libQtGui.so.4 => /usr/lib/libQtGui.so.4 (0xf68c7000)
    libQtDBus.so.4 => /usr/lib/libQtDBus.so.4 (0xf6848000)
    libQtXml.so.4 => /usr/lib/libQtXml.so.4 (0xf6802000)
    libQtCore.so.4 => /usr/lib/libQtCore.so.4 (0xf6516000)
    libmlt.so.6 => /home/nikolaus/Dokumente/daskannmannvielleichtbaldloeschen/kdenlive/kdenlive/lib/libmlt.so.6 (0xf64e3000)
    libmlt++.so.3 => /home/nikolaus/Dokumente/daskannmannvielleichtbaldloeschen/kdenlive/kdenlive/lib/libmlt++.so.3 (0xf64c3000)
    libpthread.so.0 => /lib/libpthread.so.0 (0xf64a6000)
    libX11.so.6 => /usr/lib/libX11.so.6 (0xf636b000)
    libGLU.so.1 => /usr/lib/libGLU.so.1 (0xf62e3000)
    libGL.so.1 => /usr/X11R6/lib/libGL.so.1 (0xf61df000)
    libnepomuk.so.4 => not found
    libqjson.so.0 => not found
    libkdecore.so.5 => not found
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xf60f1000)
    libm.so.6 => /lib/libm.so.6 (0xf60ab000)
    libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xf608d000)
    libc.so.6 => /lib/libc.so.6 (0xf5edc000)
    libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xf5e4e000)
    libdl.so.2 => /lib/libdl.so.2 (0xf5e49000)
    libXrender.so.1 => /usr/lib/libXrender.so.1 (0xf5e3e000)
    libz.so.1 => /lib/libz.so.1 (0xf5e26000)
    libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xf5d1f000)
    libpng16.so.16 => /usr/lib/libpng16.so.16 (0xf5ce3000)
    libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xf5c91000)
    libSM.so.6 => /usr/lib/libSM.so.6 (0xf5c88000)
    libICE.so.6 => /usr/lib/libICE.so.6 (0xf5c6d000)
    libXi.so.6 => /usr/lib/libXi.so.6 (0xf5c5c000)
    libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xf5c51000)
    libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xf5c4b000)
    libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xf5c3f000)
    libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xf5c3a000)
    libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xf5bfe000)
    libXext.so.6 => /usr/lib/libXext.so.6 (0xf5beb000)
    libdbus-1.so.3 => /lib/libdbus-1.so.3 (0xf5b9e000)
    librt.so.1 => /lib/librt.so.1 (0xf5b95000)
    /lib/ld-linux.so.2 (0xf7795000)
    libxcb.so.1 => /usr/lib/libxcb.so.1 (0xf5b72000)
    libnvidia-tls.so.331.49 => /usr/lib/tls/libnvidia-tls.so.331.49 (0xf5b6d000)
    libnvidia-glcore.so.331.49 => /usr/lib/libnvidia-glcore.so.331.49 (0xf3928000)
    libpcre.so.1 => /usr/lib/libpcre.so.1 (0xf38be000)
    libffi.so.4 => /usr/lib/libffi.so.4 (0xf38b6000)
    libuuid.so.1 => /usr/lib/libuuid.so.1 (0xf38b0000)
    libexpat.so.1 => /usr/lib/libexpat.so.1 (0xf3886000)
    libXau.so.6 => /usr/lib/libXau.so.6 (0xf3882000)
Running gdb -batch -x /tmp/start-kdenlive.gdb.input.2KbyXdk9 --args /home/nikolaus/Dokumente/daskannmannvielleichtbaldloeschen/kdenlive/kdenlive/bin/kdenlive --nocrashhandler
set pagination off
set environment LANG = de_AT.UTF-8run
Missing separate debuginfo for /lib/ld-linux.so.2
Try: zypper install -C "debuginfo(build-id)=230297fa8574e10992d4b25239148cf7f5c9fdbb"
/home/nikolaus/Dokumente/daskannmannvielleichtbaldloeschen/kdenlive/kdenlive/bin/kdenlive: error while loading shared libraries: libkdeui.so.5: cannot open shared object file: No such file or directory
[Inferior 1 (process 18134) exited with code 0177]
bt
/tmp/start-kdenlive.gdb.input.2KbyXdk9:9: Error in sourced command file:
No stack.
(0009758)
vpinon (administrator)
2014-03-11 22:29

You need to download a x86_*64* archive
(0009759)
Nikinger (reporter)
2014-03-12 13:28

Sorry, what do you mean?

I install lsb and reinstall lsb-release so the missing file is not lose anymore.

(Linux linux-4qhx 3.11.10-7-desktop #1 SMP PREEMPT Mon Feb 3 09:41:24 UTC 2014 (750023e) x86_64 x86_64 x86_64 GNU/Linux
 /etc/lsb-release not found)

And i do reinstall libkde4, libkdecore4 and libqjson too save the problems with the other not founded files; but this doesnt help....!?

I also delete an old not serviced microcode package and do reinstall uncode-intel....
(0009760)
vpinon (administrator)
2014-03-12 17:43

You downloaded a kdenlive-ubuntu12.04-x86-20140311.tar.bz2
(download changed filename base konquerorp17664 instead of kdenlive-ubuntu12?)
You should have taken kdenlive-ubuntu12.04-x86_64-20140311.tar.bz2
(as your system is "x86_64 GNU/Linux")
x86 archive seems not far from working as you seem to have installed i386 base libs (this is their name in debian/ubuntu multiarch system, I don't know in your case), but coming to kde libs you don't have the 32b/64b mix (not recomended anyhow).

So download kdenlive-ubuntu12.04-x86_64-20140311.tar.bz2 and try again!
(0009761)
Nikinger (reporter)
2014-03-12 19:56

JEAH JEAH JEA
jipie jipie
YEAH

You are the greatest and I am so a big noop LOL

... I use Opera and it do not like this adress (http://builds.meltytech.com/kdenlive/latest.rss [^]) and do not download; with konqueror it starts to download immediately, there is no choice for different files and it renamed it; at least firefox helped....

Now it works; so I will have a long night; a lot of old project and new ideas, I want to do!!!!

But
last stupid question

This is a separate installation of kdenlive.
Is there a easy way to find the different between my original, to safe the problem on the 1st one, or how should I do?
:-)

realy a stupid question; I CAN LIVE with this solution
;-)


THANK YOU very very much!
(0009763)
vpinon (administrator)
2014-03-12 20:26

I don't know what you did with your manual builds; you mentioned "configure --prefix=/usr" so if you did a (sudo) "make install" you overwrote distro packaged files. MLT or ffmpeg itself got wrongly built and the system was not functional anymore.
Maybe deinstalling ffmpeg* / libav* and all dependent packages (incl MLT & kdenlive) and then reinstalling kdenlive with all requirements (incl ffmpeg & MLT) would come back to a functional kdenlive 0.9.6? Yet the built you installed includes bug fixes that can be interesting to keep until new release comes out & gets packaged (not soon)!

- Issue History
Date Modified Username Field Change
2014-01-20 18:43 Nikinger New Issue
2014-01-21 11:23 vpinon Issue Deleted: 0003207
2014-01-21 11:25 vpinon Note Added: 0009664
2014-01-21 18:45 Nikinger Note Added: 0009665
2014-02-13 23:15 vpinon Note Added: 0009693
2014-02-13 23:15 vpinon Assigned To => vpinon
2014-02-13 23:15 vpinon Status new => feedback
2014-02-16 19:47 Nikinger Note Added: 0009707
2014-02-16 19:47 Nikinger Status feedback => assigned
2014-02-16 19:49 Nikinger Note Added: 0009708
2014-02-16 19:56 Nikinger Note Added: 0009709
2014-02-17 16:04 vpinon Note Added: 0009711
2014-03-02 21:22 vpinon Note Added: 0009744
2014-03-02 21:22 vpinon Status assigned => feedback
2014-03-11 17:37 Nikinger Note Added: 0009756
2014-03-11 17:37 Nikinger Status feedback => assigned
2014-03-11 22:29 vpinon Note Added: 0009758
2014-03-12 13:28 Nikinger Note Added: 0009759
2014-03-12 17:43 vpinon Note Added: 0009760
2014-03-12 19:56 Nikinger Note Added: 0009761
2014-03-12 20:26 vpinon Note Added: 0009763
2014-03-12 20:26 vpinon Status assigned => resolved
2014-03-12 20:26 vpinon Resolution open => no change required


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker