Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000322KdenliveFile Loadingpublic2008-11-09 09:182009-03-08 16:07
Reportercinephiliac 
Assigned Toddennedy 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.2 
Summary0000322: Formats unsupported by ffmpg seem to crash Kdenlive rather than being blocked from opening in the first place
DescriptionIt seems that there's a number of file formats that Kdenlive doesn't support, *but* does allow to be opened, only to crash shortly after dragging them to the timeline.

Vob's are a good example of this (even non css scrambled ones). It's possible to add them as a clip and even to the timeline without a single complaint. Any kind of attempt to play them though instantly crashes Kdenlive.

This bug report is not about these file formats being unsupported, so much as being able to crash Kdenlive.

Specs are as follows:
Kdenlive was installed by Kdenlive Builder Wizard 0.6.1
Information about revisions of modules at the time of compilation:
ffmpeg: Revision: 15796 Last Changed Date: 2008-11-08 14:47:10 -0500 (Sat, 08 Nov 2008)
mlt: Revision: 1232 Last Changed Date: 2008-11-09 00:30:39 -0500 (Sun, 09 Nov 2008)
mlt++: Revision: 1232 Last Changed Date: 2008-11-06 00:32:23 -0500 (Thu, 06 Nov 2008)
kdenlive: Revision: 2637 Last Changed Date: 2008-11-08 19:32:25 -0500 (Sat, 08 Nov 2008)


Backtrace (for a vob crash) is attached.
Tagscrash, ffmpg, unsuported files
Build/Install MethodNot Applicable
Attached Filestxt file icon vob.crash.gdb.output.txt [^] (18,819 bytes) 2008-11-09 09:19 [Show Content]

- Relationships
related to 0000422closed Kdenlive will load bogus file as jpg 
related to 0000455closedddennedy Add a avi Clip (rendered by synfigstudio) 

-  Notes
(0000961)
madsdyd (administrator)
2008-11-09 11:52

I agree with the poster. I have not confirmed a crash, but I have a related issue that I think fits with this: kdenlive accepts everything as a clip, if it matches the patterns. Steps to reproduce:

- type this in a terminal "echo foo > test.jpg"
- add test.jpg to the list of clips: weird, huh? It does _not_ look healthy to me :-/

There should be a mechanism to check the validity of clips before accepting them on the timeline. Perhaps there already is, but this information gets lost somewhere in the kdenlive <=> mlt++ <=> mlt <=> ffmpeg chain.
(0001430)
ddennedy (developer)
2008-11-27 01:19

MLT, its avformat producer, and kdenlive already handle invalid files. Meaning, MLT and the avformat producer will safely fail to open a file, return an error value, and kdenlive displays a dialog with "Clip X is invalid, will be removed from project." Therefore, this bug report is too generic and non-specific

This is a bug about loading a particular piece of media. Unfortunately, the backtrace does not have meaningful information, and I can load VOBs just fine. Please change the subject line and see if you can extract a little bit of the VOB using dd and attach it.

Also, madsdyd's comment should be a separate bug report because it is a different type of media. That one I can reproduce.
(0001431)
ddennedy (developer)
2008-11-27 01:21

Needs sample media or better backtrace. Also, report on playability in inigo and change the summary.
(0001484)
timosi (reporter)
2008-12-02 16:02

I had the same problem when I tried to open a vob file from a dvd that contains the menu to the subsections. Actual video files from that dvd works fine. The file is >50M but I try to send it somehow if needed.
(0001488)
ddennedy (developer)
2008-12-02 18:52

I have some menu VOBs I will test with. This is not too surprising it may fail miserably at the moment, and it may be difficult to workaround because at first they look like legitimate files to ffmpeg. So, I might have to allow kdenlive to add them, but if the video fails to decode, just display the fallback white. I am not certain I want to actually try to decode the first usable frame to validate a file - that could take a while if it has to try to decode the entire file just to determine no frame is usable. (kdenlive is not the only application using MLT. I have commercial users that must be able to load very large playlists as quickly as possible.)
(0001950)
ddennedy (developer)
2008-12-28 23:38

I am able to open VTS_*_00.VOBs that are menus. I would like to close this issue now for being too vague. We should only accept future issues that are specific to a format/codec.
(0002040)
madsdyd (administrator)
2009-01-03 22:07

Agree with ddennedy - sample media is needed. :-(

Leave open for now, letting Cinephiliac get a chance to actually respond :-)
(0002274)
ddennedy (developer)
2009-01-28 20:25

I am resolving this as "no change" because it was partly "fixed" and the remainder too vague. We must require individual issues for specific formats.
(0002331)
xzhayon (developer)
2009-02-03 02:00

closing this since "We must require individual issues for specific formats"
(0002519)
madsdyd (administrator)
2009-03-08 16:07

As far as this issue was fixed (the pattern matching for some cases), it was in 0.7.2

- Issue History
Date Modified Username Field Change
2008-11-09 09:18 cinephiliac New Issue
2008-11-09 09:19 cinephiliac Tag Attached: crash
2008-11-09 09:19 cinephiliac Tag Attached: ffmpg
2008-11-09 09:19 cinephiliac Tag Attached: unsuported files
2008-11-09 09:19 cinephiliac File Added: vob.crash.gdb.output.txt
2008-11-09 11:52 madsdyd Note Added: 0000961
2008-11-09 11:52 madsdyd Status new => acknowledged
2008-11-09 11:52 madsdyd Build => 2638
2008-11-09 11:52 madsdyd Target Version => 0.7.1
2008-11-17 20:54 madsdyd Target Version 0.7.1 => future version
2008-11-27 01:19 ddennedy Note Added: 0001430
2008-11-27 01:21 ddennedy Note Added: 0001431
2008-11-27 01:21 ddennedy Status acknowledged => feedback
2008-11-30 22:22 madsdyd Relationship added related to 0000422
2008-12-02 16:02 timosi Note Added: 0001484
2008-12-02 18:52 ddennedy Note Added: 0001488
2008-12-12 05:02 cinephiliac Relationship added related to 0000455
2008-12-16 23:35 ddennedy Status feedback => assigned
2008-12-16 23:35 ddennedy Assigned To => ddennedy
2008-12-28 23:38 ddennedy Note Added: 0001950
2008-12-28 23:38 ddennedy Status assigned => feedback
2009-01-03 22:07 madsdyd Note Added: 0002040
2009-01-28 20:25 ddennedy Note Added: 0002274
2009-01-28 20:25 ddennedy Status feedback => resolved
2009-01-28 20:25 ddennedy Resolution open => no change required
2009-02-03 02:00 xzhayon Note Added: 0002331
2009-02-03 02:00 xzhayon Status resolved => closed
2009-03-08 16:07 madsdyd Build/Install Method => Not Applicable
2009-03-08 16:07 madsdyd Note Added: 0002519
2009-03-08 16:07 madsdyd Fixed in Version => 0.7.2
2009-03-08 16:07 madsdyd Target Version future version =>


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker