Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003251KdenliveMLTpublic2014-03-31 13:592014-08-01 16:57
Reporterttguy 
Assigned Tovpinon 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionsuspended 
Platform32 bit intel and alikeOSUbuntuOS Version12.04
Product Version 
Target VersionFixed in Version 
Summary0003251: program fails to start due to - Movit failed initialization
DescriptionWhen kdenlive is started you get a message:
Movit failed initialization

Initialization of OpenGL filters failed. Exiting.
and then kdenlive closes.
This is a duplicate of 0003231 which is reported resolved by using latest build from sunabs ppa. But I am reporting that using sunabs latest build does not resolve the issue for me.
Steps To ReproduceUpgrade kdenlive using sunabs bleeding edge ppa
which gives you:
libmovit2 1.1+git20140328.eb7b041e-0ubuntu0~sunab~precise1
melt 0.9.1+git20140328.6f8293d5-0ubuntu0~sunab~precise1
kdenlive 0.9.7+git20140329.d6992af3-0ubuntu0~sunab~precise1
frei0r 1.4.0+git20131020.10d8360f-0ubuntu0~sunab~precise1
Additional InformationDuplicate of 0003231: MLT's GLSL manager init crash - but that one is closed so I can not add this report.
TagsNo tags attached.
Build/Install Method3rd party package
Attached Filestxt file icon start_kdenlive_failure.txt [^] (12,893 bytes) 2014-03-31 22:58 [Show Content]
txt file icon startlog.txt [^] (11,592 bytes) 2014-04-30 00:04 [Show Content]
txt file icon ttguy_glixinfo.txt [^] (9,110 bytes) 2014-04-30 00:18 [Show Content]

- Relationships

-  Notes
(0009869)
ttguy (updater)
2014-03-31 23:00

I get same result from a download of the daily builds and if I compile kdenlive myself using the build script. Build script reported "everything succeeded"
I have attached the console output from the starting of kdenlive from my build.
(0009878)
Sesse (developer)
2014-04-01 16:58

Hi,

Can you paste the output of glxinfo?
(0009881)
tadis (reporter)
2014-04-01 20:26

Same problem for me too.

glxinfo output here:
http://pastebin.com/raw.php?i=qscvJkKS [^]
(0009882)
Sesse (developer)
2014-04-01 20:31

glxinfo looks fine. Your MLT is compiled with --enable-opengl, right?
(0009883)
tadis (reporter)
2014-04-01 20:43

I did not try to compile. This problem exists with daily build on very fresh install of ubuntu 14.04 and ubuntu 13.10.

Maybe _ttguy_ could provide info how he compiled MLT.
(0009884)
varchar (reporter)
2014-04-01 20:48

Go here => 0003237 and vote for Movit optionality. In current state Kdenlive unusable for simplest tasks without GPU-powered powerpoint-like effects...
(0009909)
ttguy (updater)
2014-04-03 15:09

I compiled using an unmodified version of the build script from here http://www.mltframework.org/twiki/bin/view/MLT/BuildScripts#Kdenlive [^]
I have reverted my system back to an earlier sunab version to get kdenlive back working.
(0009913)
Sesse (developer)
2014-04-03 23:14

FWIW, I just pushed a change so that if Movit fails initialization, it will now tell you on stderr. (If MLT is compiled without Movit support, it still won't say anything.)
(0009944)
tadis (reporter)
2014-04-06 16:12
edited on: 2014-04-06 16:14

Daily build 20140405

QApplication: Object event filter cannot be in a different thread.
QApplication: Object event filter cannot be in a different thread.
...
QApplication: Object event filter cannot be in a different thread.
QApplication: Object event filter cannot be in a different thread.
QApplication: Object event filter cannot be in a different thread.
kdenlive: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
QtDBus: cannot relay signals from parent QObject(0x5c0b9c0 "") unless they are emitted in the object's thread QThread(0x1c3f3d0 ""). Current thread is QThread(0x7fbed8000c00 "").
KCrash: Application 'kdenlive' crashing...
...
./start-kdenlive: line 115: 32336 Terminated kdenlive "${kdenlive_args[@]}"

(0009946)
Sesse (developer)
2014-04-06 22:30

So, I took a look at the build script, and it's missing --enable-opengl. No wonder you don't have Movit then? :-)

Closing as invalid.
(0010004)
ttguy (updater)
2014-04-24 15:46
edited on: 2014-04-29 16:07

If the daily builds build a version that fails to run then this is a defect. It is not an invalid bug report to report that the daily build is not working (IMO). The fix is to fix the daily build.
According to MLT http://www.mltframework.org [^] Brian Matherly has fixed the build script and TheDiveO has got working for himself.
I however get this error when running the latest daily build
$ ./start-kdenlive
Way to run = Normal
running kdenlive
./start-kdenlive: line 218: /home/ttguy/kdenlive/./bin/kdenlive: cannot execute binary file

Edit: It turns out that this fail to execute was because I downloaded the 64bit build to a 32 bit system - whoops. I have now upgraded to a 64bit ubuntu 14.04 but the "movit failed initialization" remains an issue.

(0010005)
Sesse (developer)
2014-04-24 15:57

Sure, it's a bug in the build script. But Kdenlive does not support these build scripts as far as I know, so reporting them as a bug in Kdenlive (in Kdenlive's build tracker) is not very useful.
(0010006)
ttguy (updater)
2014-04-24 16:20

You might be right about non-support of build scripts.
But my experience has found this issue also occurring for me in sunabs PPA. Maybe he did not build his PPA versions properly either. And maybe this issue only happens under certain configurations of Linux. But it does represent a reasonably common issue - reported by quite a few. So I think it needs some looking into before the next stable release of Kdenlive.
(0010007)
Sesse (developer)
2014-04-24 16:29

Well, what exactly do you want Kdenlive to do? It can't magically add support if you didn't compile it into MLT.
(0010010)
ttguy (updater)
2014-04-25 13:12

I don't know much about the ins and outs of packaging software for linux. But for average joe users like me we just expect to be able to point our package manager at a new stable release of the kdenlive package and the package manager should install a working kdenlive and its dependencies.

Average joes like me don't compile our own software. We install it from repositories or download precompiled builds etc.

I guess this probably comes down to a packaging issue. So I guess that problem falls to the package maintainers.
(0010012)
norms2 (reporter)
2014-04-25 17:35

From the download page of Kdenlive.org

Getting the last development version of Kdenlive

1. Then add sunab's experimental PPA:

2 - Build script - MLT's website

3 - Daily Builds - http://build.mltframework.org/overview.html?guest=1 [^]

Seems silly having all these on the Kdenlive.org web site if they are not supported.

Anyway, sunab's ppa still crashes out as mention here:-

http://forum.kde.org/viewtopic.php?f=269&t=120251 [^]
(second from bottom)
(0010016)
ttguy (updater)
2014-04-30 00:03
edited on: 2014-04-30 13:19

So I am now on Ubuntu 14.04 64 bit. And I have used the build script
http://www.mltframework.org/twiki/bin/view/MLT/BuildScripts#Kdenlive [^]
and modified the config section for mlt to add --enable-opengl
It builds. But is still gets "Initialization of OpenGL filters failed. Exiting."
#####
  # mlt
  CONFIG[1]="./configure --prefix=$FINAL_INSTALL_DIR --enable-gpl --enable-debug --enable-opengl"

Stderr from the start of kdenlive is attached as startlog.txt

my glxinfo attached as ttguy_glixinfo.txt

(0010017)
ttguy (updater)
2014-04-30 16:19

should I expect to see a movit binary in my kdenlive/bin folder after my build ?
I have
ffmpeg ffplay ffprobe kdenlive kdenlive_env kdenlive_render melt x264

in ~/kdenlive/20140430/bin
(0010024)
vpinon (administrator)
2014-05-09 00:05

hello ttguy,
movit is a lib, so in [build_path]/lib/libmovit.so.*
... but looking at your glxinfo it seems that your GPU is not powerful enough, just like mine.
For that reason I have pulled all the new stuff except GLSL (sorry Sesse:/) in the branch "next". A 0.9.6.x bugfix release should come from this.
I am also planning to at last make "master" also able to work even if movit fails to start.
(0010056)
ttguy (updater)
2014-05-21 16:55

Installed 0.9.8 and it works. No Movit failed initialization errors. So we can close this
(0010058)
vpinon (administrator)
2014-05-21 23:07

I prefer to let it open, because 0.9.8 is a branch from just before Movit integration, but master (future 0.10?) still leads to the same weakness.
I changed the movit fail to warning instead of fatal error, but not finished, and I have no more time for 2 weeks...
Still lots of things to do to get master stable (OpenGL monitor), so I will also continue to support 0.9 (still far from perfect).
(0010069)
varchar (reporter)
2014-06-04 02:38

vpinon, your accept donation? I finnished my work and wanna give a bit espetially to your.
(0010146)
vpinon (administrator)
2014-08-01 16:57

unfinished movit developments have been moved to a side branch, hopefully will come back soon in stable version. It will be submitted for testing when useable again ;-)

- Issue History
Date Modified Username Field Change
2014-03-31 13:59 ttguy New Issue
2014-03-31 22:58 ttguy File Added: start_kdenlive_failure.txt
2014-03-31 23:00 ttguy Note Added: 0009869
2014-04-01 16:58 Sesse Note Added: 0009878
2014-04-01 20:26 tadis Note Added: 0009881
2014-04-01 20:31 Sesse Note Added: 0009882
2014-04-01 20:43 tadis Note Added: 0009883
2014-04-01 20:48 varchar Note Added: 0009884
2014-04-03 15:09 ttguy Note Added: 0009909
2014-04-03 23:14 Sesse Note Added: 0009913
2014-04-06 16:12 tadis Note Added: 0009944
2014-04-06 16:14 tadis Note Edited: 0009944 View Revisions
2014-04-06 22:30 Sesse Note Added: 0009946
2014-04-06 22:31 Sesse Status new => resolved
2014-04-06 22:31 Sesse Resolution open => no change required
2014-04-06 22:31 Sesse Assigned To => Sesse
2014-04-24 15:46 ttguy Note Added: 0010004
2014-04-24 15:46 ttguy Status resolved => feedback
2014-04-24 15:46 ttguy Resolution no change required => reopened
2014-04-24 15:57 Sesse Note Added: 0010005
2014-04-24 16:20 ttguy Note Added: 0010006
2014-04-24 16:20 ttguy Status feedback => assigned
2014-04-24 16:29 Sesse Note Added: 0010007
2014-04-25 13:12 ttguy Note Added: 0010010
2014-04-25 17:35 norms2 Note Added: 0010012
2014-04-29 16:07 ttguy Note Edited: 0010004 View Revisions
2014-04-30 00:03 ttguy Note Added: 0010016
2014-04-30 00:04 ttguy File Added: startlog.txt
2014-04-30 00:18 ttguy File Added: ttguy_glixinfo.txt
2014-04-30 00:19 ttguy Note Edited: 0010016 View Revisions
2014-04-30 13:19 ttguy Note Edited: 0010016 View Revisions
2014-04-30 16:19 ttguy Note Added: 0010017
2014-05-09 00:05 vpinon Note Added: 0010024
2014-05-21 16:55 ttguy Note Added: 0010056
2014-05-21 22:57 vpinon Assigned To Sesse => vpinon
2014-05-21 23:07 vpinon Note Added: 0010058
2014-06-04 02:38 varchar Note Added: 0010069
2014-08-01 16:57 vpinon Note Added: 0010146
2014-08-01 16:57 vpinon Status assigned => resolved
2014-08-01 16:57 vpinon Resolution reopened => suspended


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker