Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003324KdenliveFile Loadingpublic2014-06-17 06:552014-09-24 14:06
Reporterevorster 
Assigned Tovpinon 
PrioritynormalSeverityminorReproducibilityalways
StatusassignedResolutionreopened 
PlatformX86_64OSArch LinuxOS VersionRolling release
Product Version0.9.8 
Target VersionFixed in Version0.9.10 
Summary0003324: Picture import out of sequence
DescriptionI have noticed this bug for a few releases already. It's not major, but still it's there.
Every time a Image Sequence is imported, the very first frame is added to the end of the clip, and the rest of the frames are insterted in the proper order.
This is especially noticeable on the GoPro time-lapse feature, as it only stores about 500 frames in each sub-directory.
Steps To Reproduce1. Import image sequence as a clip.
2. Add clip to timeline.
3. Look at the first and last frame of the clip, they are the same, or at least ajacent in the time series.
Additional InformationThe workaround for me has always been to just delete the last frame from the clip, so no biggie. However, it would look much more professional if this step was not necessary.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships
duplicate of 0003289resolvedvpinon Slideshow adds an additional frame 

-  Notes
(0010361)
evorster (reporter)
2014-09-23 09:15

Just pulled a git version with this supposed fix.

The issue is still not resolved. For some reason, the first frame is duplicated at the end of the imported sequence.

2014-09-23.
(0010367)
vpinon (administrator)
2014-09-23 19:40

did you build from source or use nightly builds? I the latter case, maybe the commit was not propagated yet (I wait some time between commit and push), and we should wait for the next build… can you recheck tomorrow?
(0010373)
evorster (reporter)
2014-09-24 14:06

Hi there...

I built from git. I pulled from git again today, and can confirm that the issue is still there.

I can also confirm that the last and first frame of the imported image sequence are exactly the same frame.

kdenlive also identifies itself as version 0.9.10, which is a commit that has been applied after the fix for this issue.

A quick way to test this for yourself would be to make an image sequence from a short clip with:

ffmpeg -i <input.mp4> -an -f image2 output_%05d.jpg

Replacing <input.mp4> with the name of the actual clip, of course. That should result in an image sequence that you can easily import into kndelive.

Thanks!

- Issue History
Date Modified Username Field Change
2014-06-17 06:55 evorster New Issue
2014-09-22 16:06 vpinon Relationship added duplicate of 0003289
2014-09-22 16:06 vpinon Status new => resolved
2014-09-22 16:06 vpinon Fixed in Version => 0.9.10
2014-09-22 16:06 vpinon Resolution open => fixed
2014-09-22 16:06 vpinon Assigned To => vpinon
2014-09-23 09:15 evorster Note Added: 0010361
2014-09-23 09:15 evorster Status resolved => feedback
2014-09-23 09:15 evorster Resolution fixed => reopened
2014-09-23 19:40 vpinon Note Added: 0010367
2014-09-24 14:06 evorster Note Added: 0010373
2014-09-24 14:06 evorster Status feedback => assigned


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker