Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003344KdenliveRenderingpublic2014-08-05 00:092014-08-08 20:47
Reporteraxdoom 
Assigned Tovpinon 
PrioritynormalSeverityfeatureReproducibilityalways
StatusresolvedResolutionno change required 
PlatformLinuxOSMintOS Version16
Product Version0.9.6 
Target VersionFixed in Version0.9.8 
Summary0003344: Add support to encode projects in the .mkv container format (Matroska)
DescriptionI have tried to save my videos using the Matroska container. A profile that allows to do so is not available so I had to do it myself. On the forums, I have read that Kdenlive only allows to import or transcode video in the MKV format.

http://i.imgur.com/bmkItnX.png [^]
I am trying to encode my videos to the MKV format with H.264 video encoding and using OGG for the audio. MKV is open-source and a very popular video format that allows much more than the MP4 format without being encumbered by patents.

My problem is that MP4 doesn't support OGG for audio, and MKV allows this mix (H.264 + Ogg), so it is very useful to save on storage space and get the best quality possible.

Ogg gives the best audio quality at a lower bit-rate than any other formats (e.g.: Ogg 128 Kbits is equivalent to a 320Kbits MP3 file in terms of sound quality).

Please consider adding a Matroska profile to make things easier so people can take advantage of this.

Thanks,
Alexandre-Xavier
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Filespng file icon Kden-mkv.png [^] (144,608 bytes) 2014-08-05 00:09

- Relationships
related to 0003133assignedvpinon unable to download new render profiles 

-  Notes
(0010155)
vpinon (administrator)
2014-08-05 07:16

Thanks for sharing your profile.
There used to be a sharing function, lost due to site problems (see attached bug 3133). I will try to re-enable this soon.

I did a big profiles cleaning and leaved rather few combinations by default to avoid confusing average users (Gnome style ;-) ).

If you are concerned by open formats, I think webm is then you best choice: it is actually based on Matroska container and Vorbis audio codec (Ogg being a container actually, often containing Vorbis audio data) + VP8 patent-free video codec, fighting against proprietary H264 (see the HTML5 video tag war). Ogg/Theora is also around, but of lower video performance.
(0010164)
axdoom (reporter)
2014-08-05 13:19

H.264 has a little better quality than VP8 (VP8 is missing some features that allows better compression with less quality degradation) and H.264 files are a bit smaller. It has hardware decoding on most systems (including the Raspberry Pi), that is why I prefer it to Google's WebM.

I have to store a complete video tape collection to my hard-drive, video quality and space saving are important. The MP4 format doesn't allow me to do what I want to do. That is using the OGG format for my sound.
(0010193)
vpinon (administrator)
2014-08-05 23:52

I will not be following everyone's taste by default, but will re-enable profiles sharing
(0010205)
axdoom (reporter)
2014-08-06 02:30

And add support to export videos to the .mkv format?

It's not clear. I don't need profile sharing, but I need Kdenlive to be able to export to the .mkv format. Currently, it's not able to do so (http://i.imgur.com/bmkItnX.png [^]), it's says it's unsupported.

Thanks in advance for more clarifications,
Alexandre-Xavier
(0010206)
vpinon (administrator)
2014-08-06 08:48

ah, really sorry, I went a bit too fast and didn't catch your problem!
it's "f=mkv" that should be "f=matroska", but actually useless: the moment your have "mkv" in Extension field the encoder smartly guesses the format you want ;-)

is it working then?

(+side remark: not sure but I think many of the settings you specify to x264 are default values or don't change much, and you could also use FFmpeg & MLT presets...)
(0010210)
axdoom (reporter)
2014-08-08 00:43

I used the H.264 profile to create my Matroska profile.

It's "f=mkv" that caused to problem, thanks for your help resolving this issue.
Now it works fine: http://i.imgur.com/zkCTLgW.png [^]

Thanks again,
Alexandre-Xavier
(0010211)
vpinon (administrator)
2014-08-08 20:47

right, you use the 0.9.6 and profiles are simplified in 0.9.8... but doesn't matter you get similar results.

- Issue History
Date Modified Username Field Change
2014-08-05 00:09 axdoom New Issue
2014-08-05 00:09 axdoom File Added: Kden-mkv.png
2014-08-05 07:05 vpinon Relationship added related to 0003133
2014-08-05 07:16 vpinon Note Added: 0010155
2014-08-05 07:16 vpinon Assigned To => vpinon
2014-08-05 07:16 vpinon Status new => acknowledged
2014-08-05 13:19 axdoom Note Added: 0010164
2014-08-05 23:52 vpinon Note Added: 0010193
2014-08-05 23:52 vpinon Status acknowledged => resolved
2014-08-05 23:52 vpinon Resolution open => no change required
2014-08-06 02:30 axdoom Note Added: 0010205
2014-08-06 02:30 axdoom Status resolved => feedback
2014-08-06 02:30 axdoom Resolution no change required => reopened
2014-08-06 08:48 vpinon Note Added: 0010206
2014-08-08 00:43 axdoom Note Added: 0010210
2014-08-08 00:43 axdoom Status feedback => assigned
2014-08-08 20:47 vpinon Note Added: 0010211
2014-08-08 20:47 vpinon Status assigned => resolved
2014-08-08 20:47 vpinon Fixed in Version => 0.9.8
2014-08-08 20:47 vpinon Resolution reopened => no change required


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker