Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000345KdenliveRenderingpublic2008-11-12 12:062011-06-11 08:49
Reporterjmpoure 
Assigned Tomadsdyd 
PrioritynormalSeverityfeatureReproducibilityalways
StatusassignedResolutionopen 
PlatformDebianOSGNU/LinuxOS VersionSID
Product Version 
Target VersionFixed in Version 
Summary0000345: Capture inigo error to log or screen
DescriptionHello,

My source file was a 15fps screencast.
I am testing export profiles and modigfying them.

When testing mpeg2ts export profile using ffmpeg command lines,
ffmeg sent the error "Mpeg2 cannot handle 15fps".


This would be interesting to be able to capture inigo errors related to ffmpeg.
For users, this would be quite usefull.

For example, you understand that a 15fps screencast cannot be exported to DVD.

Kind regards,
Jean-Michel
Tagsold
Build/Install MethodBuild Wizard
Attached Files

- Relationships

-  Notes
(0001160)
madsdyd (administrator)
2008-11-12 16:58

Is this reported from inigo in some way?
(0001168)
madsdyd (administrator)
2008-11-12 22:24

Missed 0.7.0 on this one
(0001581)
ddennedy (developer)
2008-12-08 23:01

The MLT consumer_avformat needs to be more verbose, but right now MLT does not have a logging facility. So, regardless if kdenlive_render decides to use lib or inigo, messages will go to stderr. I could add a properties list to the consumer that holds multiple errors if kdenlive_render decides to go with the lib interface.
(0001605)
cinephiliac (updater)
2008-12-10 22:11

Changing to acknowledged as this doesn't seem to be waiting for any user feedback.
(0001768)
jmpoure (developer)
2008-12-17 22:47

I think we can turn it into feature request. Low urgency.
(0001825)
madsdyd (administrator)
2008-12-20 18:24

I have added some logging functionality to svn rev 2810.

I do not have a way to provoke ffmpeg errors, so I am not totally sure it works for all ffmpeg errors.

The intention with the logging is mostly to allow resolving the issues we may have with people filing "Preview is fine, but my rendered file is empty/broken". We have had a few of these on irc lately, and we really lack the information needed to help them resolve it.

So, command line parameters and content of westly is logged, as well as *all* output to sterr.

jmpoure, please test if possibly and if it is enough to close this issue.
(0001923)
madsdyd (administrator)
2008-12-23 21:32

After talking to jb, it is clear that we need to show some kind of dialog if the render process fails.

The only question is really if we should kdialog for this, or create a dialog ourselves.

Currently kdialog is actually used, but is not required by Kdenlive...

Also, kdialog is not good at showing large files, it is *extremely* slow in showing them. So, if the log grows due to a large number of frames prior to failure, it will be very slow in opening.

Assigned to me - I will do a followup, after talking to jb.
(0003521)
jmpoure (developer)
2009-06-29 10:16

Closing bug.
(0003529)
xzhayon (developer)
2009-06-29 12:44

actually, this is still active... mads made some changes days ago, and he plans to do some more

- Issue History
Date Modified Username Field Change
2008-11-12 12:06 jmpoure New Issue
2008-11-12 12:07 jmpoure Description Updated
2008-11-12 16:58 madsdyd Note Added: 0001160
2008-11-12 16:58 madsdyd Status new => feedback
2008-11-12 22:24 madsdyd Note Added: 0001168
2008-11-12 22:24 madsdyd Target Version 0.7.0 => 0.7.1
2008-11-12 22:40 madsdyd Target Version 0.7.1 => Recent git
2008-12-08 23:01 ddennedy Note Added: 0001581
2008-12-10 22:11 cinephiliac Build/Install Method => Build Wizard
2008-12-10 22:11 cinephiliac Note Added: 0001605
2008-12-10 22:11 cinephiliac Status feedback => acknowledged
2008-12-17 22:47 jmpoure Note Added: 0001768
2008-12-17 22:48 jmpoure Severity minor => feature
2008-12-17 22:48 jmpoure Target Version Recent git => future version
2008-12-20 18:24 madsdyd Note Added: 0001825
2008-12-23 21:29 madsdyd Status acknowledged => assigned
2008-12-23 21:29 madsdyd Assigned To => madsdyd
2008-12-23 21:32 madsdyd Note Added: 0001923
2009-06-26 21:13 administrator Target Version future version => 0.7.5
2009-06-29 10:16 jmpoure Note Added: 0003521
2009-06-29 10:16 jmpoure Status assigned => resolved
2009-06-29 10:16 jmpoure Resolution open => fixed
2009-06-29 12:44 xzhayon Note Added: 0003529
2009-06-29 12:45 xzhayon Status resolved => assigned
2009-06-29 12:45 xzhayon Resolution fixed => open
2009-06-29 12:45 xzhayon Target Version 0.7.5 => future version
2011-06-11 08:49 Granjow Tag Attached: old


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker