Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000346KdenliveBuild Systempublic2008-11-13 06:382008-12-29 15:37
Reporterfundawang 
Assigned Tomadsdyd 
PrioritynormalSeveritytrivialReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.7.0 
Target Version0.7.1Fixed in Version0.7.1 
Summary0000346: kdenlive 0.7 acturally uses avcodec, but to find avformat
DescriptionActurally, kdenlive 0.7 should be link against libavcodec, but it is finding libavformat.

kdelibs4 already provides FindFFmpeg.cmake module, maybe you can just use it to find FFmpeg package.
Additional Informationhttp://svn.mandriva.com/cgi-bin/viewvc.cgi/packages/cooker/kdenlive/current/SOURCES/kdenlive-kde4-fix-underlink.patch [^]
TagsNo tags attached.
Build/Install Method
Attached Files

- Relationships

-  Notes
(0001170)
madsdyd (administrator)
2008-11-13 09:08

I am not sure kdenlive uses avcodec directly? It uses mlt for this, I think.
(0001171)
fundawang (reporter)
2008-11-13 09:12

src/renderer.cpp:

if (avcodec_find_decoder(codec_context->codec_id) == NULL)
(0001172)
madsdyd (administrator)
2008-11-13 09:21

Good point from reporter.

Acknowledging for 0.7.1: Something is missing/wrong.

We should make sure to use the same ffmpeg installation as mlt though.
(0001843)
ddennedy (developer)
2008-12-21 08:36

It uses libavformat, which implies libavcodec. The description is strange; it actually looks like a complaint about underlinking, not linking avcodec as well.

In any case, this is the only place I found where kdenlive is using FFmpeg libs, and it is doing it to get metadata about a media file - streams descriptions. It seems this is something I should enhance within MLT so kdenlive does not need to directly use these libs. I will work on that because it helpful in general, not just to kdenlive.
(0001844)
madsdyd (administrator)
2008-12-21 10:24

OK, I am not sure I actually understand what exactly is the issue here. But, my understanding is that a packager has noted a dependency that is not explicit in the kdenlive CMakeList.txt file, and provided a patch.

The patch makes this dependency explicit. It sounds to me as Dans suggestion is to "move" (reimplement) the functionality in MLT. This has several benefits, one of which is that the dependency would then be explicit in MLT.

Am I right?

I have refrained from actually patching the CMakeList.txt, because I wanted jb to have a look. I still do. I don't reckon that you (Dan) will add this to MLT before we want to release 0.7.1, so, should I just patch the CMakeList.txt file for now?
(0001873)
ddennedy (developer)
2008-12-21 19:34

Actually, I would like to get this change in for the 0.7.1 release. It should be easy, and would increase the ease of distro maintainers to accepting kdenlive - whether to reduce requirements or political reasons. I have already made changes in MLT to facilitate a DV, Vorbis, images only build (--avformat-no-codecs) along with a separate mlt-ffmpeg plugin (e.g. third party repo). Maybe I will get this (extra metadata) done today.
(0001874)
madsdyd (administrator)
2008-12-21 19:49

OK!

I *wont* apply the patch then, rather we (well, the cmake gurus and the kdenlive-get-meta-data gurus, both of which I suppose is jb?) will work on getting rid of the avcodec dependency, instead relying on MLT to do it.
(0001876)
ddennedy (developer)
2008-12-21 22:09

OK, this change is in mlt/producer_avformat (not yet producer_libdv, producer_vorbis, or image producers). Here is the example output:

    <property name="meta.media.nb_streams">2</property>
    <property name="meta.media.0.stream.type">video</property>
    <property name="meta.media.0.stream.frame_rate">29.970030</property>
    <property name="meta.media.0.stream.sample_aspect_ratio">1.212121</property>
    <property name="meta.media.0.codec.pix_fmt">yuv411p</property>
    <property name="meta.media.0.codec.sample_aspect_ratio">0.000000</property>
    <property name="meta.media.0.codec.name">dvvideo</property>
    <property name="meta.media.0.codec.long_name">DV (Digital Video)</property>
    <property name="meta.media.0.codec.bit_rate">28771229</property>
    <property name="meta.media.0.codec.profile">-99</property>
    <property name="meta.media.0.codec.level">-99</property>
    <property name="meta.media.1.stream.type">audio</property>
    <property name="meta.media.1.codec.sample_fmt">s16</property>
    <property name="meta.media.1.codec.sample_rate">48000</property>
    <property name="meta.media.1.codec.channels">2</property>
    <property name="meta.media.1.codec.name">pcm_s16le</property>
    <property name="meta.media.1.codec.long_name">signed 16-bit little-endian PCM</property>
    <property name="meta.media.1.codec.bit_rate">1536000</property>
    <property name="meta.media.1.codec.profile">-99</property>
    <property name="meta.media.1.codec.level">-99</property>
(0001878)
madsdyd (administrator)
2008-12-21 22:20

Thanks Dan.

I sure hope jb will have time for this now - otherwise I need to figure out
what exactly is needed to use this from Kdenlive! :-)
(0001884)
madsdyd (administrator)
2008-12-22 12:35

A patch from Dan has been commited to Kdenlive SVN rev. 2813.

I will try to test/confirm later today. Assigning to self.
(0001896)
madsdyd (administrator)
2008-12-22 21:07

This looks very much fixed in SVN rev. 2814.

Note to reporter, please note that Kdenlive no longer depends on avcodec/libffmpeg directly during compilation, only on MLT. (At least, that is how I understand it.).

- Issue History
Date Modified Username Field Change
2008-11-13 06:38 fundawang New Issue
2008-11-13 09:08 madsdyd Note Added: 0001170
2008-11-13 09:08 madsdyd Status new => feedback
2008-11-13 09:12 fundawang Note Added: 0001171
2008-11-13 09:21 madsdyd Note Added: 0001172
2008-11-13 09:21 madsdyd Severity major => trivial
2008-11-13 09:21 madsdyd Status feedback => acknowledged
2008-11-13 09:21 madsdyd Target Version => 0.7.1
2008-12-21 08:36 ddennedy Note Added: 0001843
2008-12-21 10:24 madsdyd Note Added: 0001844
2008-12-21 19:34 ddennedy Note Added: 0001873
2008-12-21 19:49 madsdyd Note Added: 0001874
2008-12-21 22:09 ddennedy Note Added: 0001876
2008-12-21 22:20 madsdyd Note Added: 0001878
2008-12-22 12:35 madsdyd Note Added: 0001884
2008-12-22 12:35 madsdyd Status acknowledged => assigned
2008-12-22 12:35 madsdyd Assigned To => madsdyd
2008-12-22 21:07 madsdyd Note Added: 0001896
2008-12-22 21:07 madsdyd Status assigned => resolved
2008-12-22 21:07 madsdyd Fixed in Version => Recent git
2008-12-22 21:07 madsdyd Resolution open => fixed
2008-12-29 15:36 madsdyd Fixed in Version Recent git => 0.7.1
2008-12-29 15:37 madsdyd Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker