Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000368KdenliveUser Interfacepublic2008-11-19 13:242008-12-29 15:52
Reporterelhoir 
Assigned Tomadsdyd 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target Version0.7.1Fixed in Version0.7.1 
Summary0000368: Dragging a clip "beyond the end" of the timeline should scroll the timeline
Descriptionas i dont know how to explai this in english, i have recorded a video explaining this, compared with another app (i used traverso for that)

btw, the video is recorded into kdenlive :-P
TagsNo tags attached.
Build/Install Method
Attached Files? file icon capture0000.ogv [^] (2,581,898 bytes) 2008-11-19 13:24

- Relationships

-  Notes
(0001255)
madsdyd (administrator)
2008-11-19 20:32

I understand this as a feature request: that dragging a clip "beyond the end" of the timeline should scroll the timeline. Please confirm.
(0001258)
madsdyd (administrator)
2008-11-19 20:52

Acknowledged as a feature request in future version.
(0001283)
cinephiliac (updater)
2008-11-20 16:26

This looks like it's meant to be addressed by revision 2717, however I don't seem to be able to get it to work as in the video. I'm on revision 2718.
(0001286)
madsdyd (administrator)
2008-11-20 17:33

Same experience as Cinephiliac; can't see any difference with commit 2717.

I am running under KDE 3.5.10 here, but I think Cinephiliac is on kde 4?
(0001337)
administrator (administrator)
2008-11-22 11:31

Strange, it works fine for me. Add a clip to timeline. Zoom until it takes more than the screen width, then try moving it towards one border of the timeline, and it will scroll timeline...
(0001339)
madsdyd (administrator)
2008-11-22 11:41

ok, when zoomed, clip dragging "sort of" work. I say sort of, because it is jerky and slow, compared to what I would have expected.

It does not work when non-zoomed. It this intentional?
(0001341)
administrator (administrator)
2008-11-22 11:50

I just made it slightly faster. It only works if you have a horizontal scrollbar that can be moved. It means that if you are at the end of your project it will not scroll anymore.
(0001347)
madsdyd (administrator)
2008-11-22 16:14

Ah, of course, it works whenever its actually possible to scroll. Thanks for the explanation.

Speed is better now.

It occurs that scrolling only takes place, if the user does not move the mouse. In fullscreen view, the scrolling pauses, if you move the mouse up and down. In non-fullscreen view, the scrolling pauses if the user move the mouse at all.

For true polish, it would be great if scrolling would occur whenever someone tries to drag the clip outside the timeline, regardless of they are able to hold the mouse still while dragging/scrolling the timeline.
(0001846)
madsdyd (administrator)
2008-12-21 10:48

I guess we do not get the full polish this time around :-).

Resolving.

- Issue History
Date Modified Username Field Change
2008-11-19 13:24 elhoir New Issue
2008-11-19 13:24 elhoir File Added: capture0000.ogv
2008-11-19 20:32 madsdyd Note Added: 0001255
2008-11-19 20:32 madsdyd Status new => feedback
2008-11-19 20:52 madsdyd Note Added: 0001258
2008-11-19 20:52 madsdyd Severity minor => feature
2008-11-19 20:52 madsdyd Status feedback => acknowledged
2008-11-19 20:52 madsdyd Target Version => future version
2008-11-19 20:52 madsdyd Summary timeline does not work correctly when a clip is larger than one screen => Dragging a clip "beyond the end" of the timeline should scroll the timeline
2008-11-20 16:26 cinephiliac Note Added: 0001283
2008-11-20 17:33 madsdyd Note Added: 0001286
2008-11-22 11:31 administrator Note Added: 0001337
2008-11-22 11:41 madsdyd Note Added: 0001339
2008-11-22 11:50 administrator Note Added: 0001341
2008-11-22 16:14 madsdyd Note Added: 0001347
2008-12-21 10:48 madsdyd Note Added: 0001846
2008-12-21 10:48 madsdyd Status acknowledged => resolved
2008-12-21 10:48 madsdyd Fixed in Version => Recent git
2008-12-21 10:48 madsdyd Resolution open => fixed
2008-12-21 10:48 madsdyd Assigned To => madsdyd
2008-12-29 15:36 madsdyd Fixed in Version Recent git => 0.7.1
2008-12-29 15:37 madsdyd Status resolved => closed
2008-12-29 15:52 madsdyd Target Version future version => 0.7.1


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker