Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000380KdenliveUser Interfacepublic2008-11-21 07:532009-07-01 21:55
ReporterLeHomard 
Assigned Toadministrator 
PrioritylowSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target Version0.7.5Fixed in Version0.7.5 
Summary0000380: Vertical timeline zoom
DescriptionThere should be a way to zoom vertically on the timeline, thus enabling to see more timelines at a time (zoom out) or making tweaks on effect timelines easier (zoom in). At the moment only a horizontal (or temporal) zoom is available.

It could be implemented in the interface the same way as the horizontal zomm, but with a vertical slider on the side and a shortcut like shift+mouse wheel.
Additional InformationHaving large clips seems to be mainly useful for displaying at the same time thumbnails of the video and the audio waveform. But when the video has no audio or if the audio is separated from audio (see issue 332 : http://www.kdenlive.org/mantis/view.php?id=332 [^] with wich I totally agree, because I think audio should always be separated from video) then it start to get difficult to see all the tracks, especially beacuse audio tracks are grouped together under the video tracks.
TagsNo tags attached.
Build/Install Method(select)
Attached Files

- Relationships
parent of 0000272closed Add or delete timeline track 
related to 0000514acknowledged Predefined zoom levels to ease precision editing 

-  Notes
(0001323)
madsdyd (administrator)
2008-11-21 08:55

Acknowledging as a feature request. I have made this a parent of 0000272 as it makes more and more sense as Kdenlive gets the ability to add more tracks (think having 10 video tracks and 5 audio tracks - not sure it even makes sense, but if someone has a good workflow using that, zoom would be great).

The thumbnail generating should probably be remade to generate either a mipmapped thumbnail for either multiple fixed resolution zooms, or to downscale from nearest suitable. Or something :-)
(0002363)
LeHomard (developer)
2009-02-05 15:38

I've just noticed the height of the tracks can actually be set in the Kdenlive settings...
Maybe the seeting should just be easier to see (somewhere on the main interface), and it would be even better to adjust the height of individual tracks...
(0002535)
el_jefe (reporter)
2009-03-12 15:41

I second (third?) this request; it would make volume keyframe adjustments a lot easier.
(0003293)
administrator (administrator)
2009-06-18 19:52

Implemented in svn rev. 3580 (there are 2 small icons above the track numbers to zoom in/out), feedback welcome
(0003358)
Granjow (developer)
2009-06-21 13:49

Very nice. I first thought it would be a limit to have only 3 steps. but it isn't.

I'd like the selected view to be stored in the .kdenlive file.
(0003439)
administrator (administrator)
2009-06-24 19:44

Vertical zoom is now saved in the document since svn rev. 3641

- Issue History
Date Modified Username Field Change
2008-11-21 07:53 LeHomard New Issue
2008-11-21 08:52 madsdyd Relationship added parent of 0000272
2008-11-21 08:55 madsdyd Note Added: 0001323
2008-11-21 08:55 madsdyd Priority normal => low
2008-11-21 08:55 madsdyd Status new => acknowledged
2008-11-21 08:55 madsdyd Target Version => future version
2008-11-21 08:55 madsdyd Additional Information Updated
2008-11-21 19:06 cinephiliac Summary Vertical imeline zoom => Vertical timeline zoom
2008-12-23 11:43 madsdyd Relationship added related to 0000514
2009-02-05 15:38 LeHomard Note Added: 0002363
2009-03-12 15:41 el_jefe Note Added: 0002535
2009-06-18 19:52 administrator Note Added: 0003293
2009-06-18 19:52 administrator Status acknowledged => feedback
2009-06-21 13:49 Granjow Note Added: 0003358
2009-06-21 13:50 Granjow Build/Install Method => (select)
2009-06-21 13:50 Granjow Assigned To => administrator
2009-06-24 19:44 administrator Note Added: 0003439
2009-06-24 19:44 administrator Status feedback => resolved
2009-06-24 19:44 administrator Fixed in Version => Recent git
2009-06-24 19:44 administrator Resolution open => fixed
2009-06-26 21:01 administrator Fixed in Version Recent git => 0.7.5
2009-06-26 21:07 administrator Fixed in Version 0.7.5 => Recent git
2009-06-26 21:07 administrator Target Version future version => 0.7.5
2009-07-01 20:02 j-b-m Fixed in Version Recent git => 0.7.5
2009-07-01 21:55 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker