Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000387KdenliveUser Interfacepublic2008-11-21 23:472010-02-20 08:16
Reportermadsdyd 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilitysometimes
StatusclosedResolutionfixed 
Platform32 bit intel and alikeOSKubuntu LinuxOS Version8.04
Product VersionRecent git 
Target VersionFixed in Version0.7.7 
Summary0000387: Crash when using I and O shortcuts on timeline
DescriptionI can reliably reproduce a crash in

ffmpeg: Revision: 15901 Last Changed Date: 2008-11-21 19:39:16 +0100 (fre, 21 nov 2008)
mlt: Revision: 1240 Last Changed Date: 2008-11-17 06:57:32 +0100 (man, 17 nov 2008)
mlt++: Revision: 1240 Last Changed Date: 2008-11-06 06:32:23 +0100 (tor, 06 nov 2008)
kdenlive: Revision: 2718 Last Changed Date: 2008-11-20 00:13:27 +0100 (tor, 20 nov 2008)
Qt: 4.4.1
KDE: 4.1.2 (KDE 4.1.2)
Kdenlive: 0.7

when using the I and O shortcuts on the timeline
Steps To Reproduce- start kdenlive
- load a clip
- place it on the timeline
- move the position indicator to, say 20% of the clip
- press I
- move the position indicator another, say 20% to the right
- press O: Instacrash.
Additional InformationCrash log attached.
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files? file icon kbw.gdb.output.ljT24020 [^] (19,735 bytes) 2008-11-21 23:47
txt file icon IO-keys-timeline-crash.txt [^] (63,488 bytes) 2008-11-22 04:32 [Show Content]
? file icon kbw.gdb.output.GUh10903 [^] (28,236 bytes) 2008-11-22 12:56

- Relationships

-  Notes
(0001333)
cinephiliac (updater)
2008-11-22 04:31

Confirmed on:
Kdenlive Builder Wizard version: 0.7.0
ffmpeg: Revision: 15905 Last Changed Date: 2008-11-21 19:29:49 -0500 (Fri, 21 Nov 2008)
mlt: Revision: 1240 Last Changed Date: 2008-11-17 00:57:32 -0500 (Mon, 17 Nov 2008)
mlt++: Revision: 1240 Last Changed Date: 2008-11-06 00:32:23 -0500 (Thu, 06 Nov 2008)
kdenlive: Revision: 2718 Last Changed Date: 2008-11-19 18:13:27 -0500 (Wed, 19 Nov 2008)
Qt: 4.4.3
KDE: 4.1.3 (KDE 4.1.3)
Kdenlive: 0.7

Backtrace attached.
(0001338)
administrator (administrator)
2008-11-22 11:37

I cannot reproduce that crash. It seems to be FFmpeg related. Can you give me the steps to reproduce the crash ? Does disabling video thumbnails solve the crash ?
(0001340)
madsdyd (administrator)
2008-11-22 11:44

These are the steps to reproduce

- start kdenlive
 - load a clip
 - place it on the timeline
 - move the position indicator to, say 20% of the clip
 - press I
 - move the position indicator another, say 20% to the right
 - press O: Instacrash.

(Off topic: I posted these in the "steps to reproduce? Are those not visible to you? I noted they are not actually visible when not logged in, which confused me).
(0001342)
administrator (administrator)
2008-11-22 11:53

No, I can't see any "steps to reproduce" information. By the way I cannot reproduce the crash with your infos. Did you make clean in FFmpeg recently (I remember that sometimes it was necessary or you can get some mysterious crashes)...
(0001343)
madsdyd (administrator)
2008-11-22 12:08

I'll try recompiling ffmpeg from scratch (delete the ffmpeg folder).

Re the steps to reproduce: It appears that you configuration settings for the manager account is set to "view simple" for the bugs view. For reasons unknown to me, mantis only shows the "step to reproduce" if you have checked "view advanced".

Several of our reporters submit information in the "steps to reproduce" box. I think it would be best if you checked "view advanced" for the administrator account, as to not miss this information.
(0001346)
madsdyd (administrator)
2008-11-22 12:56

OK, can still reproduce after a totally clean build of ffmpeg and clean builds of mlt, mlt++ and kdenlive from svn, but this time took me two tries to get a crash, with all thumbnails enabled.

I then disabled all thumbnails, and was unable to produce the crash in 8 tries.

Uploading new crash log, with

ffmpeg: Revision: 15905 Last Changed Date: 2008-11-22 01:29:49 +0100 (lør, 22 nov 2008)
mlt: Revision: 1240 Last Changed Date: 2008-11-17 06:57:32 +0100 (man, 17 nov 2008)
mlt++: Revision: 1240 Last Changed Date: 2008-11-06 06:32:23 +0100 (tor, 06 nov 2008)
kdenlive: Revision: 2720 Last Changed Date: 2008-11-22 11:48:29 +0100 (lør, 22 nov 2008)
(0004055)
j-b-m (administrator)
2009-10-02 13:04

This was fixed in MLT's git (avformat concurrency issue), and will be part of the next MLT release.

- Issue History
Date Modified Username Field Change
2008-11-21 23:47 madsdyd New Issue
2008-11-21 23:47 madsdyd File Added: kbw.gdb.output.ljT24020
2008-11-21 23:47 madsdyd Build/Install Method => Build Wizard
2008-11-22 04:31 cinephiliac Note Added: 0001333
2008-11-22 04:31 cinephiliac Status new => acknowledged
2008-11-22 04:32 cinephiliac File Added: IO-keys-timeline-crash.txt
2008-11-22 11:37 administrator Note Added: 0001338
2008-11-22 11:44 madsdyd Note Added: 0001340
2008-11-22 11:53 administrator Note Added: 0001342
2008-11-22 12:08 madsdyd Note Added: 0001343
2008-11-22 12:56 madsdyd Note Added: 0001346
2008-11-22 12:56 madsdyd File Added: kbw.gdb.output.GUh10903
2008-11-22 12:56 madsdyd Reproducibility always => sometimes
2009-10-02 13:04 j-b-m Note Added: 0004055
2009-10-02 13:04 j-b-m Status acknowledged => resolved
2009-10-02 13:04 j-b-m Fixed in Version => Recent git
2009-10-02 13:04 j-b-m Resolution open => fixed
2009-10-02 13:04 j-b-m Assigned To => j-b-m
2009-10-08 20:20 j-b-m Fixed in Version Recent git => 0.7.6
2010-02-02 10:35 j-b-m Fixed in Version 0.7.6 => 0.7.7
2010-02-20 08:16 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker