Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000390KdenliveEffectspublic2008-11-22 14:182008-12-29 15:37
Reporterdoitux 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.1 
Summary0000390: double click on selected volume-keyframe adds a new one
DescriptionWhen i try to double click on selected keyframe of volume-effect to edit the volume value a new keyframe is added. So i dont know how to edit volume-levels of a keyframe now :(
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0001349)
madsdyd (administrator)
2008-11-22 16:24

Why can't you just drag it around? That is click-and-hold instead of double-click?
(0001350)
cinephiliac (updater)
2008-11-22 16:39

I think that doitux wants to edit it numerically, which may be easier to get precision (eg a number of keys at the *eact* same volume). This is similar to how users can currently double click on a click to adjust clip position, duration and crop start, even though all of these things can be adjusted with the mouse on the timeline. Is this correct doitux?

If it is, to me it's valid, but a wishlist rather than a bug.
(0001351)
doitux (updater)
2008-11-22 18:27

I think it is a regression bug, because on 0.7 release double-click will open the enter-numerical-value dialog. This dialog doesnt appear now but a new keyframe is added.
(0001354)
cinephiliac (updater)
2008-11-23 04:48

You're absolutely right.
Double clicking volume keyframes in older versions brings up a numeric edit box, where newer versions just create a new key frame.


Furthermore I've managed to narrow it down to the day it changed:
=============
Bug doesn't exist in:
=============
ffmpeg: Revision: 15883 Last Changed Date: 2008-11-18 20:40:09 -0500 (Tue, 18 Nov 2008)
mlt: Revision: 1240 Last Changed Date: 2008-11-17 00:57:32 -0500 (Mon, 17 Nov 2008)
mlt++: Revision: 1240 Last Changed Date: 2008-11-06 00:32:23 -0500 (Thu, 06 Nov 2008)
kdenlive: Revision: 2716 Last Changed Date: 2008-11-19 06:13:31 -0500 (Wed, 19 Nov 2008)



=============
Bug exists in:
=============
ffmpeg: Revision: 15888 Last Changed Date: 2008-11-20 04:21:52 -0500 (Thu, 20 Nov 2008)
mlt: Revision: 1240 Last Changed Date: 2008-11-17 00:57:32 -0500 (Mon, 17 Nov 2008)
mlt++: Revision: 1240 Last Changed Date: 2008-11-06 00:32:23 -0500 (Thu, 06 Nov 2008)
kdenlive: Revision: 2718 Last Changed Date: 2008-11-19 18:13:27 -0500 (Wed, 19 Nov 2008)
(0001367)
administrator (administrator)
2008-11-23 20:36

Cannot reproduce. When I double click, I get the Kdeframe edit dialog with adjustable position and value...
(0001371)
cinephiliac (updater)
2008-11-23 22:55

Is this on the current revision JB? It only seems to have occurred since somewhere after 0002716.

Anyway, just in case it helps, here's the full list of the parts of my system still showing this problem:
Kdenlive Builder Wizard version: 0.7.0
ffmpeg: Revision: 15918 Last Changed Date: 2008-11-23 14:36:44 -0500 (Sun, 23 Nov 2008)
mlt: Revision: 1240 Last Changed Date: 2008-11-17 00:57:32 -0500 (Mon, 17 Nov 2008)
mlt++: Revision: 1240 Last Changed Date: 2008-11-06 00:32:23 -0500 (Thu, 06 Nov 2008)
kdenlive: Revision: 2722 Last Changed Date: 2008-11-23 14:34:31 -0500 (Sun, 23 Nov 2008)
Qt: 4.4.3
KDE: 4.1.3 (KDE 4.1.3)
Kdenlive: 0.7
(0001393)
madsdyd (administrator)
2008-11-24 21:30

Fix commited in 2726, tested, confirmed. Resolving.

- Issue History
Date Modified Username Field Change
2008-11-22 14:18 doitux New Issue
2008-11-22 14:18 doitux Build/Install Method => Manual build from SVN
2008-11-22 16:24 madsdyd Note Added: 0001349
2008-11-22 16:24 madsdyd Status new => feedback
2008-11-22 16:39 cinephiliac Note Added: 0001350
2008-11-22 18:27 doitux Note Added: 0001351
2008-11-23 04:48 cinephiliac Note Added: 0001354
2008-11-23 04:48 cinephiliac Status feedback => acknowledged
2008-11-23 20:36 administrator Note Added: 0001367
2008-11-23 22:55 cinephiliac Note Added: 0001371
2008-11-24 21:30 madsdyd Note Added: 0001393
2008-11-24 21:30 madsdyd Status acknowledged => resolved
2008-11-24 21:30 madsdyd Resolution open => fixed
2008-11-24 21:30 madsdyd Fixed in Version => Recent git
2008-12-29 15:36 madsdyd Fixed in Version Recent git => 0.7.1
2008-12-29 15:37 madsdyd Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker