Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000402KdenliveFile Loadingpublic2008-11-24 04:402008-12-29 15:37
Reporterxzhayon 
Assigned Tomadsdyd 
PrioritynormalSeverityminorReproducibilityrandom
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.1 
Summary0000402: problem while retrieving properties from kdenlive 0.5 project file producers
Descriptiontwo issues here:
1. while reloading clips using the manual search (not automatic because there's no hash and size in old projects, obviously) kdenlive cannot update <producer />'s resource (kdenlivedoc.cpp:1037), while this is working with new pfv... i think this is related to how convertDocument() exports producers
2. many of the converted <kdenlive_producer />s don't have video/audio properties, resulting in black standard 10min clips. below an example (same behavior if the files exist or not; same problem when automatic/manual search didn't exist)
Additional Informationdifference between broken and working kdenlive_producer (path is hidden, but no unusual character in it):

<kdenlive_producer file_size="103248000" groupid="152" groupname="chapter_1" file_hash="1d77f7b8eaac7cd95e694f89fb767033" type="3" id="88" resource="/home/albi/xxx/sc5_sq2_tk1.mpg.dv" />
  <kdenlive_producer audio_max="1" id="87" default_video="0" fps="25.000000" videocodec="DV (Digital Video)" resource="/home/albi/xxx/sc5_sq1_tk3.mpg.dv" default_audio="1" audiocodec="signed 16-bit little-endian PCM" duration="1713" groupid="152" file_hash="65b4c9cbfbd6d1d12457004d9dde2e29" aspect_ratio="1.422222" channels="2" frequency="48000" video_max="0" groupname="chapter_1" type="3" frame_size="720x576" file_size="246672000" />
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0001413)
xzhayon (developer)
2008-11-25 20:19

patch "document_conversion.svn2735_2.patch" attached to issue 358 seems to fix this problem (i can't test slideshows, but they should be ok)
(0001578)
madsdyd (administrator)
2008-12-08 20:42

Could you please test if newest SVN (2759 or newer) fixes this? It has the patch from 0000358.

If yes, I want to close this bug, and fix the outstanding stuff in 0000358 instead.
(0001645)
xzhayon (developer)
2008-12-14 20:54

problem fixed here, at least with the projects i have and with my last patch from 358
this is starting to be a duplicate of 358
(0001664)
madsdyd (administrator)
2008-12-15 11:10

One or more of the patches submitted in relation to 0000358 seems to have fixed this problem. So, resolving.

- Issue History
Date Modified Username Field Change
2008-11-24 04:40 xzhayon New Issue
2008-11-24 04:40 xzhayon Build/Install Method => Manual build from SVN
2008-11-25 20:19 xzhayon Note Added: 0001413
2008-12-08 20:42 madsdyd Note Added: 0001578
2008-12-08 20:42 madsdyd Status new => feedback
2008-12-14 20:54 xzhayon Note Added: 0001645
2008-12-15 11:10 madsdyd Note Added: 0001664
2008-12-15 11:10 madsdyd Status feedback => resolved
2008-12-15 11:10 madsdyd Fixed in Version => Recent git
2008-12-15 11:10 madsdyd Resolution open => fixed
2008-12-15 11:10 madsdyd Assigned To => madsdyd
2008-12-29 15:36 madsdyd Fixed in Version Recent git => 0.7.1
2008-12-29 15:37 madsdyd Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker